Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Remote KDE session?

  1. #1
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Remote KDE session?

    Is it possible to run a remote KDE session some how?
    I am running a test install of 13.1 Factory and want to use it as my main machine and then remote into my normal system so I can interact with what it's doing like transferring files, starting torrents and my IRC sessions.
    Is there a way to do this?

    Thanks

    Test machine
    Machine is a Dell Optiplex 755 with 3 gig of memory running KDE and 13.1 x64
    Tumbleweed

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,582
    Blog Entries
    14

    Default Re: Remote KDE session?

    Sure there's a way to do it, what makes it easy is that it's both openSUSE machines.

    On the remote:
    In Yast's softwaremanager select View-Patterns
    tick the Remote desktop pattern, perform the install
    Next use Yast - Network services - Remote desktop, don't forget to open the port in the firewall.

    On the client:
    install KRDC or another VNC viewer of your choice
    Use remote's IP address and port 5901 to connect. You'll see the login screen
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default Re: Remote KDE session?

    Hi Knurpht,

    if both machines are his own and running openSUSE with KDE, can't he do a "real" remote login?

    On the remote:
    In Yast's softwaremanager select View-Patterns
    tick the Remote desktop pattern, perform the install
    Next use Yast - Network services - Remote desktop, don't forget to open the port in the firewall.
    Plus: Create your user on the remote.

    On the client:
    KDE menue go to "logout" or "change user"
    choose "start new session"
    you should get into KDM menue to login
    type "alt + r" or click on the start icon and choose "remote login" all remote machines in your LAN that allow remote login will be listed.
    Choose your remote (e.g. double click on it) and there you are.
    If you did not log out of your old session, you can switch back and forth with "ctrl + alt + F7" / "ctrl + alt + F8"
    (Sorry if the English terms are not precise.)

    Or am I missing something about 13.1 not yet ready and remote X not available?

    Best regards

    kasi




  4. #4
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Remote KDE session?

    Method 2 seems to work except all the text is mirrored in reverse and I can't read it.

    I could not get KDRC to connect. (method one)

    I can't close the connection to the remote machine.

    The remote machine is running 12.3 and the client is running 13.1
    Bug?
    Tumbleweed

  5. #5
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Remote KDE session?

    The text is reversed too. I the input (mouse and keyboard) is wonky too.

    Tumbleweed

  6. #6
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default Re: Remote KDE session?

    Wow! I am using that method since years with the largest number of different openSUSE versions, never had that. I don't know if that is a bug or something about video driver etc.
    If you shutdown the client, that session will be killed. Can you switch to your old session? "ctrl+alt+F7?

  7. #7
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default Re: Remote KDE session?

    Probably it has got something to do with the resolution settings on the host? That the client's hardware can't cope?
    I am just guessing wildly. I have just tried a remote from my laptop (12.2) to my homeserver (11.2) without problems.
    I suspected kernelmodeset. My homserver doesn't have any xorg.conf file, so I can't tell if creating one would help.
    Can you somehow reduce the resolution on the host?

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,582
    Blog Entries
    14

    Default Re: Remote KDE session?

    Weird. Method 2 in my case crashes. No time to investigate atm. KRDC works fine (and fast) both LAN and WAN
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Remote KDE session?

    I too now suspect the differences in Video settings and systems.
    Client machine is running VESA framebuffer at an unknown resolution and host machine is running Nvidia binary blob at 1920X1080.
    Looking in KDE configure desktop on the client machine to see the reported resolution shows just VGA no dimensions given.

    Still trying to figure out why Knurpht's method seems to connect but there is no display at all.
    Anyway it;s not a show stopper for me. I have a KVM switch and the host machine has a cloned second monitor so I can watch what is going on; on that machine.

    Not sure this is a bug or incompatibility in hardware so I'll not report it as a bug against 13.1 beta 1.

    Thanks for your assistance.

    By the way I am not getting email notifications of post to threads I have started even though I am subscribed by default.
    Is this how the forum is currently working?
    Tumbleweed

  10. #10
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Remote KDE session?

    Quote Originally Posted by Knurpht View Post
    Weird. Method 2 in my case crashes. No time to investigate atm. KRDC works fine (and fast) both LAN and WAN


    OK Knurpht trying the KRDC method.

    Now I have configured a machine with the same version of openSUSE and the same graphics and driver.
    I enter the address of the host machine into KRDC likes so
    Code:
    192.168.1.100:5901
    I hit the arrow key.
    I see no login prompt.
    What am I doing wrong?

    I see the disconnect icon as if it's connected.
    Tumbleweed

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •