Results 1 to 9 of 9

Thread: Packagekit

  1. #1

    Angry Packagekit

    I have had this happen a couple of times. Try using yast software management or zypper and find it's blocked by packagekit even though I have no idea how this has been run. I suspect it's a kde thing.

    Any ideas on the quickest way to kill it. Maybe there is a lock file somewhere?

    What causes it?

    I notice right clicking an rpm doesn't offer open with yast any more and suspect this has something to do with it.

    Even better how to stop it ever happening again. I'm not very keen on kde getting in the way of installations.

    John
    -

  2. #2

    Default Re: Packagekit

    Looking at the replies to this problem I should point out that the repo log is blocked so can't run anything to un install it.

    Fix

    Code:
    ohn@linux-448o:~> ps -A | grep packagekitd
    12192 ?        00:00:55 packagekitd
    john@linux-448o:~> kill 12192
    bash: kill: (12192) - Operation not permitted
    john@linux-448o:~> su
    Password: 
    linux-448o:/home/john # kill 12192
    Then it can be uninstalled selecting option 1 from the problems YAST mentions.

    Suppose I should have switched to su before killing it.

    Now right clicking an rpm and selecting open with install/remove software shows a YAST command.

    Best and tidiest way to see what is running looks to be pstree
    ps -A is needed to get the process number to kill.

    John
    -

  3. #3
    Join Date
    Mar 2009
    Location
    Southern New Jersey
    Posts
    27

    Default Re: Packagekit

    I'm guess your running an older version. I had that issue a few versions ago and just uninstalled packagekit. The recent versions normally mention that packagekit has something locked and usually after clicking the yes option it gets pass the issue.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Packagekit

    If it bothers you, uninstall Apper. It's the desktop app triggering the packagekitd to refresh the repos, look for updates etc. in the backgroud of the desktop environment.
    But, apper has come a long way now, and I like it very much. My routine was to "Packages - All packages - Update if a newer version applicable" (if not using zypper from a terminal window). These days I use the apper-plasmoid, click "Review" to see which updates are available, click "Install" to perform the updates.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Packagekit

    As far as my 12.3 goes it's up to date and I knew about packagekit's periodic short run times. What seems to have happened is that it locked in permanently. I had wondered why no update reminders where popping up.

    I have had this happen a couple of times and previously fixed it by rebooting.

    I see some previous posts on the subject suggesting using the YAST ask packagekit to stop facility - well it doesn't stop.

    Out of interest I also have another problem that may be related over the last few reboots - an su log in pop up appears. Clicking cancel doesn't do anything either still comes up on the next reboot..

    I have a feeling that both problems are related to using the remember password facility in the install pop as I generally do not do that but on one occasion did. Hence wondered if anyone knew how the 3 facilities were locked. packagekit,zypper and yast.

    John
    -

  6. #6

    Default Re: Packagekit

    Quote Originally Posted by John_82 View Post
    As far as my 12.3 goes it's up to date and I knew about packagekit's periodic short run times. What seems to have happened is that it locked in permanently. I had wondered why no update reminders where popping up.
    AFAIK it could seem to have locked up if there are problems with some repos during refreshing.
    But "sudo killall -KILL packagekitd" should kill it in any case (packagekitd runs as root, so you need "sudo" or "su" to kill it).


    Out of interest I also have another problem that may be related over the last few reboots - an su log in pop up appears. Clicking cancel doesn't do anything either still comes up on the next reboot..

    I have a feeling that both problems are related to using the remember password facility in the install pop as I generally do not do that but on one occasion did.
    No, this can't be related to the "remember password" facility, this only remembers the password for a certain amount of time in the current session (5 minutes I think).
    I would press Ctrl+ESC when that su login dialog appears and have a look what gets started (well, the dialog should tell you what's going to be started as root, anyway).
    You could try to disable session management (Configure Desktop->Launch and Quit->Session Management) to see if that makes the dialog disappear.

  7. #7

    Default Re: Packagekit

    I should have noticed what was being launched and needed root password. Turns out to be Samsung's SmartPanel for my printer. It shows toner life and gives easy access to other aspects. I have made myself a member of lp which seems to keep CUPS happy and also changed permission of the file - owner root group lp and group execution rights. KDE auto start launches it as a task bar icon user me and group users. Read and write no execute - haven't tried changing that yet. There are a number of KDE services running that I don't use as well. Not looked in Service Configuration before.

    The remember password aspect is the only thing I can think of that I have done differently when packagekit miss behaved.

    John
    -

  8. #8
    Join Date
    Oct 2012
    Location
    Australia
    Posts
    3

    Default Re: Packagekit

    Since you use KDE the easiest way to shut down Packagekit is to put the "KDE System Monitor" applet in the panel. When you are blocked by any application, open the System Monitor and click on the Process tab, then click on the "Name" bar to alphabetize the processes. Scroll down to packagekit and click to highlight, then click the "End Process radio button next to the address bar. Answer the pop -up to end packagekit and when prompted enter your admin password. Really though you just need top decide if you are going to update manually with Yast, by Terminal with Zypper or silently automatically with Apper. Personally I would disable Apper. Alternately you can open a terminal, su to root priviledges and type kill <process number>. The PID # should be shown in your notification that pops up.

    Best Wishes

  9. #9
    Join Date
    Oct 2012
    Location
    Australia
    Posts
    3

    Default Re: Packagekit

    Quote Originally Posted by OneEyedMonk View Post
    Since you use KDE the easiest way to shut down Packagekit is to put the "KDE System Monitor" applet in the panel. When you are blocked by any application, open the System Monitor and click on the Process tab, then click on the "Name" bar to alphabetize the processes. Scroll down to packagekit and click to highlight, then click the "End Process radio button next to the address bar. Answer the pop -up to end packagekit and when prompted enter your admin password. Really though you just need top decide if you are going to update manually with Yast, by Terminal with Zypper or silently automatically with Apper. Personally I would disable Apper. Alternately you can open a terminal, su to root privileges and type kill <process number>. The PID # should be shown in your notification that pops up.

    Best Wishes
    Apper can be turned off in the KDE "Configure Desktop" utility, under System Management-> Apper Software Management-> Settings-> Check for new updates-> (drop down menu) Never

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •