Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: en_AU.UTF-8 locale

  1. #1

    Default en_AU.UTF-8 locale

    Hello! I'm configuring up a development server running OpenSUSE 12.3 which I've built through SuSE Studio. I'm trying to set the locale to en_AU.UTF-8 but there's no option in the languages section of yast for Australia, and when I look /etc/sysconfig/language it's not listed anywhere and adding it to the LANG environment variable doesn't seem to change it. How do I generate this locale?

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: en_AU.UTF-8 locale

    Quote Originally Posted by mmagin View Post
    Hello! I'm configuring up a development server running OpenSUSE 12.3 which I've built through SuSE Studio. I'm trying to set the locale to en_AU.UTF-8 but there's no option in the languages section of yast for Australia, and when I look /etc/sysconfig/language it's not listed anywhere and adding it to the LANG environment variable doesn't seem to change it. How do I generate this locale?
    go to

    Yast > System > Languages > Details

    and select en_AU from there.

    SUSE Paste

  3. #3

    Default Re: en_AU.UTF-8 locale

    Thanks for that, but that select is empty in my installation. Is there a package I need to install to populate it?

    SUSE Paste

  4. #4

    Default Re: en_AU.UTF-8 locale

    Quote Originally Posted by mmagin View Post
    Thanks for that, but that select is empty in my installation. Is there a package I need to install to populate it?

    SUSE Paste
    Try to set your primary language to "English (US)" in the standard language settings. You should then be able to select all english variants in "Details", including en_AU.
    At least that worked on my (german) system...

  5. #5

    Default Re: en_AU.UTF-8 locale

    Quote Originally Posted by wolfi323 View Post
    Try to set your primary language to "English (US)" in the standard language settings. You should then be able to select all english variants in "Details", including en_AU.
    At least that worked on my (german) system...
    That didn't work either. When I set the primary language to US it only gives me the en_US option, if I switch it to English UK it only has the en_GB option. Still nothing for Australia. I have to be missing something simple, this is ridiculous.

  6. #6
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    147

    Default Re: en_AU.UTF-8 locale

    Works for me [openSUSE 12.3 (x86_64) KDE 4.10.5, US keyboard, primary language en_UK, Country Australia].

    Thanks farcusnz - I had 'forgotten' where to set this.

  7. #7

    Default Re: en_AU.UTF-8 locale

    I've got no GUI on this (server), but here's some screenshots of yast on command line:

    SUSE Paste
    SUSE Paste
    SUSE Paste

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: en_AU.UTF-8 locale

    On 2013-09-23 02:16, mmagin wrote:
    >
    > I've got no GUI on this (server), but here's some screenshots of yast on
    > command line:


    You know you can run the full graphical yast from a client machine X
    session, right? Just in case yast is different.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: en_AU.UTF-8 locale

    Quote Originally Posted by robin_listas View Post
    On 2013-09-23 02:16, mmagin wrote:
    >
    > I've got no GUI on this (server), but here's some screenshots of yast on
    > command line:


    You know you can run the full graphical yast from a client machine X
    session, right? Just in case yast is different.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    I didn't know that, no. How? All I can find with regards to using yast remotely is enabling VNC access.

    Either way this should still work in the CLI yast and if it doesn't I'd like to submit a bug report, but I don't want to do that until I'm sure I've exhausted all options.

  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: en_AU.UTF-8 locale

    Quote Originally Posted by mmagin View Post
    I didn't know that, no. How? All I can find with regards to using yast remotely is enabling VNC access.

    Either way this should still work in the CLI yast and if it doesn't I'd like to submit a bug report, but I don't want to do that until I'm sure I've exhausted all options.
    for me - using CLI all the choices are there, so I don't think that is your problem (although I didn't check it remotely).

    My install is just the default KDE install (64bit) - I didn't need to install any packages to have a choice of different locales.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •