Results 1 to 4 of 4

Thread: Trying to get vibe.d working

  1. #1

    Default Trying to get vibe.d working

    Hi,

    I'm trying to get vibe.d working on my opensuse system but I first need to get dub working. i get this error:

    dub: error while loading shared libraries: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory

    Does anybody know where i can get this?
    I do have libcurl4 and libgnutls installed from yast2

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,402

    Default Re: Trying to get vibe.d working

    Hello and welcome here,

    Please tell allways what version of openSUSE you use. We can not guess this.

    And as you specificaly tell that you installed those two libraries using YaST (thus from the standard OSS repo I guess), but you do not tell the same about dub, please also tell where and how you installed it. Again, we can not guess what you did. Never assume that the way you did something is the only and/or logical way to do it. Other people may do it in a very different way and the confusion created by assumptions may even block any usefull communication about a problem.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,059
    Blog Entries
    14

    Default Re: Trying to get vibe.d working

    Although agreeing to hcvv's post, here's what you can do:

    Start the softwaremanager, go search, check all available options, search for "libcurl-gnutls.so.4". If any package provides it, it will show up. Install it, done. If not, remove the ".4" and see what you do have.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Trying to get vibe.d working

    Sorry, i was a little annoyed of not being able to figure out where to grab libcurl-gnutls and didn't take the time to look at the posting requirements.

    I did figure out the problem though, I'm not sure if it is the best solution but i ended up making a copy of libcurl.so.4.3.0 and renaming it to libcurl-gnutls.so.4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •