Results 1 to 3 of 3

Thread: Opensuse 12.3 - Dreckeffekte nach Update auf KDE 4.11.1 (Digikam, Amarok)

  1. #1

    Post Opensuse 12.3 - Dreckeffekte nach Update auf KDE 4.11.1 (Digikam, Amarok)

    Hallo,

    nach dem Update meines Surf- und Testrechners von 4.11.0 auf 4.11.1 (aus dem offiziellen KDE4.11-Repository von Opensuse) mit der Methode "Alle Systemdateien auf die Version in diesem Repository umstellen" laufen die o.g. Anwendungen unrund, ein Update ist für den Anwender, der sie ernsthaft braucht, z.Z. wohl nicht zu empfehlen:

    * Digikam (das in Version 3.4 installiert wird) findet zahlreiche Icons in der Benutzeroberfläche nicht mehr, unabhängig von der bevorzugten Icon-Geschmacksrichtung (sei es Oxygen, Gnome etc.). Es wird dann auf das "Unbekannt"- (Fragezeichen)-Icon zurückgegriffen, das aber während des Programmstarts erst (in dutzendfacher Anzahl) gesucht wird. Das Programm startet dadurch viel langsamer als zuvor. In den Menüs kann man die Icons durch andere ersetzen oder systemweit ganz abschalten, an einige andere Stellen in der Oberfläche kommt man jedoch nicht direkt heran. Löschen und Neuanlegen der Konfigurationsdateien für das Programm im Homeverzeichnis bringt keine Abhilfe, auch nicht das Downgrade von Digikam auf Vorversionen (soweit sie noch unter KDE 4.11.1 laufen). Offenbar bringt das KDE-Update als solches eine grundsätzliche Unverträglichkeit mit Digikam mit, der man auf den Grund gehen müsste.

    * Amarok wird von 2.7.90 auf 2.8.0 aktualisiert und funktioniert auf diesem Rechner in beiden Versionen perfekt, aber: Die 2.8.0 startet nach dem Aufruf zahlreiche Hintergrundprozesse (gibt auch eine entsprechende Statusmeldung aus), die mindestens ca. 30-50 Fehlermeldungen in eigenen Fensterchen auswerfen (mit dem Inhalt, dass irgendwelche Streamingserver-Probleme bestehen, Adressen oder Dateien auf diesen Servern nicht gefunden wurden, Zeitüberschreitung im Netzwerk etc.). Solange diese Prüfungen laufen, muss der Nutzer warten, was etwas nervt. Abhilfe schafft das komplette Deaktivieren aller Skripte, die auf Streamingdienste zugreifen (offensichtliche Übeltäter hauptsächlich German Radio und Shoutcast-Service, die brauch ich aber beide, muss sie dann immer neu aktivieren... - scheinbar prüfen diese Skripte beim Start nun komplett, ob die mehreren Hundert gespeicherten Stationen alle erreichbar sind). Die Vorabversion aus KDE 4.11.0 war nicht so gesprächig und startete von jetzt auf gleich.

    Tipps zur Abhilfe müssen nicht unbedingt sein - wenn ein Entwickler mitliest, wäre es nett, wenn er diese Dinge im Hinterkopf speichert und die nächste Version bereinigt. Neue Versionen sollten ja eigentlich weniger Mängel haben als die alten.


    Gruß und schönes Rest-Wochenende, Tom

  2. #2
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default AW: Opensuse 12.3 - Dreckeffekte nach Update auf KDE 4.11.1 (Digikam, Amarok)

    Zu Digikam: Könnte am Cache liegen. Probier mal ein
    Code:
    kbuildsycoca4 --noincremental
    Hat bei mir mal bei einem ähnlichen Problem geholfen.
    - openSuse 12.1 3.1.0-1.2-desktop x86_64 KDE: 4.7.4 (4.7.4) "release 11"

    Murphy's Law is recursive. Washing your car to make it rain doesn't work.

  3. #3

    Default AW: Opensuse 12.3 - Dreckeffekte nach Update auf KDE 4.11.1 (Digikam, Amarok)

    Quote Originally Posted by Fruchtratte View Post
    Zu Digikam: Könnte am Cache liegen. Probier mal ein
    Code:
    kbuildsycoca4 --noincremental
    Hat bei mir mal bei einem ähnlichen Problem geholfen.
    In dem Fall wird das vermutlich nicht helfen.
    KDE 4.11.1 hat leider einen Fehler, der fehlende Icons verursacht, nicht nur in Digikam sondern auch kolourpaint, krita, naja fast überall!
    https://bugs.kde.org/show_bug.cgi?id=324574

    Und jetzt die gute Nachricht:
    Der Fehler wurde heute gefunden und behoben und sollte in 4.11.2 nicht mehr vorhanden sein.
    Und der Fix wurde auch bereits zu openSUSE's 4.11.1 Paketen hinzugefügt.

    Daher einfach mal "sudo zypper up" ausführen, und die Icons sollten wieder in Ordnung sein. Bei mir funktionierts bereits wieder...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •