Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Yast2 problem after update to latest modules 12.2

  1. #1
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Question Yast2 problem after update to latest modules 12.2

    KDE and yast2 are having problems after the latest updates from the repositories. I am still able to start a session using LXDE so from there

    yast reports

    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in qt
    YaST got signal 6 at YCP file Wizard.ycp:1801
    /sbin/yast2: line 427: 9837 Aborted
    $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS


    KDE reports unable to start kdeinit4, but file is present and permissions look ok

    Can anyone tell me what to look for or how to get back to working?

    Thanks
    Brian

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Yast2 problem after update to latest modules 12.2

    As it seems that the update is "guilty", we have to look into what was updated from what.
    You say "from the repositories". But as we do not know what repos you use and also not which of them you used to update from (all?) we are a bit at loss here. Also how you updated (YaST and what, zypper, which what command(s)), we can only guess. And guessing is not a very solid base for solving computer problems.
    Henk van Velden

  3. #3
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Default Re: Yast2 problem after update to latest modules 12.2

    When I updated, there were 428 updates from repositories, using yast2, update, option when running kde version "update if newer available", list follows of repositories used.

    Running ltsp, terminals, this server is running as a virtual machine, XEN, 8 core amd processor 16gb memory.

    KDE will not start, unable to run kdeinit4
    gnome starts then freezes with clock showing for ever but the screen locking time out works.... can unlock it to continue

    LXDE seems to work fine, but yast does not run as noted above, apper seems to work fine.

    I seems to be some form of QT problem maybe, but I dont even know where to look to see why KDE will not start, tried to create a new user and login using kde same problem.

    ncurses of yast work fine, --gtk version has same error as noted above.

    Hope this helps a little!


    70 │ x │ x │KDE QT STABLE │ │Index of /repositories/KDE:/Qt48/openSUSE_12.2
    │ 70 │ x │ x │KDE 4.11 update │ │Index of /repositories/KDE:/Release:/411/openSUSE_12.2
    │ 80 │ x │ x │openSUSE BuildService - KDE:Extra │ │Index of /repositories/KDE:/Extra/openSUSE_12.2
    │ 80 │ x │ x │openSUSE BuildService - KDE:UpdatedApps │ │Index of /repositories/KDE:/UpdatedApps/openSUSE_12.2
    │ 85 │ x │ x │Xorg by X11 │ │Index of /repositories/X11:/XOrg/openSUSE_12.2
    │ 90 │ x │ x │openSUSE-12.2-Update-Non-Oss │ │Index of /update/12.2-non-oss
    │ 90 │ x │ x │openSUSE-12.2-Update │ │Index of /update/12.2
    │ 90 │ x │ x │openSUSE-12.2-Update-Debug-Non-Oss │ │Index of /debug/update/12.2-non-oss
    │ 90 │ x │ x │openSUSE-12.2-Update-Debug │ │Index of /debug/update/12.2
    │ 99 (Default)│ x │ x │openSUSE-12.2-Non-Oss │ │Index of /distribution/12.2/repo/non-oss
    │ 99 (Default)│ x │ x │openSUSE BuildService - devel:languagesython│ │Index of /repositories/devel:/languages:/python/openSUSE_12.2
    │ 99 (Default)│ x │ x │google-chrome │ │http://dl.google.com/linux/chrome/rpm/stable/x86_64
    │ 99 (Default)│ x │ x │libdvdcss repository │ │http://opensuse-guide.org/repo/12.2/
    │ 99 (Default)│ x │ x │Packman Repository │ │Index of /suse/12.2/
    │ 99 (Default)│ x │ x │openSUSE-12.2-Debug │ │Index of /debug/distribution/12.2/repo/oss
    │ 99 (Default)│ x │ x │server:ltsp │ │Index of /repositories/server:/ltsp/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE-12.2-Oss │ │Index of /distribution/12.2/repo/oss
    │ 99 (Default)│ x │ x │openSUSE-12.2-Source │ │Index of /source/distribution/12.2/repo/oss
    │ 99 (Default)│ x │ x │openSUSE BuildService - PHP │ │Index of /repositories/server:/php/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - devel:languageserl │ │Index of /repositories/devel:/languages:/perl/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - Javaackages │ │Index of /repositories/Java:/packages/openSUSE_12.2
    │ 99 (Default)│ x │ x │Main Repository (Sources) │ │Index of /source/distribution/12.2/repo/oss
    │ 99 (Default)│ x │ x │Main Repository (DEBUG) │ │Index of /debug/distribution/12.2/repo/oss
    │ 99 (Default)│ x │ x │openSUSE BuildService - Mozilla │ │Index of /repositories/mozilla/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - Games │ │Index of /repositories/games/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - filesystems │ │Index of /repositories/filesystems/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - Database │ │Index of /repositories/server:/database/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - LibreOffice │ │Index of /repositories/LibreOffice:/Stable/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - Education │ │Index of /repositories/Education/openSUSE_12.2
    │ 99 (Default)│ x │ x │openSUSE BuildService - Mono:Community │ │Index of /repositories/Mono:/Community/openSUSE_12.2
    │ 99 (Default)│ x │ x │nVidia Graphics Drivers │ │ftp://download.nvidia.com/opensuse/12.2/
    │ 99 (Default)│ x │ x │desktop │ │Index of /repositories/X11:/RemoteDesktop/openSUSE_12.2
    │ 99 (Default)│ x │ x │X11:RemoteDesktop:x2go │ │Index of /repositories/X11:/RemoteDesktop:/x2go/openSUSE_12.2

  4. #4
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Default Re: Yast2 problem after update to latest modules 12.2

    update, after more testing.

    gnome, functions correctly on the virtual console, but the mouse is not displayed, the desktop background is displayed on the ltsp terminal but, the little clock shows and never goes away, but screen locking timeout works and password entry works to unlock. but goes back to little clock for mouse display....

    KDE, will not start at all virtual console or ltsp, same error in both cases, yast same error in virtual console or on ltsp terminal.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Yast2 problem after update to latest modules 12.2

    Two comments.

    Please next time copy/paste your computer output into a post beteen CODE tags. You get the CODE tags by clicking on the # button in the tool bar of the post editor. This will make a tbale as the one you try to show here readable.

    As you can decide from the above, your table is next to unreadable, but it is far beyond the basic five (5) repos (OSS, non-OSS, Updates OSS, Updates non-OSS, Packman). Now a few (when you like to go for a newer KDE e.g.) is exceptable when you handle them properly. But what you have is IMHO likely to create problems.
    Henk van Velden

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast2 problem after update to latest modules 12.2

    On 2013-09-11 10:06, hcvv wrote:

    > As you can decide from the above, your table is next to unreadable, but
    > it is far beyond the basic five (5) repos (OSS, non-OSS, Updates OSS,
    > Updates non-OSS, Packman). Now a few (when you like to go for a newer
    > KDE e.g.) is exceptable when you handle them properly. But what you have
    > is IMHO likely to create problems.


    Absolutely. I tried to examine the table, but I had to give up. Could
    you (ercoupeflyer) please repost it? Inside code tags this time, please.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Default Re: Yast2 problem after update to latest modules 12.2

    Table of repos
    Code:
      │ 70          │   x   │     x     │KDE QT STABLE                                         │       │Index of /repositories/KDE:/Qt48/openSUSE_12.2                       
      │ 70          │   x   │     x     │KDE 4.11 update                                          │       │Index of /repositories/KDE:/Release:/411/openSUSE_12.2               
      │ 80          │   x   │     x     │openSUSE BuildService - KDE:Extra             │       │Index of /repositories/KDE:/Extra/openSUSE_12.2                      
      │ 80          │   x   │     x     │openSUSE BuildService - KDE:UpdatedApps       │       │Index of /repositories/KDE:/UpdatedApps/openSUSE_12.2 
      │ 85          │   x   │     x     │Xorg by X11                                                   │       │Index of /repositories/X11:/XOrg/openSUSE_12.2                
      │ 90          │   x   │     x     │openSUSE-12.2-Update-Non-Oss                  │       │Index of /update/12.2-non-oss                                       
      │ 90          │   x   │     x     │openSUSE-12.2-Update                                  │       │Index of /update/12.2                                                
      │ 90          │   x   │     x     │openSUSE-12.2-Update-Debug-Non-Oss            │       │Index of /debug/update/12.2-non-oss                                
      │ 90          │   x   │     x     │openSUSE-12.2-Update-Debug                        │       │Index of /debug/update/12.2                                          
      │ 99 (Default)│   x   │     x     │openSUSE-12.2-Non-Oss                         │       │Index of /distribution/12.2/repo/non-oss                            
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - devel:languages:python│       │Index of /repositories/devel:/languages:/python/openSUSE_12.2        
      │ 99 (Default)│   x   │     x     │google-chrome                                 │       │http://dl.google.com/linux/chrome/rpm/stable/x86_64                                     
      │ 99 (Default)│   x   │     x     │libdvdcss repository                          │       │http://opensuse-guide.org/repo/12.2/                                                    
      │ 99 (Default)│   x   │     x     │Packman Repository                            │       │Index of /suse/12.2/                                                      
      │ 99 (Default)│   x   │     x     │openSUSE-12.2-Debug                           │       │Index of /debug/distribution/12.2/repo/oss                           
      │ 99 (Default)│   x   │     x     │server:ltsp                                   │       │Index of /repositories/server:/ltsp/openSUSE_12.2                    
      │ 99 (Default)│   x   │     x     │openSUSE-12.2-Oss                             │       │Index of /distribution/12.2/repo/oss                                  
      │ 99 (Default)│   x   │     x     │openSUSE-12.2-Source                          │       │Index of /source/distribution/12.2/repo/oss                           
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - PHP                   │       │Index of /repositories/server:/php/openSUSE_12.2                      
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - devel:languages:perl  │       │Index of /repositories/devel:/languages:/perl/openSUSE_12.2           
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - Java:packages         │       │Index of /repositories/Java:/packages/openSUSE_12.2                   
      │ 99 (Default)│   x   │     x     │Main Repository (Sources)                     │       │Index of /source/distribution/12.2/repo/oss                           
      │ 99 (Default)│   x   │     x     │Main Repository (DEBUG)                       │       │Index of /debug/distribution/12.2/repo/oss                            
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - Mozilla               │       │Index of /repositories/mozilla/openSUSE_12.2                          
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - Games                 │       │Index of /repositories/games/openSUSE_12.2                            
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - filesystems           │       │Index of /repositories/filesystems/openSUSE_12.2                      
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - Database              │       │Index of /repositories/server:/database/openSUSE_12.2                 
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - LibreOffice           │       │Index of /repositories/LibreOffice:/Stable/openSUSE_12.2              
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - Education             │       │Index of /repositories/Education/openSUSE_12.2                        
      │ 99 (Default)│   x   │     x     │openSUSE BuildService - Mono:Community        │       │Index of /repositories/Mono:/Community/openSUSE_12.2                  
      │ 99 (Default)│   x   │     x     │nVidia Graphics Drivers                       │       │ftp://download.nvidia.com/opensuse/12.2/                                                  
      │ 99 (Default)│   x   │     x     │desktop                                       │       │Index of /repositories/X11:/RemoteDesktop/openSUSE_12.2                
      │ 99 (Default)│   x   │     x     │X11:RemoteDesktop:x2go                        │       │Index of /repositories/X11:/RemoteDesktop:/x2go/openSUSE_12.2

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast2 problem after update to latest modules 12.2

    On 2013-09-11 21:26, ercoupeflyer wrote:
    >
    > Table of repos


    Something is wrong. Some of the URLs have been converted to short links,
    this should not happen. Also... I thought you knew, so I did not mention
    it: we normally do this by issuing the command:

    Code:
    zypper lr --details
    and pasting all that inside a code block. I think you must have done it
    from... yast?

    Doesn't matter, I can see what I wanted to see. No need to post it
    again, I think.

    Anyway... you problem may be because YaST is sensitive to the QT
    libraries installed. You have several repos to update KDE and QT, and
    _maybe_ those have broken YaST, and KDE.

    I'm not an expert at that kind of KDE problem. Me, I would revert to the
    version on the DVD, and then perhaps update carefully somethings.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: Yast2 problem after update to latest modules 12.2

    I also think that that Qt repo (#1 in your list) might cause your problems.
    Remove it, the KDE 4.11 repo contains it's own libqt4. Switch all libqt4* packages to the versions in the KDE 4.11 repo.

    Maybe run
    Code:
    sudo zypper dup --from "KDE 4.11 update"
    or click on "Switch all system packages..." in YaST.

    Some other notes:
    You don't need "KDE:UpdatedApps" if you have that KDE 4.11 repo, since this contains all those apps in their latest version.
    And the URL for your KDE:Extra repo is wrong. You need the one for KDE 4.11:
    http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_411_openSUSE_12.2/

    And, do you have "libyui4-qt-pkg4" installed?

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,861
    Blog Entries
    14

    Default Re: Yast2 problem after update to latest modules 12.2

    The Yast issue arrizes when libyui-qt-pkg4 is not installed.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •