Results 1 to 5 of 5

Thread: USB AutoMount / AutoFS

  1. #1

    Default USB AutoMount / AutoFS

    Greetings! Have been playing with OpenSuse for a while and really beginning to enjoy it. Simple question...how do I enable auto-mounting of USB devices. When I say automount, I mean the directory should appear in /var/run/media (or wherever the default mount place) is without me having to click on it in the file manager.

    I was told to enable AutoFS in YaST but when I do that it just goes from AutoFS Enabled = No to AutoFS Enabled = *No.

    Any suggestions?

    KL

  2. #2

    Default AW: USB AutoMount / AutoFS

    Quote Originally Posted by Kernellinux1 View Post
    Any suggestions?
    If you're using KDE, the easiest way may be to enable automatic mounting in the device notifier.
    See here for detailed information about using removeable media with KDE:
    How to Manage Removable Devices in KDE - Make Tech Easier
    Regarding your question especially, scroll down to the second sub-heading "Automatic Connections" after about a third of the article.

  3. #3

    Default Re: USB AutoMount / AutoFS

    Quote Originally Posted by Kernellinux1 View Post
    I was told to enable AutoFS in YaST but when I do that it just goes from AutoFS Enabled = No to AutoFS Enabled = *No.
    You're talking about the YaST Runlevel module, right?
    The "*No" in this case means, that the service is enabled to be started on boot, but it is not running at the moment (or was it the other way round? Click on the Help button to get an explanation ). A reboot should suffice to actually start it.
    But I think you would have to configure AutoFS as well, so that it works like you would like it to work, see here: http://www.autofs.org/. But I have no experience with that.

    But that YaST module doesn't really work 100% correctly with systemd in 12.3. So maybe you would have to use systemctl to enable AutoFS.

    Anyway, if you're doing it the KDE way as mentioned in my previous post, you can disable AutoFS again, it's not needed then.

  4. #4

    Default Re: AW: USB AutoMount / AutoFS

    Quote Originally Posted by wolfi323 View Post
    If you're using KDE, the easiest way may be to enable automatic mounting in the device notifier.
    See here for detailed information about using removeable media with KDE:
    How to Manage Removable Devices in KDE - Make Tech Easier
    Regarding your question especially, scroll down to the second sub-heading "Automatic Connections" after about a third of the article.
    I actually tried doing this...but the issue is I need every device named "name" to automatically mount and somehow Suse knows that "name" on device 1 is not the same as "name" when I insert device 2. Same make, same model, same format layout, same parition same name...it knows.

    It's very strange I've never dealt with this in Ubuntu or Fedora. I am using KDE if that helps. I tried restrting and it didn't make a differnce in fact, it still shows *No

  5. #5

    Default Re: USB AutoMount / AutoFS

    Quote Originally Posted by Kernellinux1 View Post
    I actually tried doing this...but the issue is I need every device named "name" to automatically mount and somehow Suse knows that "name" on device 1 is not the same as "name" when I insert device 2. Same make, same model, same format layout, same parition same name...it knows.
    What do you mean with that?
    If you enable automounting and enable "Automatically mount removable media when attached", EVERY device you connect/insert should be mounted automatically.
    Or do you only want to mount certain devices?

    It's very strange I've never dealt with this in Ubuntu or Fedora. I am using KDE if that helps. I tried restrting and it didn't make a differnce in fact, it still shows *No
    As mentioned, that YaST module isn't working reliably with systemd atm. A new one has already been written and will be in 13.1, but I doubt it will be released as update to 12.3...

    You can check if AutoFS is running with "systemctl status autofs".
    Enable it with "sudo systemctl enable autofs".
    It should be started then on next boot. You can immediately start it with "sudo systemctl start autofs".

    But as I said, just starting it is not enough. You have to configure it as well. See the link I gave you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •