Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Disabling KDE Window transparency

  1. #1

    Default Disabling KDE Window transparency

    openSUSE 12.3, KDE 4.10

    I'm trying to disable all translucency effects. I thought could be achieved by disabling the desktop effect, however my window decorations are still trasparent which is rather annoying. Does disabling translucency affect window decorations or is it suppose to have a universal effect?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,630
    Blog Entries
    3

    Default Re: Disabling KDE Window transparency

    I probably misunderstood the question.

    I have desktop effects disabled, and I am not seeing any transparency of window decorations. But maybe when desktop effects are disabled, you have to logout and login again before the change is fully effective.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Disabling KDE Window transparency

    Quote Originally Posted by nrickert View Post
    I probably misunderstood the question.

    I have desktop effects disabled, and I am not seeing any transparency of window decorations. But maybe when desktop effects are disabled, you have to logout and login again before the change is fully effective.
    Sorry, I noticed a typo in my original question. In short does disabling the desktop effect traslucent also apply to window decorations? I've logging out and back and It's still there. To be more specific it's the window title bar.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Disabling KDE Window transparency

    I suspect that you will find that window decorations are determined by System Settings>Workspace appearance>Window decorations and that the way forward is to install a different style.

  5. #5

    Default Re: Disabling KDE Window transparency

    Quote Originally Posted by john_hudson View Post
    I suspect that you will find that window decorations are determined by System Settings>Workspace appearance>Window decorations and that the way forward is to install a different style.
    I tried and it doesn't work. Unless every decoration I used has a transparent window title bar.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,852
    Blog Entries
    14

    Default Re: Disabling KDE Window transparency

    what happens if you turn off desktop effects entirely?
    Also have a look at the desktop effects / all effects / transparency. It has a settings button.

    If the problem persists, you may consider setting the plasma settings back to default (i.e. remove them, so that new defaults will be generated).
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Disabling KDE Window transparency

    Quote Originally Posted by Knurpht View Post
    what happens if you turn off desktop effects entirely?
    Also have a look at the desktop effects / all effects / transparency. It has a settings button.

    If the problem persists, you may consider setting the plasma settings back to default (i.e. remove them, so that new defaults will be generated).
    Disabling all effects stopped the transparency.

    Would the command below reset the plasma settings to default?

    Code:
    rm -rf .kde/share/config/plasma-*

  8. #8

    Default Re: Disabling KDE Window transparency

    Quote Originally Posted by Static2k View Post
    Would the command below reset the plasma settings to default?

    Code:
    rm -rf .kde/share/config/plasma-*
    No. On openSUSE, KDE4's settings are in ~/.kde4 so the line should be:
    Code:
    rm ~/.kde4/share/config/plasma-*
    But: Plasma has nothing to do with the window decorations, so this won't help you!
    I think there are some special transparency settings either in "Configure Desktop"->"Workspace Appearance"->"Window Decorations" or in "Applications Appearance". I'm not sure right now where they are. I will have a look in the evening...

    If you don't want to wait that long, you could try to remove ~/.kde4/share/config/kwinrc, that's where those things should be stored IIANM.

  9. #9

    Default AW: Re: Disabling KDE Window transparency

    Quote Originally Posted by john_hudson View Post
    and that the way forward is to install a different style.
    Sorry, that's wrong.
    I guess you mixed that up with the plasma panel's transparency?

  10. #10

    Default Re: Disabling KDE Window transparency

    Quote Originally Posted by wolfi323 View Post
    No. On openSUSE, KDE4's settings are in ~/.kde4 so the line should be:
    Code:
    rm ~/.kde4/share/config/plasma-*
    But: Plasma has nothing to do with the window decorations, so this won't help you!
    I think there are some special transparency settings either in "Configure Desktop"->"Workspace Appearance"->"Window Decorations" or in "Applications Appearance". I'm not sure right now where they are. I will have a look in the evening...

    If you don't want to wait that long, you could try to remove ~/.kde4/share/config/kwinrc, that's where those things should be stored IIANM.
    Thanks! I'll wait.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •