Pardon me if this is not the right forum. I thought there used to be one about software updates. So it was either this one or the Install one.

It's happened again. I made a 30 mile round trip to the library (had other things to do, too) to get the repodata for the updates. I noticed the update date on the files was the 23rd and today was 29th. I checked right before I left and the files were still the 23rd. So I tried to be optimistic. By the time I got home and tried to use the files, they had updated them.

After finding merely copying the files to the repodata directory did not work, what I normally do in Yast is to run the Online Update and as soon as it starts and creates the temporary update directory in /var/cache/zypp/raw/, I click abort. This gives me 30 seconds to copy my files into the directory, the update, seeing that the server and the directory files are the same, then moves them over and all is fine. When the files have been updated in the meantime, I'm out of luck with the knowledge I have.

The reason I have to go to the library is that repodata file filelists and primary are over 14MB! That is basically out of reach for me on dialup. Once, I thought I would try early in the morning hoping they wouldn't update them during the time. I verified they had just been updated the previous day and started my download manager. After several hours, I noticed that it was having problems at 90% on the last one. I found out they had updated them during that time.

So the question is, am I out of luck? I realize I can't get the current updates, but could I at least use the ones I just downloaded? It would work for awhile. If one of the software files are updated and they remove the one in my older filelist, then I'm out of luck, but at least I might have a few days to get things updated. Is there some way to tell the update software to use the current files I put in the repodata directory?

I had turned off all the automatic updates I could find to prevent my internet use from basically being disabled, so don't know if that has an effect. I couldn't manage to do that in 12.1 so if I remember, I load Software Management in the background to prevent the packagekit from running.