Results 1 to 4 of 4

Thread: How to add "vga=0" to the kernel

  1. #1

    Default How to add "vga=0" to the kernel

    Hi,

    My computer (AMD A8 3850 CPU, ATI 4550 video card, OPENSUSE 12.3, 32 bit, Windows 7 dual boot) does not sleep. It stuck there, but keyboard LED still works.
    I want to try search the options to make sleep work. I do not know how to do these:



    passing "vga=0" to the kernel



    There is GRUB2 on boot. It can select OPENSUSE 12.3 boot or Windows 7 boot at the beginning. Somebody says key in "vga=0" after I press 'e' key. Is it really?



    Could you explain it in detail to me?

    Thanks,

  2. #2

    Default Re: How to add "vga=0" to the kernel

    To answer your question about adding vga=0 as a boot argument: You can either hit escape to go from the graphical grub2 screen to the text screen, enter edit mode and modify the kernel line to append vga=0, or you can permenantly add kernel boot arguments using Yast -> Boot configuration -> Boot Loader Options -> Optional kernel command line parameters.

    However, this is not going to have any effect on you system sleeping.

    Are you trying to suspend to ram or to disk?

    What happens exactly? Does it log you out and hang? Just hand immediately? Does the screen go black, but the system not power down?

  3. #3

    Default Re: How to add "vga=0" to the kernel

    Quote Originally Posted by LewsTherinTelemon View Post
    To answer your question about adding vga=0 as a boot argument: You can either hit escape to go from the graphical grub2 screen to the text screen, enter edit mode and modify the kernel line to append vga=0, or you can permenantly add kernel boot arguments using Yast -> Boot configuration -> Boot Loader Options -> Optional kernel command line parameters.

    However, this is not going to have any effect on you system sleeping.

    Are you trying to suspend to ram or to disk?

    What happens exactly? Does it log you out and hang? Just hand immediately? Does the screen go black, but the system not power down?

    Thank you very much. I get the instruction from web page:
    [/QUOTE]SDB:Suspend to RAM

    There are machines that will not resume when using a framebuffer console. Recent Dell and HP models for example very often fall into this category.
    You can disable the framebuffer in your bootloader configuration by passing "vga=0" to the kernel.ATI graphics chipsets

    Lately many machines i came across with ATI Radeon graphics chipsets did not work with any framebuffer (usually they hung inside the BIOS, not even capslock did work after trying to resume). They often worked fine with "vga=0" and "s2ram -f -p -m" or "s2ram -f -p -s". [/QUOTE]

    I have tried the above two commands. The monitor are sleep then, but the desktop computer continue run and does not respond to keyboard and mouse any more. My computer has the following info:

    [/QUOTE]linux-kx35:/home/wan2/Downloads # s2ram -i
    This machine can be identified by:
    sys_vendor = "MSI"
    sys_product = "MS-7696"
    sys_version = "1.0"
    bios_version = "V1.0B6"
    [/QUOTE]

    (Please use info in this post if it is different with my previous posts)
    CPU: AMD A8-3850
    Video card:
    SAPPHIRE Radeon HD 5450 1GB 64-bit DDR3 PCI Express 2.1 x16 HDCP Ready Low Profile Ready Video Card ( 100292DDR3L)

    OPENSUSE (12.3, 32 bit) is really cool and fast. But s2ram does not work (I only need it sleep to ram (not disk)), Could you help me on steps to make S2RAM work?

    Thanks,

  4. #4

    Default Re: How to add "vga=0" to the kernel

    Quote Originally Posted by LewsTherinTelemon View Post
    To answer your question about adding vga=0 as a boot argument: You can either hit escape to go from the graphical grub2 screen to the text screen, enter edit mode and modify the kernel line to append vga=0, or you can permenantly add kernel boot arguments using Yast -> Boot configuration -> Boot Loader Options -> Optional kernel command line parameters.

    However, this is not going to have any effect on you system sleeping.

    Are you trying to suspend to ram or to disk?

    What happens exactly? Does it log you out and hang? Just hand immediately? Does the screen go black, but the system not power down?
    Thanks. The screen goes to sleep (Its LED blink), but the system does not respond any more. On the web, some check /var/log/pm-suspend.log. I do NOT see that log file. There is only pm-powersave.log. Below is its contents. Is it useful or not?

    Quote Originally Posted by LewsTherinTelemon View Post
    Running hook /usr/lib/pm-utils/power.d/disable_wol false:
    Setting Wake On Lan for eth0 to enable...Done.

    /usr/lib/pm-utils/power.d/disable_wol false: success.
    Running hook /usr/lib/pm-utils/power.d/hal-cd-polling false:

    /usr/lib/pm-utils/power.d/hal-cd-polling false: success.
    Running hook /usr/lib/pm-utils/power.d/intel-audio-powersave false:
    Setting power savings for snd_hda_intel to 0...Done.

    /usr/lib/pm-utils/power.d/intel-audio-powersave false: success.
    Running hook /usr/lib/pm-utils/power.d/journal-commit false:
    Setting journal commit time for / to 0...Done.
    Setting journal commit time for /boot to 0...Done.
    Setting journal commit time for /opt to 0...Done.
    Setting journal commit time for /home to 0...Done.

    /usr/lib/pm-utils/power.d/journal-commit false: success.
    Running hook /usr/lib/pm-utils/power.d/laptop-mode false:
    Laptop mode disabled.

    /usr/lib/pm-utils/power.d/laptop-mode false: success.
    Running hook /usr/lib/pm-utils/power.d/pcie_aspm false:

    /usr/lib/pm-utils/power.d/pcie_aspm false: success.
    Running hook /usr/lib/pm-utils/power.d/readahead false:
    Setting readahead for /dev/sda6 to 256...Done.
    Setting readahead for /dev/sda3 to 256...Done.
    Setting readahead for /dev/sda5 to 256...Done.
    Setting readahead for /dev/sda4 to 256...Done.

    /usr/lib/pm-utils/power.d/readahead false: success.
    Running hook /usr/lib/pm-utils/power.d/sata_alpm false:
    Setting SATA APLM on host0 to max_performance...Done.
    Setting SATA APLM on host1 to max_performance...Done.
    Setting SATA APLM on host2 to max_performance...Done.
    Setting SATA APLM on host3 to max_performance...Done.

    /usr/lib/pm-utils/power.d/sata_alpm false: success.
    Running hook /usr/lib/pm-utils/power.d/sched-powersave false:
    **sched policy powersave OFF

    /usr/lib/pm-utils/power.d/sched-powersave false: success.
    Running hook /usr/lib/pm-utils/power.d/wireless false:

    /usr/lib/pm-utils/power.d/wireless false: success.
    Running hook /usr/lib/pm-utils/power.d/xfs_buffer false:

    /usr/lib/pm-utils/power.d/xfs_buffer false: success.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •