Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Are Power Management Settings NOT Even Being Used?

  1. #1

    Default Are Power Management Settings NOT Even Being Used?

    Hello All,

    OS: OpenSuSE 12.1 (i586) --- *Using KDE4 too

    Ok, so awhile back I installed OpenSuSE 12.1 on an OS-Free "Zotac ZBox" PC (*i.e. No native OS installed when purchased). Not sure it matters but I thought I'd mention who made the PC...

    So this PC is being used like a Kiosk which is displaying ONLY on a big LCD Flat-Screen TV. It's only video output is an HDMI port, so that's how it's currently connected to the TV.

    The problem I'm having is that, no matter what I set the "Power Management" settings to, after about 10 mins the TV is showing "No Signal" because I'm assuming the PC is stopping the signal being sent to the TV due to Power Settings...

    I've tried creating a new Power Profile and in it unchecking all the options that tell it to do stuff after x minutes.

    For example, I've Un-checked all of the following Options:
    - Dim Display
    - Screen Energy Saving
    - Suspend Session
    - Button Events Handling

    Then I've set that profile to be used inside the "Global Power Management Settings".


    I'm not quite sure what I'm missing here, but does anyone have any idea what could be going on here? Is that Power Profiles thing actually used or could something else be controlling my Power settings? I was also reading the README doc for the pm-profiler but wasn't sure if that would change anything.

    Any thoughts and/or suggestion would be greatly appreciated... My goal is to never have the monitor go blank and to never let the PC go to sleep (*unless specifically selected by a user to do so)...


    Thanks in Advance,
    Matt

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,983
    Blog Entries
    14

    Default Re: Are Power Management Settings NOT Even Being Used?

    There's a couple of things I can think of:
    - Open a terminal window, and do
    Code:
    xset s noblank -dpms
    and see if this improves things.
    - Check /var/log/messages for logmessages
    - Disable screensaving entirely in KDE
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Are Power Management Settings NOT Even Being Used?

    Hey Knurpht, thanks for the reply!

    I'm not in the office at the moment to give this a try, but I'll give it a shot first thing tomorrow and I'll let you know what happens...

    Thanks Again,
    Matt

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Are Power Management Settings NOT Even Being Used?

    Quote Originally Posted by mmartin0926 View Post
    Hey Knurpht, thanks for the reply!

    I'm not in the office at the moment to give this a try, but I'll give it a shot first thing tomorrow and I'll let you know what happens...

    Thanks Again,
    Matt
    If you are using KDE, make sure to check your screen saver settings in menu / Configure Desktop / Display & Monitor / Screen Locker / The default is to start after 10 minutes.

    1've had good luck adding the following:

    Code:
    DPMS-dependent=false
    to your kscreensaverrc file in "/home/user/.kde4/share/config" under the "[ScreenSaver]" section, still assuming you're running KDE. On two of my machines running Kubuntu, the screensavers failed. After adding the above code and restarting, they started working again.

    Thank You,
    Last edited by jdmcdaniel3; 21-Aug-2013 at 18:20.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,983
    Blog Entries
    14

    Default Re: Are Power Management Settings NOT Even Being Used?

    Quote Originally Posted by jdmcdaniel3 View Post
    1've had good luck adding the following:

    Code:
    DPMS-dependent=false
    to your kscreensaverrc file in "/home/user/.kde4/share/config" under the "[ScreenSaver]" section, still assuming you're running KDE. On two of my machines running Kubuntu, the screensavers failed. After adding the above code and restarting, they started working again.
    Cheers, James, I knew there was something else. On my server/workstation I added this some years ago, same reason, couldn't remember yesterday
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Are Power Management Settings NOT Even Being Used?

    Quote Originally Posted by jdmcdaniel3 View Post
    If you are using KDE, make sure to check your screen saver settings in menu / Configure Desktop / Display & Monitor / Screen Locker / The default is to start after 10 minutes.

    1've had good luck adding the following:

    Code:
    DPMS-dependent=false
    to your kscreensaverrc file in "/home/user/.kde4/share/config" under the "[ScreenSaver]" section, still assuming you're running KDE. On two of my machines running Kubuntu, the screensavers failed. After adding the above code and restarting, they started working again.

    Thank You,

    Hey jdmcdaniel, thanks for the reply!

    Thanks for the info, I couldn't figure out where that screensaver setting was, the one for configuring the display when I was trying to work this out a few days ago. Because I remember changing those settings in there when I was trying to disable the screensaver but it looks like it was on the 2nd PC we have for the same purpose just in a different location. But I went into the "Personal Settings" which is what its called when you search it in the "Start" like Menu from the taskbar and adjusted the settings for the "System/Personal Settings > Display and Monitor > Screen Saver". In there it was set to "4 min" which is weird because it never followed that anyway...

    But I've disabled the screensaver all together so we'll see what happens.

    As far as the DPMS setting in the config file, I already added that "DPMS-dependent=false" line when I was working at this a few days ago. I had found it in another post I think on this site...

    So my kscreensaverrc file contains:
    Code:
    [ScreenSaver]
    Enabled=false
    PlasmaEnabled=false
    Saver=kblank.desktop
    Timeout=60000
    DPMS-dependent=false
    Hopefully disabling the Screen Saver setting for "Start automatically after: x mins" will completely disable it...

    I also found this setting below in the "powerdevilrc"file, but I don't know if that does anything currently...
    Code:
    [General]
    configLockScreen=false
    
    [Profiles]
    ACProfile=Performance
    I'm kinda curious why it would have the "Performance" profile set in there when I created a new Power Profile and set that as the default in the Global Power Settings..?


    Anyway, thanks again guys for the replies, much appreciated!


    Thanks Again,
    Matt

  7. #7

    Default Re: Are Power Management Settings NOT Even Being Used?

    Hey again...

    So this is strange, I'm SSH'ed into that PC I'm trying to disable the Monitor for and I ran the "systemsettings" command in order to get that window open that has the "System Settings" in it (*you can run it just like you can run YaST2 through the commnand Line and open a GUI window for it remotely.). But anyway after I applied the Screensaver settings I went back to the listing of all the setting categories and opened the "Power Management" section and when I did I got an error saying:
    Power Management configuration module could not be loaded. The Power Management Service appears not to be running. This can be solved by starting or scheduling it inside "Startup and Shutdown."
    In there it gives the same message for both options inside the Power Management section, which are "Global Settings" and "Power Profiles". I don't know if it's just a coincidence or not but you can sort of see passed this message that is displayed over the settigns area and inside the Power Profiles page I can see that pretty much every option is checked off. Like Dim Display, Screen Energy Saving, Suspend Session, etc...

    How do I start the Power Management Service that they are talking about in that error message so I can check what these settings really are?

    EDIT:
    Nevermind I found how to start it. But when I did I went back to the Power Management settings and nothing that I set those settings to is there anymore... Everything looks like it was reset back to defaults. Will this happen all the time? Or is there a way to make sure these settings stick on reboots?

    Thanks Again,
    Matt

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Are Power Management Settings NOT Even Being Used?

    Quote Originally Posted by mmartin0926 View Post
    Hey again...

    So this is strange, I'm SSH'ed into that PC I'm trying to disable the Monitor for and I ran the "systemsettings" command in order to get that window open that has the "System Settings" in it (*you can run it just like you can run YaST2 through the commnand Line and open a GUI window for it remotely.). But anyway after I applied the Screensaver settings I went back to the listing of all the setting categories and opened the "Power Management" section and when I did I got an error saying:

    In there it gives the same message for both options inside the Power Management section, which are "Global Settings" and "Power Profiles". I don't know if it's just a coincidence or not but you can sort of see passed this message that is displayed over the settigns area and inside the Power Profiles page I can see that pretty much every option is checked off. Like Dim Display, Screen Energy Saving, Suspend Session, etc...

    How do I start the Power Management Service that they are talking about in that error message so I can check what these settings really are?

    EDIT:
    Nevermind I found how to start it. But when I did I went back to the Power Management settings and nothing that I set those settings to is there anymore... Everything looks like it was reset back to defaults. Will this happen all the time? Or is there a way to make sure these settings stick on reboots?

    Thanks Again,
    Matt
    If this command helps:

    Code:
    xset s noblank -dpms
    It would need to be run on each new openSUSE session. System Configurations like screen saver and file edits would stay after each reboot. If the above command needs to be root, have a look here:

    systemd and using the after.local script in openSUSE 12.1 - Blogs - openSUSE Forums

    It seems to be my most popular Blog Post of all times.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9

    Default Re: Are Power Management Settings NOT Even Being Used?

    Quote Originally Posted by jdmcdaniel3 View Post
    If this command helps:
    Code:
    xset s noblank -dpms
    Hey jdmcdaniel, thanks again for the reply!

    Sorry, totally forgot to run that command yesterday....
    I just ran it now though on that PC as just a regular user and it seemed to execute successfully. So I don't think it will be a problem executing this during/after boot time.

    Thanks again for the info... Is there any other command that is part of the XServer like the xset command, but instead of setting things we can just view what's already set? Or is there a config file for this somewhere, where I can view these settings? I tried checking the xorg.conf file but didn't notice anything different...


    Again, thanks for the help. Much appreciated!


    Thanks Again,
    Matt

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Are Power Management Settings NOT Even Being Used?

    Quote Originally Posted by mmartin0926 View Post
    Hey jdmcdaniel, thanks again for the reply!

    Sorry, totally forgot to run that command yesterday....
    I just ran it now though on that PC as just a regular user and it seemed to execute successfully. So I don't think it will be a problem executing this during/after boot time.

    Thanks again for the info... Is there any other command that is part of the XServer like the xset command, but instead of setting things we can just view what's already set? Or is there a config file for this somewhere, where I can view these settings? I tried checking the xorg.conf file but didn't notice anything different...


    Again, thanks for the help. Much appreciated!


    Thanks Again,
    Matt
    You can use xset q for status info, but other utils can be used as well:

    Code:
    xset q
    For more hardware detail, look at my bash script here that loads inxi: H.I. Hardware Information - A Bash script to install and run inxi with default options! - Blogs - openSUSE Forums

    Thank You.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •