Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: KDE 4.11 upgrade on openSUSE 12.3

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default KDE 4.11 upgrade on openSUSE 12.3

    After changing the KDE openSUSE repositories from 4.10 to 4.11 many packages that where in the 4.10 repository are now missing from the 4.11 repository. Those packages are available as downgrade from the openSUSE OSS repository.

    YaST Sceenshot of these many packages:
    https://docs.google.com/file/d/0B-lDdSLkpJa5UUZaSHVab3dKM28


    Did anyone upgrade from 4.10 to 4.11 successfully using the openSUSE KDE repository? In that case what did you do with these missing packages?

    I am a bit unsure to downgrade so many packages with the OSS repository.

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    No problem found going from 4.10 to 4.11, on pc's or laptops

    those shown in red were not interpreted as downgrades,
    only different numbering systems,
    looking at the issue date of the version change is a better indication

    NB. openSUSE, KDE, Tumbleweed, Packman ... etc have large number differences in
    versions to avoid potential overlapping

  3. #3

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    Today I update to KDE 4.11. Currently, I have a problem with: plasma-desktop and kopete

  4. #4
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    What I find strange is that some previous KDE packages in the 4.10 repository is no longer provided in the 4.11 repository.

  5. #5

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    Quote Originally Posted by DJViking View Post
    What I find strange is that some previous KDE packages in the 4.10 repository is no longer provided in the 4.11 repository.
    Which ones do you mean exactly?
    Some got superseeded by other packages, some you should downgrade to the standard repo's versions, some may have been missed.

    I personally don't use the KDE:Release:* repos anymore at the moment, so I just don't know.
    But I might be able to give clues...

  6. #6

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    Quote Originally Posted by ismaelrubio View Post
    Today I update to KDE 4.11. Currently, I have a problem with: plasma-desktop and kopete
    And which problem exactly?

  7. #7
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    @wolfi323

    are you booting to plasma from the desktop manager login screen?

    if yes, try renaming directory /home/<username>/.kde4/ then reboot,
    (reset of desktop will be necessary)
    if this does not help change back to original name

    hth

  8. #8

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    Quote Originally Posted by keellambert View Post
    @wolfi323

    are you booting to plasma from the desktop manager login screen?

    ...snipped...
    ???
    My system is running fine (12.3 with KDF).

    I'm just trying to help here, as you are.

  9. #9
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    Quote Originally Posted by wolfi323 View Post
    Which ones do you mean exactly?
    Some got superseeded by other packages, some you should downgrade to the standard repo's versions, some may have been missed.

    I personally don't use the KDE:Release:* repos anymore at the moment, so I just don't know.
    But I might be able to give clues...

    There where many packages. They are listed in the screenshot I posted above.

    Some packages where easy to switch to KDE (downgrade as well as upgrade). Many packages that was in the KDE 4.10 repository are no longer in the KDE 4.11 repository and thus must be downgraded with the packages in the openSUSE OSS repository. Why aren't all the packages that KDE requires within the KDE repository anymore?

    Examples.
    Virtuoso
    PackageKit
    k3b
    kaffeine
    kmymoney
    krename
    liblastfm1 (needed by amarok)
    libredland0 (needed by several KDE packages
    etc.

  10. #10

    Default Re: KDE 4.11 upgrade on openSUSE 12.3

    Quote Originally Posted by DJViking View Post
    Virtuoso
    PackageKit
    k3b
    kaffeine
    kmymoney
    krename
    liblastfm1
    libredland0
    Just downgrade them, they're the same versions anyway.
    And some of them are not even in KDE:Release:410 either.

    etc.
    For "etc." I cannot tell, but I guess it's safe to downgrade them all as well.
    If you get conflicts then, better ask again with the exact conflict message.
    Last edited by wolfi323; 19-Aug-2013 at 12:51. Reason: added a smiley ;)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •