Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Updates on August 9th killed my texlive/latex installation

  1. #1
    Join Date
    Nov 2009
    Posts
    11

    Default Updates on August 9th killed my texlive/latex installation

    Hi,

    after installting the texlive updates on August 9th into my OpenSuse 12.3 final I cannot compile any document anymore. The updates on Augsut 17th did not help. I already files a bug

    https://bugzilla.novell.com/show_bug.cgi?id=834278

    however, noone answered yet.

    $ latex example.tex
    cb@betty:~/source/habil> latex habil.tex
    warning: kpathsea: /etc/texmf/ls-R: No usable entries in ls-R.
    warning: kpathsea: See the manual for how to generate ls-R.
    warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R.
    warning: kpathsea: See the manual for how to generate ls-R.
    warning: kpathsea: /var/cache/texmf/fonts/ls-R: No usable entries in ls-R.
    warning: kpathsea: See the manual for how to generate ls-R.
    This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/TeX Live for SUSE Linux)
    restricted \write18 enabled.
    kpathsea: Running mktexfmt latex.fmt
    warning: kpathsea: /etc/texmf/ls-R: No usable entries in ls-R.
    warning: kpathsea: See the manual for how to generate ls-R.
    warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R.
    warning: kpathsea: See the manual for how to generate ls-R.
    warning: kpathsea: /var/cache/texmf/fonts/ls-R: No usable entries in ls-R.
    warning: kpathsea: See the manual for how to generate ls-R.
    tcfmgr: config file `tcfmgr.map' (usually in $TEXMFMAIN/texconfig) not found (ls-R missing?).
    fmtutil: config file `fmtutil.cnf' not found.
    I can't find the format file `latex.fmt'!

    $ texhash
    public: texhash: Success
    $ mktexlsr --verbose
    public: mktexlsr: Success

    does nothing.

    Please help.

    Thanx in advance,

    Chris

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates on August 9th killed my texlive/latex installation

    On 2013-08-17 10:46, chba wrote:
    >
    > Hi,
    >
    > after installting the texlive updates on August 9th into my OpenSuse


    There was a bunch of texlive updates yesterday, too.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    Join Date
    Nov 2009
    Posts
    11

    Default Re: Updates on August 9th killed my texlive/latex installation

    > There was a bunch of texlive updates yesterday, too.

    right. However, as written above, these updates did not change the Situation.

    @Carlos (and all others)
    Does your latex operate as desired? Could you please try to compile some document?

    Thx, Chris

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,874
    Blog Entries
    3

    Default Re: Updates on August 9th killed my texlive/latex installation

    Quote Originally Posted by chba View Post
    @Carlos (and all others)
    Does your latex operate as desired? Could you please try to compile some document?
    I just tried. It is working fine for me.

    Check whether you have a disk partition that is full. Maybe there wasn't space to build the database to find tex components.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates on August 9th killed my texlive/latex installation

    On 2013-08-17 13:16, chba wrote:
    >
    >> There was a bunch of texlive updates yesterday, too.

    >
    > right. However, as written above, these updates did not change the
    > Situation.
    >
    > @Carlos (and all others)
    > Does your latex operate as desired? Could you please try to compile
    > some document?


    Sorry, I don't really know why I have latex installed, as what I use is
    LyX sometimes. Only some conversions seem to use latex.

    If there is some latex sample document you know about that can be tried,
    I will.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6
    Join Date
    Nov 2009
    Posts
    11

    Default Re: Updates on August 9th killed my texlive/latex installation

    Quote Originally Posted by nrickert View Post
    I just tried. It is working fine for me.

    Check whether you have a disk partition that is full. Maybe there wasn't space to build the database to find tex components.
    My Partition has definitvely more than enough free space. Is there another command similar to texhash or mktexlsr to execute. It seems like some paths are not set correctly, and/or some config files fmtutil ... are missing or at the wrong place .


    A possible texfile would be:

    \documentclasss{article}

    \begin{document}
    Hello, World!
    \end{document}

    Just write it as plain text into a file example.tex and run latex example.tex .
    Before the updates all things worked fine.

    Thx again

    Chris

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates on August 9th killed my texlive/latex installation

    On 2013-08-17 15:26, chba wrote:
    >
    > nrickert;2579764 Wrote:
    >> I just tried. It is working fine for me.
    >>
    >> Check whether you have a disk partition that is full. Maybe there
    >> wasn't space to build the database to find tex components.

    >
    > My Partition has definitvely more than enough free space. Is there
    > another command similar to texhash or mktexlsr to execute. It seems like
    > some paths are not set correctly, and/or some config files fmtutil ...
    > are missing or at the wrong place .
    >
    >
    > A possible texfile would be:
    >
    > \documentclasss{article}
    >
    > \begin{document}
    > Hello, World!
    > \end{document}
    >
    > Just write it as plain text into a file example.tex and run latex
    > example.tex .
    > Before the updates all things worked fine.


    Code:
    
    > File example.tex saved
    > cer@Telcontar:~/tmp/latex> latex example.tex
    > This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/TeX Live for SUSE Linux)
    >  restricted \write18 enabled.
    > entering extended mode
    > (./example.tex
    > LaTeX2e <2011/06/27>
    > Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
    > rman-x-2011-07-01, ngerman-x-2011-07-01, afrikaans, ancientgreek, ibycus, arabi
    > c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
    > h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
    > h, french, friulan, galician, german, ngerman, swissgerman, monogreek, greek, h
    > ungarian, icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, ma
    > rathi, oriya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian,
    > kurmanji, lao, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nyn
    > orsk, polish, portuguese, romanian, romansh, russian, sanskrit, serbian, serbia
    > nc, slovak, slovenian, spanish, swedish, turkish, turkmen, ukrainian, uppersorb
    > ian, welsh, loaded.
    > ! Undefined control sequence.
    > l.1 \documentclasss
    >                    {article}
    > ? ^C! Interruption.
    > <to be read again>
    >                    {
    > l.1 \documentclasss{
    >                     article}
    > ? ^C^C^CTerminated
    > cer@Telcontar:~/tmp/latex>
    > cer@Telcontar:~/tmp/latex> cat example.tex
    > \documentclasss{article}
    >
    > \begin{document}
    > Hello, World!
    > \end{document}
    > cer@Telcontar:~/tmp/latex>

    I had to kill latex to exit.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,874
    Blog Entries
    3

    Default Re: Updates on August 9th killed my texlive/latex installation

    Quote Originally Posted by chba View Post
    A possible texfile would be:

    \documentclasss{article}

    \begin{document}
    Hello, World!
    \end{document}
    I had tested with a more complicated tex source file than that.

    However, I retested with your file. And it failed:
    Code:
    ! Undefined control sequence.
    l.1 \documentclasss
                       {article}
    However, once I fixed the spelling mistake, it worked.
    Code:
    (/usr/share/texmf/tex/latex/base/article.cls
    Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (/usr/share/texmf/tex/latex/base/size10.clo))
    No file example.aux.
    [1] (./example.aux) )
    Output written on example.dvi (1 page, 232 bytes).
    Transcript written on example.log.
    (and no, I am not suggesting that the problem you are having is due to a spelling mistake).

    (added in edit): I'll add that my test is after applying yesterday's latex patch. I don't think I used latex between the first and the second of the two recent patches.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Nov 2009
    Posts
    11

    Default Re: Updates on August 9th killed my texlive/latex installation

    Sorry for the spelling mistake,
    \documentclass should have only two instead of three s .

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates on August 9th killed my texlive/latex installation

    On 2013-08-17 16:56, chba wrote:
    >
    > Sorry for the spelling mistake,
    > \documentclass should have only two instead of three s .


    Ah! Ok, with that change it compiles correctly and I can display the
    resulting dvi.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •