Results 1 to 5 of 5

Thread: Password request on Shutdown/reboot.

  1. #1
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Password request on Shutdown/reboot.

    Hi guys, I have read, and tried the suggestions here:
    https://forums.opensuse.org/english/...utdown-pc.html
    And here:
    https://forums.opensuse.org/english/...-shutdown.html

    But I still have to enter root password to shutdown or reboot. I am currently using 12.3 with KDE 4.10.5

    If I log on as a different user, I do not have to enter the PW.

    I have recently zypper dup from 12.2 to 12.3, but this problem was there with 12.2 as well.

    Any ideas please?

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Password request on Shutdown/reboot.

    Quote Originally Posted by wakou View Post
    Hi guys, I have read, and tried the suggestions here:
    https://forums.opensuse.org/english/...utdown-pc.html
    And here:
    https://forums.opensuse.org/english/...-shutdown.html

    But I still have to enter root password to shutdown or reboot. I am currently using 12.3 with KDE 4.10.5

    If I log on as a different user, I do not have to enter the PW.

    I have recently zypper dup from 12.2 to 12.3, but this problem was there with 12.2 as well.

    Any ideas please?
    So in KDE if you go to Configure Desktop / System Administration / Startup and Shutdown / Session Management / Under General, it Does allow to Offer Shutdown? In the same section, try On Login, Start with an Empty Session. Have you or do you use KWallet? Do you use a Wireless network connection? Can we assume you do not startup the PC as root. What user groups do you belong to?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Password request on Shutdown/reboot.

    Quote Originally Posted by jdmcdaniel3 View Post
    So in KDE if you go to Configure Desktop / System Administration / Startup and Shutdown / Session Management / Under General, it Does allow to Offer Shutdown? In the same section, try On Login, Start with an Empty Session. Have you or do you use KWallet? Do you use a Wireless network connection? Can we assume you do not startup the PC as root. What user groups do you belong to?

    Thank You,
    Thank-you James.....
    Starting from the last of your questions...
    User groups: video;users (same as my 'other' user, btw)
    I do NOT start up as root (!)
    I connect using a wired ethernet connection
    I HAVE kwallet, but for some reason, none of my apps access it nowadays.... I don't know why!

    Configure Desktop / System Administration / Startup and Shutdown / Session Management / General, is set to 'offer shutdown options'
    I have changed login from 'restore session' to 'empty session' and am trying it now.....

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  4. #4
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Password request on Shutdown/reboot.

    ! and !! and What?

    I could have spent five years on this and never would have come to the conclusion that changing login to 'start with empty session' could or would ever have an effect on this shutdown behaviour. But it did, and now it shuts down cleanly. Thank-you James. I cannot pretend to understand, and nor will I ever. But it worked.

    ps It was using your instructions that I upped to 12.3 the other day. You might wish to add that those using non OSS video drivers (I use NVidia, the 'hard' way) will have to re-install them after the dup, as the kernel is different. Apart from that, all went perfectly smoothly.

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Password request on Shutdown/reboot.

    Quote Originally Posted by wakou View Post
    ! and !! and What?

    I could have spent five years on this and never would have come to the conclusion that changing login to 'start with empty session' could or would ever have an effect on this shutdown behaviour. But it did, and now it shuts down cleanly. Thank-you James. I cannot pretend to understand, and nor will I ever. But it worked.

    ps It was using your instructions that I upped to 12.3 the other day. You might wish to add that those using non OSS video drivers (I use NVidia, the 'hard' way) will have to re-install them after the dup, as the kernel is different. Apart from that, all went perfectly smoothly.
    Ours is not to reason why, but to only do or, well you know, follow the suggestions of our elders. Seems like not starting an empty session can get some hangers on in the mix and using an empty session is the fix. I love to have a success story in the morning and I was very happy to help. On the upgrade story, it is true that for any kernel update, proprietary video drivers must be reinstalled. I will see if I can put that info in the narrative as you suggest.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •