Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: libdb problem

  1. #1

    Default libdb problem

    Hi,

    I'm trying to install a program, but it requires Berkeley DB C++ library (including headers: db.h db_cxx.h). I'm running OpenSuSE 11.2 64-bit and I have libdb-4_5 and libdb-4_5-devel installed, but db_cxx.h is nowhere to be found. I have googled with not luck, so I'm hoping someone on here can help.

    Thanks,

    -matt

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,124

    Default Re: libdb problem

    I guess that is a bit of a problem because 11.2 is long out of support. It is still possible to find repos for 11.2 (e.g. at: ftp://ftp5.gwdg.de/pub/opensuse/disc...11.2/repo/oss/ ), but I doubt there is more there then there was at the end of 11.2's life.
    Henk van Velden

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: libdb problem

    Dot h files are headers you would need the source for that package installed. Where to find that for 11.2 is the problem

  4. #4

    Default Re: libdb problem

    Quote Originally Posted by gogalthorp View Post
    Dot h files are headers you would need the source for that package installed. Where to find that for 11.2 is the problem
    No, the file "db_cxx.h" should be in libdb-4_5-devel, and according to "pin" it is there in 12.3:
    Code:
    wolfi@amiga:~> pin db_cxx.h
    pin 0.38 - package info for db_cxx.h
    
    ------------------------------------------------------------------
    *** no rpm named db_cxx.h installed
    ------------------------------------------------------------------
    
    
    
    
    ------------------------------------------------------------------
    *** zgrep db_cxx.h /var/lib/pin/ARCHIVES.gz
    ------------------------------------------------------------------
    ...
    ./suse/x86_64/libdb-4_5-devel-4.5.20-122.1.2.x86_64.rpm:    -r--r--r--    1 root    root                    37258 Jan 27 00:31 /usr/include/db4/db_cxx.h
    ./suse/x86_64/libdb-4_5-devel-4.5.20-122.1.2.x86_64.rpm:    -rw-r--r--    1 root    root                       24 Jan 27 00:34 /usr/include/db_cxx.h
    ...
    ./suse/i586/libdb-4_5-devel-4.5.20-122.1.2.i586.rpm:    -r--r--r--    1 root    root                    37258 Jan 27 00:42 /usr/include/db4/db_cxx.h
    ./suse/i586/libdb-4_5-devel-4.5.20-122.1.2.i586.rpm:    -rw-r--r--    1 root    root                       24 Jan 27 00:43 /usr/include/db_cxx.h
    ...
    So maybe there's a packaging bug in 11.2, but who's going to fix that now?

    I guess the best thing would be to ask on the Evergreen mailinglist, since they still support 11.2 till November 2013​:
    Evergreen Info Page

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libdb problem

    On 2013-08-07 16:56, hcvv wrote:
    >
    > I guess that is a bit of a problem because 11.2 is long out of support.
    > It is still possible to find repos for 11.2 (e.g. at:
    > http://tinyurl.com/42u92hm ), but I doubt there is more there then there
    > was at the end of 11.2's life.


    11.2 is still supported under Evergreen, till Nov 3013.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libdb problem

    On 2013-08-07 21:16, gogalthorp wrote:
    >
    > Dot h files are headers you would need the source for that package
    > installed. Where to find that for 11.2 is the problem


    Source, or -devel package? I can not check now, limited internet.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  7. #7

    Default Re: libdb problem

    Quote Originally Posted by wolfi323 View Post
    I guess the best thing would be to ask on the Evergreen mailinglist, since they still support 11.2 till November 2013​:
    Evergreen Info Page
    PS: For more information on the Evergreen project, see here if you don't know it already (you really should if you're still using 11.2):
    https://en.opensuse.org/openSUSE:Evergreen

  8. #8

    Default Re: libdb problem

    Quote Originally Posted by robin_listas View Post
    11.2 is still supported under Evergreen, till Nov 3013.
    I don't think they will support it that long...

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libdb problem

    On 2013-08-07 21:56, wolfi323 wrote:
    >
    > robin_listas;2577563 Wrote:
    >>
    >> 11.2 is still supported under Evergreen, till Nov 3013.
    >>

    > I don't think they will support it -that- long...


    AHHHH! O:-)


    (laptop keyboard...)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  10. #10

    Default Re: libdb problem

    Quote Originally Posted by robin_listas View Post
    On 2013-08-07 21:56, wolfi323 wrote:
    >
    > robin_listas;2577563 Wrote:
    >>
    >> 11.2 is still supported under Evergreen, till Nov 3013.
    >>

    > I don't think they will support it -that- long...


    AHHHH! O:-)


    (laptop keyboard...)
    Yeah, it was clear to me that this was a typo. But I HAD to reply, sorry...
    No offense meant, I hope none is taken.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •