Results 1 to 10 of 10

Thread: Firefox KDE Integration doesn't work anymore

  1. #1

    Default Firefox KDE Integration doesn't work anymore

    I have installed Firefox 21 , openSUSE 12.3

    List of installed Firefox packages:

    Code:
    MozillaFirefox-21.0-1.18.1.x86_64
    MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64
    MozillaFirefox-translations-common-21.0-1.18.1.x86_64
    mozilla-nspr-4.10-1.1.x86_64
    mozilla-nss-certs-3.14.3-1.8.1.x86_64
    mozilla-nss-3.15.1-1.1.x86_64
    ca-certificates-mozilla-1.85-3.1.1.noarch
    libstartup-notification-1-0-0.12-7.1.1.x86_64
    What should I check?

    Thank you in advance.

  2. #2

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by Napas View Post
    I have installed Firefox 21 , openSUSE 12.3

    List of installed Firefox packages:

    Code:
    MozillaFirefox-21.0-1.18.1.x86_64
    MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64
    MozillaFirefox-translations-common-21.0-1.18.1.x86_64
    mozilla-nspr-4.10-1.1.x86_64
    mozilla-nss-certs-3.14.3-1.8.1.x86_64
    mozilla-nss-3.15.1-1.1.x86_64
    ca-certificates-mozilla-1.85-3.1.1.noarch
    libstartup-notification-1-0-0.12-7.1.1.x86_64
    What should I check?

    Thank you in advance.
    Where did you install that from?
    Firefox is already at version 22 in the standard update repo. So please check your updates...
    Also you seem to have a mixture of versions from different repos there.

    The current versions from the standard 12.3 repos (oss and update) are:
    Code:
    MozillaFirefox-22.0-1.25.1.x86_64
    MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64
    MozillaFirefox-translations-common-22.0-1.25.1.x86_64
    mozilla-nspr-4.9.6-1.10.1.x86_64
    mozilla-nss-certs-3.14.3-1.8.1.x86_64
    mozilla-nss-3.14.3-1.8.1.x86_64
    ca-certificates-mozilla-1.85-3.1.1.noarch
    libstartup-notification-1-0-0.12-7.1.1.x86_64
    With those packages the KDE integrations works fine on my system.

  3. #3

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by wolfi323 View Post
    Where did you install that from?
    Firefox is already at version 22 in the standard update repo. So please check your updates...
    Also you seem to have a mixture of versions from different repos there.

    The current versions from the standard 12.3 repos (oss and update) are:
    Code:
    MozillaFirefox-22.0-1.25.1.x86_64
    MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64
    MozillaFirefox-translations-common-22.0-1.25.1.x86_64
    mozilla-nspr-4.9.6-1.10.1.x86_64
    mozilla-nss-certs-3.14.3-1.8.1.x86_64
    mozilla-nss-3.14.3-1.8.1.x86_64
    ca-certificates-mozilla-1.85-3.1.1.noarch
    libstartup-notification-1-0-0.12-7.1.1.x86_64
    With those packages the KDE integrations works fine on my system.
    So, right by now I have updated Firefox to 22 version from updates-repo, and it doesn't works I have an integration extension enabled, but the main problem is I haven't notifications enabled by ending of downloading file and the second one is I have Gnome menu "open a file..." instead of KDE

  4. #4

    Default Re: Firefox KDE Integration doesn't work anymore

    Does it work for a new user or if you rename the directory ~/.mozilla ?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by Napas View Post
    So, right by now I have updated Firefox to 22 version from updates-repo, and it doesn't works I have an integration extension enabled, but the main problem is I haven't notifications enabled by ending of downloading file and the second one is I have Gnome menu "open a file..." instead of KDE
    Why didn't you show the same information as in your first post, so we can check? Now we have on ly your vague description on what you did, but no facts.
    Henk van Velden

  6. #6

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by wolfi323 View Post
    Does it work for a new user or if you rename the directory ~/.mozilla ?
    I've created a new user, and unfortunately the same result : no kde-dialog in "open a file.." and notifications is showing without using kde-notifications.

    I suppose there can be another different packages which isn't installed on my system? I used to delete packages with their full dependencies.

  7. #7

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by Napas View Post
    I've created a new user, and unfortunately the same result : no kde-dialog in "open a file.." and notifications is showing without using kde-notifications.

    I suppose there can be another different packages which isn't installed on my system? I used to delete packages with their full dependencies.
    Yes, there's "mozilla-kde4-integration", do you have that installed?

    Here's a list of all packages containing the word "mozilla" on my system:
    Code:
    wolfi@amiga:~/Desktop> rpm -qa |grep -i mozilla
    mozilla-nspr-4.9.6-1.10.1.x86_64
    mozilla-kde4-integration-0.6.4-2.1.1.x86_64
    MozillaFirefox-22.0-1.25.1.x86_64
    ca-certificates-mozilla-1.85-3.1.1.noarch
    mozilla-nss-3.14.3-1.8.1.x86_64
    mozilla-js-17.0.7-1.20.1.x86_64
    mozilla-nspr-devel-4.9.6-1.10.1.x86_64
    MozillaFirefox-translations-common-22.0-1.25.1.x86_64
    mozilla-nss-devel-3.14.3-1.8.1.x86_64
    mozilla-nss-certs-3.14.3-1.8.1.x86_64
    MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64

  8. #8

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by wolfi323 View Post
    Yes, there's "mozilla-kde4-integration", do you have that installed?

    Here's a list of all packages containing the word "mozilla" on my system:
    Code:
    wolfi@amiga:~/Desktop> rpm -qa |grep -i mozilla
    mozilla-nspr-4.9.6-1.10.1.x86_64
    mozilla-kde4-integration-0.6.4-2.1.1.x86_64
    MozillaFirefox-22.0-1.25.1.x86_64
    ca-certificates-mozilla-1.85-3.1.1.noarch
    mozilla-nss-3.14.3-1.8.1.x86_64
    mozilla-js-17.0.7-1.20.1.x86_64
    mozilla-nspr-devel-4.9.6-1.10.1.x86_64
    MozillaFirefox-translations-common-22.0-1.25.1.x86_64
    mozilla-nss-devel-3.14.3-1.8.1.x86_64
    mozilla-nss-certs-3.14.3-1.8.1.x86_64
    MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64
    Cheers, man! After installing mozilla-kde4-integration , Firefox works correctly now!

    Thank in advance, problem is solved!


  9. #9

    Default Re: Firefox KDE Integration doesn't work anymore

    Firefox is NOW at version 23
    it came out two days ago



  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Firefox KDE Integration doesn't work anymore

    Quote Originally Posted by JohnVV View Post
    Firefox is NOW at version 23
    it came out two days ago
    it'll probably be a little while before it makes its way to the oss-update repo though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •