Results 1 to 6 of 6

Thread: Compose Key does not work at all

  1. #1

    Default Compose Key does not work at all

    Hi,

    on my new Acer Aspire V5 laptop, I installed openSUSE 12.3 (64bit) with KDE desktop.

    However, it seems impossible to get the Compose key to work. In Configure Desktop -> Input Devices -> Keyboard -> Advanced, there is an option Compose Key Position. I chose Menu and expected that the Menu Key would act as a Compose Key henceafter. It didn't.

    xev tells me that the Menu Key has keycode 135. xmodmap -pk | grep 135 indeed gives the line
    135 0xff20 (Multi_key) 0xff20 (Multi_key) 0xff20 (Multi_key) 0xff20 (Multi_key)
    Everything seems fine, except that the key does not work as expected. Typing the sequence
    <menu><double quote><a> gives the two characters "a separately, not the expected single ä.

    Disabling the Compose key in Configure Desktop etc will reset the xmodmap output to
    135 0xff67 (Menu) 0x0000 (NoSymbol) 0xff67 (Menu)
    which seems perfectly normal.

    But why, then, is the Compose Key never active?


    My locale is
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    and yes, there is is a file /usr/share/X11/locale/en_US.UTF-8/Compose containing the line
    <Multi_key> <quotedbl> <a> : "ä" adiaeresis # LATIN SMALL LETTER A WITH DIAERESIS

    The KDE Keyboard Settings dialogue claims my keyboard is "Generic | Generic 101-key PC" which I have no reason to doubt.

    Warm regards,
    Gernot

  2. #2

    Default Re: Compose Key does not work at all

    Since nobody has answered, I must have done something wrong in describing the problem. Let's try again.

    A compose key is a key that allows to enter entire Unicode character strings with a few keystroke; typically, the strings are short (one more or less exotic letter, or one latter with some accent decoration). It is typically used to extend the range of the keyboard, i.e., to enter characters that are not found on the keyboard. While this can often be done by switching keyboard layouts, the compose key is much more general (which keyboard has, for example, ṭ or p̣ [both with dots below], which are common characters in the transliteration of Caucasian or Ethiopian languages?).

    As far as I understand it, the Compose Key is built into the X Windows System, and thus works whenever X is available. The compose sequences are defined in /usr/share/X11/locale/*/Compose depending on the locale. Each X application reads the Compose file on startup an remembers the Compose sequences defined therein. For example, the sequence <single quote> <a> is defined to yield an accented á. Each sequence must be introduced by hitting the specific key on the Keyboard, the Compose key; so a typical accented character is available by three keystrokes.

    The Compose key is assigned to some arbitrary key; typically, Menu, Win, Right Alt or something similar is chosen. This is done with xmodmap, but KDE offers some predefined choices in Configure Destop => Input Devices => Keyboard => Advanced.

    Now the problem with my new openSUSE 12.3 installation is that the Compose key seems to do exactly nothing, and the following two keystrokes, which should be interpreted as a Compose sequence, end up as characters as I type. There is a conflict between the output of xmodmap -pke, which says that the key 135 (Menu, according to xev) is Multi_key (=Compose key), and the fact that hitting Menu followed by a compose sequence does nothing useful.

    Is this likely a hardware support problem (The Laptop is an Indian model not in any way designed for openSUSE)? I not it is recognized as 'Generic 101 key PC', but has only 84 keys at best. Any clues?

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Compose Key does not work at all

    On 08/05/2013 02:16 PM, masala wallah wrote:
    > Since nobody has answered, I must have done something wrong in
    > describing the problem.


    i read your question and remembered there was a similar question in
    these forums not very long ago (at the time i had to google "compose
    key" to understand the question)--i didn't remember the outcome or
    'answer' to your problem...so, thought another user here might...and,
    might answer......but:

    have a look at these and see if you can find anything helpful
    https://www.google.com/search?q=site...se+key"+"12.3"

    however, since you wrote your keyboard "has only 84 keys at best" you
    might find a smile just by selecting a different keyboard (in
    Configure Desktop > Hardware > Input Devices..)

    but if that search and hint didn't find the info you need then try
    this one
    https://www.google.com/search?q=site...+"compose+key"

    and this one from the documentation section of our wiki might be
    helpful also
    https://www.google.com/search?q=site...+"compose+key"

    if you can't find a workable solution in any of those you might have
    discovered a bug, either in the system or in the documentation...so,
    let us hear from you again please....smiling or not..

    --
    dd
    http://tinyurl.com/DD-Caveat
    http://tinyurl.com/DD-Complaints

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,183
    Blog Entries
    3

    Default Re: Compose Key does not work at all

    Quote Originally Posted by masala_wallah View Post
    Since nobody has answered, I must have done something wrong in describing the problem.
    I am successfully using the right Windows key (flag key) as a compose key.

    I did not answer your post, because I don't know how to help with your specific problem. "xev" tells me that right windows key has a keycode of 134, and it agrees with you that the menu key has a keycode of 135.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: Compose Key does not work at all

    Quote Originally Posted by nrickert View Post
    I am successfully using the right Windows key (flag key) as a compose key.
    Obviously you are luckier than me.

    I tried to use xmodmap directly to create a compose key, by creating a file with the three lines
    remove Control = Control_R
    keysym Control_R = Multi_key
    add Control = Control_R
    and running xmodmap on it (lines taken from /ect/X11/Xmodmap). Same negative result.

    I'll try a USB keyboard to rule out any chance that the problem is related to the particular keyboard.
    Maybe I will be able to find one tomorrow.

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Compose Key does not work at all

    On Mon, 05 Aug 2013 16:26:02 +0000, nrickert wrote:

    > masala_wallah;2576962 Wrote:
    >> Since nobody has answered, I must have done something wrong in
    >> describing the problem.

    >
    > I am successfully using the right Windows key (flag key) as a compose
    > key.
    >
    > I did not answer your post, because I don't know how to help with your
    > specific problem. "xev" tells me that right windows key has a keycode
    > of 134, and it agrees with you that the menu key has a keycode of 135.


    I am as well (GNOME desktop here, so I figured my experience wasn't
    relevant since the OP is using KDE), and it works fine here. I had no
    advice, so I didn't respond.

    OP: No answers doesn't mean you did anything wrong in describing the
    problem - it can also mean that nobody has an idea of how to help you.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •