Results 1 to 2 of 2

Thread: synaptiks window will not open

  1. #1
    Join Date
    Feb 2012
    Location
    Halifax, NS
    Posts
    22

    Default synaptiks window will not open

    Hello,

    I'm running 12.3 64 bit with kde
    Code:
    linux-7v9h:/etc/X11/xorg.conf.d # synaptiks -v
    Qt: 4.8.4
    KDE Development Platform: 4.10.5 "release 1"
    synaptiks: 0.8.1
    linux-7v9h:/etc/X11/xorg.conf.d #
    recently I have had a problem with the synaptik window not opening alongside freezing occurring when the laptop(Sony Vaio) comes out of sleep.

    The package has not been modified and has been purged/re-installed clean in order to ensure that this was not a "me" thing.

    I have furthermore reviewed a file referred to in other posts:
    Code:
    linux-7v9h:~ # rpm -fq /etc/X11/xorg.conf.d/50-synaptics.conf
    xf86-input-synaptics-1.6.3-1.1.1.x86_64
    linux-7v9h:~ # rpm -V xf86-input-synaptics-1.6.3-1.1.1.x86_64
    linux-7v9h:~ #
    The icon appears in the application panel, and responds properly to right click
    I have the ability to disable my touchpad from this action as well by custom hot-key configuration (ctrl-alt-t)
    The expected behavior is that when I click on the "Synaptik" icon a configuration window would appear.

    any suggestions are greatly appreciated.

    C

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: synaptiks window will not open

    I've only just stumbled across this thread, while responding to another user with a different synaptiks issue. Anyway, I became aware that I had the same issue as you've described (I'm have openSUSE 12.2 installed)

    Code:
    synaptiks -v
    Qt: 4.8.4
    KDE Development Platform: 4.10.5 "release 4"
    synaptiks: 0.8.1
    I found a couple of bugs related to python, for different openSUSE versions (but more related to python version conflicts):

    https://bugzilla.novell.com/show_bug.cgi?id=799925
    https://bugzilla.novell.com/show_bug.cgi?id=785078

    When I was attempting to start synaptiks from the command prompt, I was getting the same errors reported as in the above bug reports.

    Anyway, I found the solution that worked for me was some manual package management, including the upgrading of upgrade python-sip, which involved downgrading python-kt4, then re-installing python-qt4 (with an alternative package)
    Code:
    # zypper up python-sip
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: qt4-qtscript-0.2.0-20.5.x86_64 requires libqt4 = 4.8.4, but this 
    requirement cannot be provided
      deleted providers: libqt4-4.8.4-313.1.x86_64
     Solution 1: downgrade of python-qt4-4.10-104.4.x86_64 to 
    python-qt4-4.9.1-2.1.2.x86_64
     Solution 2: downgrade of qt4-qtscript-0.2.0-20.5.x86_64 to 
    qt4-qtscript-0.2.0-2.1.x86_64
     Solution 3: do not install python-sip-4.14.7-106.1.x86_64
     Solution 4: do not install python-sip-4.14.7-106.1.x86_64
     Solution 5: break qt4-qtscript-0.2.0-20.5.x86_64 by ignoring some of its 
    dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/5/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    The following package is going to be upgraded:
      python-sip 
    
    The following package is going to be downgraded:
      python-qt4 
    
    The following package is going to change vendor:
      python-qt4  obs://build.opensuse.org/KDE -> openSUSE
    
    
    1 package to upgrade, 1 to downgrade, 1 to change vendor.
    Overall download size: 3.2 MiB. After the operation, 76.8 KiB will be 
    freed.
    Continue? [y/n/?] (y): y
    Retrieving package python-sip-4.14.7-106.1.x86_64                       
    (1/2),  57.0 KiB (125.9 KiB unpacked)
    Retrieving: python-sip-4.14.7-106.1.x86_64.rpm 
    ...........................................[done (17.5 KiB/s)]
    Retrieving package python-qt4-4.9.1-2.1.2.x86_64                        
    (2/2),   3.2 MiB ( 19.4 MiB unpacked)
    Retrieving: python-qt4-4.9.1-2.1.2.x86_64.rpm 
    .............................................[done (1.1 MiB/s)]
    Installing: python-sip-4.14.7-106.1 
    ...................................................................[done]
    Installing: python-qt4-4.9.1-2.1.2 
    ....................................................................[done]
    linux-akl:~ # zypper up python-qt4
    Loading repository data...
    Reading installed packages...
    There is an update candidate for 'python-qt4', but it is from different 
    vendor. Use 'zypper install python-qt4-4.10.2-110.1.x86_64' to install 
    this candidate.
    Resolving package dependencies...
    
    Nothing to do.
    linux-akl:~ # zypper install python-qt4-4.10.2
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: python-qt4-4.10.2-110.1.x86_64 requires libqt4-x11 >= 4.8.5, but 
    this requirement cannot be provided
      uninstallable providers: libqt4-x11-4.8.5-325.1.i586[kde410]
                       libqt4-x11-4.8.5-325.1.x86_64[kde410]
     Solution 1: downgrade of qt4-qtscript-0.2.0-20.5.x86_64 to 
    qt4-qtscript-0.2.0-2.1.x86_64
     Solution 2: do not install python-qt4-4.10.2-110.1.x86_64
     Solution 3: do not install python-qt4-4.10.2-110.1.x86_64
     Solution 4: break python-qt4-4.10.2-110.1.x86_64 by ignoring some of its 
    dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c] (c): 4
    Resolving dependencies...
    Resolving package dependencies...
    
    The following package is going to be upgraded:
      python-qt4 
    
    The following package is going to change vendor:
      python-qt4  openSUSE -> obs://build.opensuse.org/KDE
    
    
    1 package to upgrade, 1 to change vendor.
    Overall download size: 3.2 MiB. After the operation, additional 96.3 KiB 
    will be 
    used.
    Continue? [y/n/?] (y): y
    Retrieving package python-qt4-4.10.2-110.1.x86_64
                                                (1/1),   3.2 MiB ( 19.5 MiB 
    unpacked)
    Retrieving: python-qt4-4.10.2-110.1.x86_64.rpm ..............[done (425.1 
    KiB/s)]
    Installing: python-qt4-4.10.2-110.1 
    .......................................[done]
    I could then start synaptiks from the CLI again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •