Results 1 to 7 of 7

Thread: YAST2 errror couldn't load plugin in qt-pkg

  1. #1

    Default YAST2 errror couldn't load plugin in qt-pkg

    After a failed install I get when trying to use YAST to install software:

    couldn't load plugin in qt-pkg

    The log is:

    terminate called after throwing an instance of 'YUINoDialogException'
    what(): No dialog existing
    YaST got signal 6 at YCP file /usr/share/YaST2/clients/sw_single.ycp:721
    /sbin/yast2: line 431: 9842 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    zypper is working

    openSUSE 12.3 (64 bit) - gnome desktop

    I have not found any solution after google and searching the forums that worked. (zypper up & zypper dup)

    I am tempted to try removing and reinstalling yast via zypper.

  2. #2

    Default Re: YAST2 errror couldn't load plugin in qt-pkg

    Are you explicitely trying to start the Qt interface? (by specifying "--qt" on the command line or configuring it in /etc/sysconfig/yast2)

    Because normally on GNOME the GTK interface should be used.

    Does it work if you type the following into a terminal window?
    Code:
    gnomesu -c "/sbin/yast2 --gtk"
    To make the Qt version work, this should help:
    Code:
    sudo zypper in -f libyui-qt-pkg4

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YAST2 errror couldn't load plugin in qt-pkg

    On 2013-07-29 14:56, jslozier wrote:
    >
    > After a failed install I get when trying to use YAST to install
    > software:
    >
    > couldn't load plugin in qt-pkg


    Maybe you do not have installed "libyui-qt-pkg4" :-?


    > I have not found any solution after google and searching the forums
    > that worked. (zypper up & zypper dup)


    Why do you use "zypper dup"?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4

    Default Re: YAST2 errror couldn't load plugin in qt-pkg

    Quote Originally Posted by jslozier View Post
    After a failed install I get when trying to use YAST to install software:

    couldn't load plugin in qt-pkg

    The log is:

    terminate called after throwing an instance of 'YUINoDialogException'
    what(): No dialog existing
    YaST got signal 6 at YCP file /usr/share/YaST2/clients/sw_single.ycp:721
    /sbin/yast2: line 431: 9842 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    zypper is working

    openSUSE 12.3 (64 bit) - gnome desktop

    I have not found any solution after google and searching the forums that worked. (zypper up & zypper dup)

    I am tempted to try removing and reinstalling yast via zypper.
    The first command opened YAST and everything worked. After running the second command, opening YAST from the GUI worked correctly. The second command installed what was apparently a missing package.

    Thanks for the help

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: YAST2 errror couldn't load plugin in qt-pkg

    jslozier wrote:
    >
    > jslozier;2575324 Wrote:
    >> After a failed install I get when trying to use YAST to install
    >> software:
    >>
    >> couldn't load plugin in qt-pkg
    >>
    >> The log is:
    >>
    >> terminate called after throwing an instance of 'YUINoDialogException'
    >> what(): No dialog existing
    >> YaST got signal 6 at YCP file
    >> /usr/share/YaST2/clients/sw_single.ycp:721
    >> /sbin/yast2: line 431: 9842 Aborted $ybindir/y2base
    >> $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    >>
    >> zypper is working
    >>
    >> openSUSE 12.3 (64 bit) - gnome desktop
    >>
    >> I have not found any solution after google and searching the forums
    >> that worked. (zypper up & zypper dup)
    >>
    >> I am tempted to try removing and reinstalling yast via zypper.

    >
    > The first command opened YAST and everything worked. After running the
    > second command, opening YAST from the GUI worked correctly. The second
    > command installed what was apparently a missing package.
    >
    > Thanks for the help
    >
    >

    The package was not missing . If you use GNOME it is not installed.
    Also why didn't you invoke yast through activities ?
    left win/meta key ==> type "install" -==> click on install/remove
    software
    --
    GNOME 3.6.2
    openSUSE Release 12.3 (Dartmouth) 64-bit
    Kernel Linux 3.7.10-1.16-desktop

  6. #6

    Default Re: YAST2 errror couldn't load plugin in qt-pkg

    Quote Originally Posted by wolfi323 View Post
    Are you explicitely trying to start the Qt interface? (by specifying "--qt" on the command line or configuring it in /etc/sysconfig/yast2)

    Because normally on GNOME the GTK interface should be used.

    Does it work if you type the following into a terminal window?
    Code:
    gnomesu -c "/sbin/yast2 --gtk"
    To make the Qt version work, this should help:
    Code:
    sudo zypper in -f libyui-qt-pkg4
    I have just this bug after upgrade 12.3 to 13.1, all problem solve thrught install libyui-qt-pkg4 but pkg5...past two years after this tread. The cuestion is, any body think this is a bug for repport??? past two years and bug continue...i think this libyui-qt-pkg4 is need to add to yast2-qt dependencies...this was my only bug in dup great job for the firts time upgrade¡¡¡. Well and the skype in repo no work and need install download from skype.

  7. #7

    Default Re: YAST2 errror couldn't load plugin in qt-pkg

    Quote Originally Posted by juliandojal View Post
    I have just this bug after upgrade 12.3 to 13.1, all problem solve thrught install libyui-qt-pkg4 but pkg5...past two years after this tread. The cuestion is, any body think this is a bug for repport??? past two years and bug continue...i think this libyui-qt-pkg4 is need to add to yast2-qt dependencies...
    On 13.1 libyui-qt-pkg5 is needed, and it should be automatically installed by the patterns.
    It works in general, no idea why it didn't for you. Maybe you don't have the necessary patterns installed? Is this a KDE installation, or did you add KDE/YaST-Qt later on?

    Well and the skype in repo no work and need install download from skype.
    Which repo?
    There is no Skype included in openSUSE.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •