Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Unable to install Skype

  1. #1

    Default Unable to install Skype

    I am using 12.3 and running a 64 bit version. I downloaded the skype rpm package from the skype website (I chose the 12.1 32 bit version as that was the only one I found for openSUSE). However when running the rpm -i command it said It couldn’t find the file.

    Code:
    rpm -i skype-4.2.0.11-suse.i586.rpm                                                                                                                           
    error: open of skype-4.2.0.11-suse.i586.rpm failed: No such file or directory
    I also followed the instructions here to install some 32 bit packages in order to run skype. It was also unable to install all of the packages.

    Code:
    zypper install libqt4-32bit libqt4-x11-32bit libpng12-0-32bit libQtWebKit4-32bit xorg-x11-libs libXss1-32bit libpng12-0
    Loading repository data...
    Reading installed packages...
    Package 'libQtWebKit4-32bit' not found.
    Package 'libXss1-32bit' not found.
    Package 'xorg-x11-libs' not found.
    'libpng12-0' not found in package names. Trying capabilities.
    No provider of 'libpng12-0' found.
    'libpng12-0-32bit' is already installed.
    Package 'libpng12-0-32bit' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
    Resolving package dependencies...
    
    Problem: nothing provides libICE.so.6 needed by libqt4-x11-32bit-4.8.4-3.6.1.x86_64
     Solution 1: do not install libqt4-x11-32bit-4.8.4-3.6.1.x86_64
     Solution 2: break libqt4-x11-32bit-4.8.4-3.6.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): 2
    Resolving dependencies...
    Resolving package dependencies...
    
    The following NEW packages are going to be installed:
      libqt4-32bit libqt4-qt3support-32bit libqt4-sql-32bit libqt4-sql-sqlite-32bit libqt4-x11-32bit 
    
    5 new packages to install.
    Overall download size: 14.2 MiB. After the operation, additional 42.9 MiB will be used.
    Continue? [y/n/?] (y): y
    Retrieving package libqt4-32bit-4.8.4-3.6.1.x86_64                                                                                             (1/5),   3.1 MiB ( 10.6 MiB unpacked)
    Retrieving: libqt4-32bit-4.8.4-3.6.1.x86_64.rpm ..................................................................................................................[done (1.6 MiB/s)]
    Retrieving package libqt4-sql-32bit-4.8.4-3.6.1.x86_64                                                                                         (2/5), 106.3 KiB (254.1 KiB unpacked)
    Retrieving: libqt4-sql-32bit-4.8.4-3.6.1.x86_64.rpm ............................................................................................................[done (197.2 KiB/s)]
    Retrieving package libqt4-x11-32bit-4.8.4-3.6.1.x86_64                                                                                         (3/5),  10.0 MiB ( 29.0 MiB unpacked)
    Retrieving: libqt4-x11-32bit-4.8.4-3.6.1.x86_64.rpm ..............................................................................................................[done (1.7 MiB/s)]
    Retrieving package libqt4-sql-sqlite-32bit-4.8.4-3.6.1.x86_64                                                                                  (4/5),  35.1 KiB ( 50.1 KiB unpacked)
    Retrieving: libqt4-sql-sqlite-32bit-4.8.4-3.6.1.x86_64.rpm ...................................................................................................................[done]
    Retrieving package libqt4-qt3support-32bit-4.8.4-3.6.1.x86_64                                                                                 (5/5), 1014.6 KiB (  3.1 MiB unpacked)
    Retrieving: libqt4-qt3support-32bit-4.8.4-3.6.1.x86_64.rpm .......................................................................................................[done (1.5 MiB/s)]
    (1/5) Installing: libqt4-32bit-4.8.4-3.6.1 ...................................................................................................................................[done]
    (2/5) Installing: libqt4-sql-32bit-4.8.4-3.6.1 ...............................................................................................................................[done]
    (3/5) Installing: libqt4-x11-32bit-4.8.4-3.6.1 ...............................................................................................................................[done]
    (4/5) Installing: libqt4-sql-sqlite-32bit-4.8.4-3.6.1 ........................................................................................................................[done]
    (5/5) Installing: libqt4-qt3support-32bit-4.8.4-3.6.1 ........................................................................................................................[done]

    Any help is appreciated.

    Thank you

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Unable to install Skype

    To install the .rpm you have to be working in the same dir as the .rpm

    But you can just click/double click (depending on your settings) the .rpm and the software manager will install it

    Not sure about the missing deps, I don't use skype.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Unable to install Skype

    Just , says I need libQtWebKit.so.4 to install it. I then downloaded the libQtWebKit.so.4 file, but it says I need the libwebp.so.4 file. I am able to successfully install that file (I got it from here, tried installing both openSUSE versions). However when I try to install the libQtWebKit.so.4 file, it still says I am missing the libwebp.so.4 file.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Unable to install Skype

    8ofspades wrote:

    > still says I
    > am missing the libwebp.so.4 file.


    My system says libwebp4 provides this

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,589

    Default Re: Unable to install Skype

    You need the 32 bit versions for skype

  6. #6

    Default Re: Unable to install Skype

    Quote Originally Posted by 8ofspades View Post
    Just , says I need libQtWebKit.so.4 to install it. I then downloaded the libQtWebKit.so.4 file, but it says I need the libwebp.so.4 file. I am able to successfully install that file (I got it from here, tried installing both openSUSE versions). However when I try to install the libQtWebKit.so.4 file, it still says I am missing the libwebp.so.4 file.
    You should not use libwebp for Factory, all you need is included in the distribution.

    Just install libQtWebKit4-32bit with YaST (and make sure libwep4 is the version included in 12.3, so v0.2.1) or:
    Code:
    sudo zypper in -f libQtWebKit4-32bit libbwebp4

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to install Skype

    On 2013-07-29 05:56, 8ofspades wrote:
    >
    > Just , says I need libQtWebKit.so.4 to install it. I then downloaded the
    > libQtWebKit.so.4 file,


    Are you installing that file without installing the rpm? DON'T.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to install Skype

    On 2013-07-29 08:06, gogalthorp wrote:
    >
    > You need the 32 bit versions for skype


    If we are not mistaken, 8ofspades does not have the OSS repo. Just found
    that out on another thread (Yast 1 click install and zypper lock up
    during an install).

    So, he is unable to install "anything" >:-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,491
    Blog Entries
    37

    Default Re: Unable to install Skype

    I suspect a problem with the user's repositories.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to install Skype

    On 2013-07-29 15:56, oldcpu wrote:
    >
    > I suspect a problem with the user's repositories.


    Yes, absolutely. See the other thread.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •