Results 1 to 5 of 5

Thread: FFMpeg audio recording makes noise.

  1. #1

    Default FFMpeg audio recording makes noise.

    Hello.

    I'm using ffmpeg 2.0
    Code:
    ffmpeg version 2.0 Copyright (c) 2000-2013 the FFmpeg developers
    built on Jul 22 2013 19:48:32 with gcc 4.7 (SUSE Linux)
    And I'm recording via these parameters.
    Code:
    ffmpeg -f alsa -ac 2 -i hw:0 -f x11grab -r 30 -s 1600x900 -i :0.0 -acodec pcm_s16le -vcodec libx264 -threads 0 output.avi
    When I talk quietly, everything is ok, but when I talk normally or little bit loudly, in video is noise in background. I tried to record video on Windows with same microphone and everything was okay. Maybe I'm just running ffmpeg with bad audio codec, but I don't know.

    Does anybody know how to fix it?

    Here's the video, it could be available after 45 minutes of posting this thread.

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: FFMpeg audio recording makes noise.



    repakolius wrote:




    Hello. I'm using ffmpeg 2.0 Code: -------------------- ffmpeg version 2.0 Copyright (c) 2000-2013 the FFmpeg developers built on Jul 22 2013 19:48:32 with gcc 4.7 (SUSE Linux) -------------------- And I'm recording via these parameters. Code: -------------------- ffmpeg -f alsa -ac 2 -i hw:0 -f x11grab -r 30 -s 1600x900 -i :0.0 -acodec pcm_s16le -vcodec libx264 -threads 0 output.avi -------------------- When I talk quietly, everything is ok, but when I talk normally or little bit loudly, in video is noise in background. I tried to record video on Windows with same microphone and everything was okay. Maybe I'm just running ffmpeg with bad audio codec, but I don't know. Does anybody know how to fix it? 'Here's the video' (https://vimeo.com/71202508), it could be available after 45 minutes of posting this thread.

    Try reducing mike boost in YaST==>Sound==>Other==>Volume



    -- GNOME 3.6.2 openSUSE Release 12.3 (Dartmouth) 64-bit Kernel Linux 3.7.10-1.16-desktop


  3. #3

    Question Re: FFMpeg audio recording makes noise.

    Ehm... I think I don't have this option...

    Screenshot

  4. #4

    Default Re: FFMpeg audio recording makes noise.

    PROBLEM SOLVED

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: FFMpeg audio recording makes noise.

    repakolius wrote:
    >
    > *PROBLEM SOLVED*
    >
    >

    and the resolution is ?

    --
    GNOME 3.6.2
    openSUSE Release 12.3 (Dartmouth) 64-bit
    Kernel Linux 3.7.10-1.16-desktop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •