Results 1 to 2 of 2

Thread: Thunderbird cannot access profile on mounted partition

  1. #1

    Default Thunderbird cannot access profile on mounted partition

    Hi,
    I just installed openSUSE 12.3 KDE x64 on one of my PCs and installed Thunderbird as it is a vital software for me.

    The Profile is stored on a mounted NTFS partition, so I changed the path in "/home/roberto/.thunderbird/profiles.ini" to the folder on my mounted partition, like

    Code:
    Path=/media/ntfs1/x44537.default
    But it cannot access it, no mather what. I keep getting the "Thunderbird is already running" or "profile folder is not found. etc" errors even though I did exactly the same thing on my other machine wich runs openSUSE 12.2 KDE x64 and works fine.
    I immediately thought I has something to do with permissions so I did a "chmod 777 for /media/ntfs1/x44537.default" folder but it doesn' work.
    I also tried mounting the partition to a new folder created directly in "/", like "/mountedntfs", but this also does not work.

    I only works if I mount the partition manually, that is no entry in fstab, clicking the Label in Dolphin after rebooting and providing my password. I see now in 12.3 the partitions are mounted in "var/run".
    OpenSUSE Leap 42.2 x64 KDE

  2. #2

    Default Re: Thunderbird cannot access profile on mounted partition

    Quote Originally Posted by robertot5 View Post
    I only works if I mount the partition manually, that is no entry in fstab, clicking the Label in Dolphin after rebooting and providing my password. I see now in 12.3 the partitions are mounted in "var/run".
    On 12.2 KDE still used udisk1 which mounts all drives to /media.
    But on 12.3 KDE uses the successor udisks2, this mounts the drives to /var/run/media/$USER/ by default.

    If you want to mount the drive to /media, you have 2 possibilites:

    - create a directory in /media and add an entry in /etc/fstab which mounts the drive to that directory.
    udisks2 respects fstab, so even if you manually mount with dolphin, it's mounted to that directory set in /media (you can set it to automatically be mounted on boot as well, of course). /media is no tmpfs in 12.3 (contrary to 12.2) so the directory you created in /media will stay there.
    But since it is an NTFS filesystem you have to specify mount options for your user to have access.
    From "man mount":
    uid=value, gid=value and umask=value
    Set the file permission on the filesystem. The umask value is given in octal. By default, the files are owned by root and not readable by somebody else.
    - there's the possibility now to tell udisks2 to mount drives to /media (it behaves like udisks1 in 12.2 then).
    Do this: [Bug 809837] udisks ignores UDISKS_FILESYSTEM_SHARED flag

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •