Results 1 to 8 of 8

Thread: Packman repo dep issue

  1. #1

    Default Packman repo dep issue

    Hi forum,

    Its been a while sence I have had any issues and had to post here .

    I reloaded my system the other day and all seemed to go well, however when I add the packman repo and then do a vendor switch to it as I was instructed long ago to do, I get the following error:



    Any ideas on how I should proceed? Should I do the recommended option and use the x86 version?

    Thanks!
    Joe

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Packman repo dep issue

    There is a big thread on this and more
    https://forums.opensuse.org/english/...ml#post2574338

    You might want to read it all.

    I didn't have issues because I have x264 installed
    Not libx264
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Packman repo dep issue

    Quote Originally Posted by caf4926 View Post
    There is a big thread on this and more
    https://forums.opensuse.org/english/...ml#post2574338

    You might want to read it all.

    I didn't have issues because I have x264 installed
    Not libx264
    HI Caf

    Thanks for the reply. I read the thread and opted for the option to "break by ignoring some of its dependencies" as specified by wolfi323 in the post.

    Now, I have this:

    Code:
    zypper verify
    Loading repository data...
    Reading installed packages...
    
    Problem: nothing provides libx264.so.129()(64bit) needed by libquicktime0-1.2.4-61.2.x86_64
     Solution 1: Following actions will be done:
      downgrade of libquicktime0-1.2.4-61.2.x86_64 to libquicktime0-1.2.4-4.1.1.x86_64
      install libquicktime0-1.2.4-4.1.1.x86_64 (with vendor change)
        http://packman.links2linux.de  -->  openSUSE
     Solution 2: break libquicktime0-1.2.4-61.2.x86_64 by ignoring some of its dependencies
    So, I will patiently wait for the files to be synced .

    You mentioned that you do not use this dependency because you use another package. Is there a way I can use this other package as well to get past this?

    Thanks again for the help!
    Joe

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Packman repo dep issue

    I see now why I don't have the problem
    I have the old dependency too
    SUSE Paste
    See it showing Red
    If I try and delete it, I get the problem you have.

    Just wait it out
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Packman repo dep issue

    Here is the 64 bit depend if you want to add it manually to
    /usr/lib64

    https://dl.dropboxusercontent.com/u/...264.so.129.zip

    Extract the file and copy it over
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Packman repo dep issue

    libquicktime0 has been updated in the meantime to use libx264-135. And x264 now also has been upgraded to 0.135.

    On my system the only packages still needing libx264-129 are cinelerra and vlc-codecs.
    Cinelerra has already been rebuilt for libx264-135 and should be synced out to the mirrors soon though.

    So there's only vlc-codecs left...

    And I think I should clarify something:
    x264 and libx264 are not interchangeable. They are completely different things.
    x264 is a (command line) program to encode video files to the H264/AVC codec.
    libx264 is a library for encoding that is used by other programs/libraries.

    That's why x264 doesn't cause dependency problems (you could even remove it from your system if you don't want to call it manually, I'm not aware of anything else that uses it), but libx264 does.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Packman repo dep issue

    It's all good now from what I see
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Packman repo dep issue

    Quote Originally Posted by caf4926 View Post
    It's all good now from what I see
    Yup, just did an update and verify and all seems well again

    Thanks for the help and insight!!!

    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •