Results 1 to 9 of 9

Thread: Incorrect time every time I boot into KDE

  1. #1
    Join Date
    Aug 2011
    Location
    Manchester, England
    Posts
    46

    Default Incorrect time every time I boot into KDE

    Every time I boot my laptop it sets the time an hour ahead of what it actually is. I rebooted and checked to see what the computer itself thinks the time is and that has it correct in the BIOS. However, every single piggin' time I boot up, I have to right click on the clock and set it an hour back. Please don't suggest NTP, because I don't have Internet while on site on this laptop (it's my laptop and I cannot connect to the company network).

    I'm running 12.3 with KDE in case that's relevant. Anyone know why it refuses to remember the time on shutdown, why it refuses to take the computer's time from hardware and what I can do to fix this please?

    Thanks!

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Incorrect time every time I boot into KDE

    Quote Originally Posted by DiBosco View Post
    Every time I boot my laptop it sets the time an hour ahead of what it actually is. I rebooted and checked to see what the computer itself thinks the time is and that has it correct in the BIOS. However, every single piggin' time I boot up, I have to right click on the clock and set it an hour back. Please don't suggest NTP, because I don't have Internet while on site on this laptop (it's my laptop and I cannot connect to the company network).

    I'm running 12.3 with KDE in case that's relevant. Anyone know why it refuses to remember the time on shutdown, why it refuses to take the computer's time from hardware and what I can do to fix this please?

    Thanks!
    Can you check settings(especially the timezone) in YaST ==>Date and time ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3
    Join Date
    Aug 2011
    Location
    Manchester, England
    Posts
    46

    Default Re: Incorrect time every time I boot into KDE

    It's set to UK/London which is correct. I set that in the clock settings when right clicking on the clock. One thing that is ticked is hardware clock set to UTC. AFAIK, UTC is a new fangled term for GMT, so I suppose if it thinks the clock is set to GMT, but we're actually in British summertime which is an hour ahead, maybe that's why the OS is setting it.

    It's poor that right clicking in that clock icon doesn't have that check box or it's poor that both YAST and the clock control it. It should either be both control it, but right clicking on the clock gives all options, or only YAST should control it.

    Thanks for the tip on YAST. I bet deselecting that box that fixes it.

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Incorrect time every time I boot into KDE

    Quote Originally Posted by DiBosco View Post
    It's set to UK/London which is correct. I set that in the clock settings when right clicking on the clock. One thing that is ticked is hardware clock set to UTC. AFAIK, UTC is a new fangled term for GMT, so I suppose if it thinks the clock is set to GMT, but we're actually in British summertime which is an hour ahead, maybe that's why the OS is setting it.

    It's poor that right clicking in that clock icon doesn't have that check box or it's poor that both YAST and the clock control it. It should either be both control it, but right clicking on the clock gives all options, or only YAST should control it.

    Thanks for the tip on YAST. I bet deselecting that box that fixes it.
    you are welcome.
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Incorrect time every time I boot into KDE

    On 2013-07-24 12:16, DiBosco wrote:
    >
    > It's set to UK/London which is correct. I set that in the clock settings
    > when right clicking on the clock. One thing that is ticked is hardware
    > clock set to UTC. AFAIK, UTC is a new fangled term for GMT, so I suppose
    > if it thinks the clock is set to GMT, but we're actually in British
    > summertime which is an hour ahead, maybe that's why the OS is setting
    > it.


    Related.

    Please run these commands in a terminal, and paste here:

    Code:
    su -
    date --utc
    date --rfc-3339=seconds
    hwclock --debug
    cat /etc/sysconfig/clock | egrep -v "^[[:space:]]*$|^#"
    Now, notice that "system" time is shown by the above commands; whatever
    KDE displays can be wrong and unrelated to the above.

    So, first, let us make sure that the _system_ clock is correct, then
    we'll think about KDE. My guess is that you also need to configure KDE
    time (do not set time using KDE, at least till you really understand
    what it does).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Incorrect time every time I boot into KDE

    On 07/24/2013 12:16 PM, DiBosco wrote:

    > It's poor that right clicking in that clock icon doesn't have that
    > check box


    it is well documented how to correctly set the clock and tick the
    boxes *during* install:
    http://doc.opensuse.org/documentatio...sec.y2.country

    that you missed that step in install means you then may or may not
    get confused--depending on which desktop environment you select, and
    how it intends you to set the clock.


    > or it's poor that both YAST -and- the clock control it.


    the problem is that openSUSE (and SuSE before it) well tended to the
    clock, using YaST--long before KDE was born...so, now along comes KDE
    and builds in a way for the user of openSUSE, and Red Hat, and
    Debian, and 300 others to set the clock without using pre-existing,
    distribution provided ways..

    if openSUSE stripped that out of KDE then the user just in from
    Mandrivia, KDE, Kbuntu etc etc etc couldn't figure out how to set the
    clock (without reading the provided documentation, of course)..

    and, if openSUSE does not strip out KDE's redundant way to set the
    clock then folks come in and say it is 'poor' that there are two ways!

    can win.

    --
    dd
    openSUSE®, the "German Engineered Automobile" of operating systems!
    http://goo.gl/PUjnL
    http://tinyurl.com/DD-Caveat
    http://tinyurl.com/DD-Hardware
    http://tinyurl.com/DD-Software

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,889
    Blog Entries
    3

    Default Re: Incorrect time every time I boot into KDE

    Quote Originally Posted by DiBosco View Post
    It's set to UK/London which is correct. I set that in the clock settings when right clicking on the clock. One thing that is ticked is hardware clock set to UTC. AFAIK, UTC is a new fangled term for GMT, so I suppose if it thinks the clock is set to GMT, but we're actually in British summertime which is an hour ahead, maybe that's why the OS is setting it.
    Something seems amiss. Here's some output:
    Code:
    > date
    Wed Jul 24 09:20:08 CDT 2013
    > TZ=GMT date
    Wed Jul 24 14:20:17 GMT 2013
    > TZ=UK/London date
    Wed Jul 24 14:20:27  2013
    My computer is giving the same time for GMT and for UK/London. It also gives the same time for UTC (not shown in the above output). Yet you say that there is a one hour difference.

    So maybe that's a bug in the timezone database.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,889
    Blog Entries
    3

    Default Re: Incorrect time every time I boot into KDE

    Quote Originally Posted by nrickert View Post
    So maybe that's a bug in the timezone database.
    Some further checking. I looked in "/usr/share/zoneinfo" which is where the timezone info is kept.

    It looks to me that there is no actual zone "UK/London", so some software must be faking it and getting it wrong.

    I'd say that your timezone should be Europe/London
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Incorrect time every time I boot into KDE

    On 2013-07-24 16:26, nrickert wrote:

    > So maybe that's a bug in the timezone database.


    Using the TZ variable is not very reliable, some strings work, some do
    not. Try "Europe/London" ;-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •