Results 1 to 10 of 10

Thread: Default browser [Chrome] not opening

  1. #1
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    241

    Default Default browser [Chrome] not opening

    The default browser is currently set to Google Chrome, as confirmed by the Chrome Settings page: viz:





    How come then, if i click on an HTML file to open it, Firefox opens suggesting i should make IT the default browser??

    This behaviour also affects other programs that need to open a browser [eg: gnome-gmail-notifier] ... which opens up Firefox instead of the default browser ..in this case Chrome???

    You can even see that under [System Settings > System > Details] that Chrome is the 'Preferred Application'





    .... but behaviour of OpenSUSE 12.3 -64bit Gnome suggest otherwise??


    Is this a bug or have i misses something somewhere?

    Thanks .. this one is a biggie for me!!

  2. #2
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,160

    Default Re: Default browser [Chrome] not opening

    Not sure if this'll fix the whole problem but try this:
    In FX Edit>Preferences>Advanced>General
    Uncheck the Always Check to see... box
    Secondly, may advise that you get Chromium instead of Chrome from our repos , just search for it in Yast.
    Integration will be better with you Opensuse.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Default browser [Chrome] not opening

    @op- can you check whether there is a chrome entry for html files inside /home/dartmouth/.local/share/applications/mimeapps.list ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Default browser [Chrome] not opening

    If not available you can make some

    Code:
    [Default Applications]
    ...
    text/html=chrome.desktop
    application/xhtml+xml=chrome.desktop
    application/x-extension-html=chrome.desktop
    application/x-extension-xhtml=chrome.desktop
    ...
    [Added Associations]
    ...
    text/html=chrome.desktop
    application/xhtml+xml=chrome.desktop
    application/x-extension-html=chrome.desktop
    application/x-extension-xhtml=chrome.desktop
    ...
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    241

    Default Re: Default browser [Chrome] not opening

    Quote Originally Posted by Sagemta View Post
    Not sure if this'll fix the whole problem but try this:
    In FX Edit>Preferences>Advanced>General
    Uncheck the Always Check to see... box
    Secondly, may advise that you get Chromium instead of Chrome from our repos , just search for it in Yast.
    Integration will be better with you Opensuse.

    Okay .. thnx for the advise Sag.

    After rebuilding from an earlier image I cant seem to completely reproduce this issue ... in as much as all external links open to the default browser except when evoking a gmail account from 'gnome-gmail-notifier' ... Firefox still opens declaring that i should make IT the default browser ..............








    and I have replaced Chrome with Chromium from the repository and adjusted FX, as you suggest [even though in the above image FX IS checking] ... however that does not change anything wrt to the operation of gnome-gmail-notifier! .... So i guess the issue lies with that Application??!

    I will open up a new thread and badge it as an issue with 'gnome-gmail-notifier' .... however, strange thing is i had it working without issue under OpenSUSE12.2-32bit Gnome!

    Before i start a new thread ... anyone have any further??

    Thnx

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,008
    Blog Entries
    1

    Default Re: Default browser [Chrome] not opening

    I note the same question was asked here:

    Issue 93 - gnome-gmail-notifier - Clicking on notification does not use the system's default browser - A Gmail Inbox Monitor for the GNOME2 desktop - Google Project Hosting

    and the answer suggested it was a Gnome DE issue to configure the default browser correctly


    Hmmmm.... I wonder if this is relevant (its an ArchLinux Wiki, but may still be relevant):

    https://wiki.archlinux.org/index.php...place_Nautilus

    Default web browser

    To configure the web browser used by the AUR package gnome-gmail-notifier, open gconf-editor and edit the /desktop/gnome/url-handlers/http/ key. You may want to change https/, about/, and unknown/ keys while you are at it.
    I'm not a Gnome user, so please disregard if I'm not on the right track with this.

  7. #7
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Default browser [Chrome] not opening

    Quote Originally Posted by deano_ferrari View Post
    I note the same question was asked here:

    Issue 93 - gnome-gmail-notifier - Clicking on notification does not use the system's default browser - A Gmail Inbox Monitor for the GNOME2 desktop - Google Project Hosting

    and the answer suggested it was a Gnome DE issue to configure the default browser correctly


    Hmmmm.... I wonder if this is relevant (its an ArchLinux Wiki, but may still be relevant):

    https://wiki.archlinux.org/index.php...place_Nautilus



    I'm not a Gnome user, so please disregard if I'm not on the right track with this.
    Editing gconf might do the trick. I think notifier is using gtk2 but gnome uses gtk3 toolkit
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  8. #8
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    241

    Default Re: Default browser [Chrome] not opening

    Quote Originally Posted by deano_ferrari View Post

    Default web browser:

    To configure the web browser used by the AUR package gnome-gmail-notifier, open gconf-editor and edit the /desktop/gnome/url-handlers/http/ key. You may want to change https/, about/, and unknown/ keys while you are at it.
    That does it!!!!!!!!!!!!! *big broad smile*

    Both the http and https labels where hardcoded with /usr/bin/Firefox .... i manually changed them to read /usr/bin/google-chrome ... and BINGO!!

    Thanks ever so much vaz .... !! Much appreciated.



  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,008
    Blog Entries
    1

    Default Re: Default browser [Chrome] not opening

    Glad you got it sorted.

  10. #10
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Default browser [Chrome] not opening

    griadooss wrote:
    > Thanks ever so much vaz .... !! Much appreciated.

    you are welcome

    --
    GNOME 3.6.2
    openSUSE Release 12.3 (Dartmouth) 64-bit
    Kernel Linux 3.7.10-1.16-desktop

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •