Results 1 to 10 of 10

Thread: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

  1. #1

    Default openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Hi,

    My 12.2 has been working perfectly at 1024x768 resolution until now. This PM after booting with Grub(2) menu I see a screen with humongous fonts. I cannot change screen resolution by right clicking the mouse. Booting in fail-safe option doesn't help either. I have been using Nvidia driver instead of nouveau for GT6600 video card. As a result, I cannot login.

    Any suggestions? Thanks a lot for your help.


  2. #2

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Quote Originally Posted by taytong888 View Post
    My 12.2 has been working perfectly at 1024x768 resolution until now. This PM after booting with Grub(2) menu I see a screen with humongous fonts. I cannot change screen resolution by right clicking the mouse. Booting in fail-safe option doesn't help either. I have been using Nvidia driver instead of nouveau for GT6600 video card. As a result, I cannot login.
    Why can't you login? It should suffice if you just enter your password, even if you can't see anything because of the wrong resolution.
    Where are you right clicking to change the screen resolution?
    Could you maybe post a picture?

    Did you install a kernel update maybe?
    That could prevent the nvidia driver from working. You may have to reinstall it (depends on how you installed it in the first place).

    Could you maybe upload the file /var/log/Xorg.0.log to SUSE Paste or similar and post a link? That should provide a clue as to what's wrong.

    If your monitor suddenly is reporting a wrong resolution, it may help to completely unplug it (including the power plug) and reconnect it again.

  3. #3

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Hello wolfi323,

    1. I cannot log in because I don't see the login screen.
    2. After booting into run level 3, I was able to log in

    3.
    Code:
    #rpm -qa | grep nvidia
    nvidia-computeG02-304.88-25.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.88_k3.4.6_2.10-24.1.x86_64
    x11-video-nvidiaG02-304.88-25.1.x86_64
    4.
    Code:
    #less /var/log/Xorg.0.log
    At this point, this log includes the following clues: "no screen section", "no layout section", "no monitor specified", and "the directory /usr/share/fonts/URW does not exist". Perhaps an update yesterday somehow messed up the display. I don't remember if a kernel update was involved.

    How do I select relevant parts of Xorg.0.log, copy then upload the excerpt to SUSE Paste?

    Thanks in advance for your help.

  4. #4

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Hi everyone,

    I booted into runlevel 3 then

    Code:
    startx
    I was then able to access the normal and default log in screen. I did not see a link after pasting Xorg.0.log onto susepaste box so I will post it below:

    Code:
    #cat /var/log/Xorg.0.log
    
    inux-rtcr:~ # cat /var/log/Xorg.0.log
    [   149.513] 
    X.Org X Server 1.12.3
    Release Date: 2012-07-09
    [   149.513] X Protocol Version 11, Revision 0
    [   149.513] Build Operating System: openSUSE SUSE LINUX
    [   149.513] Current Operating System: Linux linux-rtcr 3.4.47-2.38-desktop #1 SMP PREEMPT Fri May 31 20:17:40 UTC 2013 (3961086) x86_64
    [   149.514] Kernel command line: root=/dev/disk/by-id/ata-ST3250824AS_5ND36152-part5 resume=/dev/disk/by-id/ata-ST3250824AS_5ND36152-part9 splash=silent quiet 3 nomodeset vga=0x317
    [   149.514] Build Date: 27 June 2013  08:19:01AM
    [   149.514]  
    [   149.514] Current version of pixman: 0.24.4
    [   149.515]    Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.
    [   149.515] Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   149.516] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul 16 18:06:31 2013
    [   149.566] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [   149.566] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [   149.628] (==) No Layout section.  Using the first Screen section.
    [   149.628] (==) No screen section available. Using defaults.
    [   149.628] (**) |-->Screen "Default Screen Section" (0)
    [   149.628] (**) |   |-->Monitor "<default monitor>"
    [   149.642] (==) No monitor specified for screen "Default Screen Section".
            Using a default monitor configuration.                                                                                                                                                           
    [   149.642] (==) Automatically adding devices                                                                                                                                                           
    [   149.642] (==) Automatically enabling devices                                                                                                                                                         
    [   149.752] (WW) The directory "/usr/share/fonts/URW/" does not exist.                                                                                                                                  
    [   149.752]    Entry deleted from font path.                                                                                                                                                            
    [   149.752] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.                                                                                                                              
    [   149.752]    Entry deleted from font path.                                                                                                                                                            
      ...                        
            
    [   151.131] (II) LoadModule: "nvidia"
    [   151.131] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
    [   151.211] (II) Module nvidia: vendor="NVIDIA Corporation"
    [   151.211]    compiled for 4.0.2, module version = 1.0.0
    [   151.211]    Module class: X.Org Video Driver
    [   151.238] (II) LoadModule: "nouveau"
    [   151.240] (WW) Warning, couldn't open module nouveau
    [   151.240] (II) UnloadModule: "nouveau"
    [   151.240] (II) Unloading nouveau
    [   151.240] (EE) Failed to load module "nouveau" (module does not exist, 0)
    [   151.240] (II) LoadModule: "nv"
    [   151.241] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
    [   151.256] (II) Module nv: vendor="X.Org Foundation"
    [   151.256]    compiled for 1.12.3, module version = 2.1.20
    [   151.256]    Module class: X.Org Video Driver
    [   151.256]    ABI class: X.Org Video Driver, version 12.0
    [   151.257] (II) LoadModule: "fbdev"
    [   151.257] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [   151.264] (II) Module fbdev: vendor="X.Org Foundation"
    [   151.264]    compiled for 1.12.3, module version = 0.4.2
    [   151.264]    ABI class: X.Org Video Driver, version 12.0
    [   151.264] (II) LoadModule: "vesa"
    [   151.265] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [   151.274] (II) Module vesa: vendor="X.Org Foundation"
    [   151.274]    compiled for 1.12.3, module version = 2.3.1
    [   151.274]    Module class: X.Org Video Driver
    [   151.274]    ABI class: X.Org Video Driver, version 12.0
    [   151.275] (II) NVIDIA dlloader X Driver  304.88  Wed Mar 27 14:28:14 PDT 2013
    [   151.275] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [   151.290] (II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
            
            ...
           
            Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
            
            
        ...    
            
         
            
    [   151.297] (II) FBDEV: driver for framebuffer: fbdev
    [   151.297] (II) VESA: driver for VESA chipsets: vesa
    [   151.297] (--) using VT number 2
    
    [   151.316] (II) Loading sub module "fb"
    [   151.316] (II) LoadModule: "fb"
    [   151.317] (II) Loading /usr/lib64/xorg/modules/libfb.so
    [   151.334] (II) Module fb: vendor="X.Org Foundation"
    [   151.334]    compiled for 1.12.3, module version = 1.0.0
    [   151.334]    ABI class: X.Org ANSI C Emulation, version 0.4
    [   151.334] (II) Loading sub module "wfb"
    [   151.334] (II) LoadModule: "wfb"
    [   151.334] (II) Loading /usr/lib64/xorg/modules/libwfb.so
    [   151.341] (II) Module wfb: vendor="X.Org Foundation"
    [   151.341]    compiled for 1.12.3, module version = 1.0.0
    [   151.341]    ABI class: X.Org ANSI C Emulation, version 0.4
    [   151.341] (II) Loading sub module "ramdac"
    [   151.341] (II) LoadModule: "ramdac"
    [   151.341] (II) Module "ramdac" already built-in
    [   151.356] (WW) Falling back to old probe method for fbdev
    [   151.356] (II) Loading sub module "fbdevhw"
    [   151.356] (II) LoadModule: "fbdevhw"
    [   151.356] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [   151.363] (II) Module fbdevhw: vendor="X.Org Foundation"
    [   151.363]    compiled for 1.12.3, module version = 0.0.2
    [   151.363]    ABI class: X.Org Video Driver, version 12.0
    [   151.363] (WW) Falling back to old probe method for vesa
    [   151.363] (II) NVIDIA(0): Creating default Display subsection in Screen section
            "Default Screen Section" for depth/fbbpp 24/32
    [   151.363] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
    [   151.363] (==) NVIDIA(0): RGB weight 888
    [   151.363] (==) NVIDIA(0): Default visual is TrueColor
    [   151.363] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    [   151.364] (**) NVIDIA(0): Enabling 2D acceleration
    [   152.871] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
    [   152.881] (II) NVIDIA(0): NVIDIA GPU GeForce 6600 (NV43) at PCI:1:0:0 (GPU-0)
    [   152.881] (--) NVIDIA(0): Memory: 524288 kBytes
    [   152.881] (--) NVIDIA(0): VideoBIOS: 05.43.02.75.00
    [   152.881] (II) NVIDIA(0): Detected PCI Express Link width: 16X
    [   152.881] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    [   152.881] (--) NVIDIA(0): Valid display device(s) on GeForce 6600 at PCI:1:0:0
    [   152.881] (--) NVIDIA(0):     CRT-0 (connected)
    [   152.881] (--) NVIDIA(0):     CRT-1
    [   152.881] (--) NVIDIA(0):     TV-0
    [   152.881] (--) NVIDIA(0):     DFP-0
    [   152.881] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
    [   152.881] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
    [   152.881] (--) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
    [   152.881] (--) NVIDIA(0): TV encoder: Unknown
    [   152.881] (--) NVIDIA(0): DFP-0: 155.0 MHz maximum pixel clock
    [   152.881] (--) NVIDIA(0): DFP-0: Internal Single Link TMDS
    [   152.881] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    [   152.881] (**) NVIDIA(0):     device CRT-0 (Using EDID frequencies has been enabled on
    [   152.881] (**) NVIDIA(0):     all display devices.)
    [   152.881] (==) NVIDIA(0): 
    [   152.881] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [   152.881] (==) NVIDIA(0):     will be used as the requested mode.
    [   152.881] (==) NVIDIA(0): 
    [   152.882] (II) NVIDIA(0): Validated MetaModes:
    [   152.882] (II) NVIDIA(0):     "CRT-0:nvidia-auto-select"
    [   152.882] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
    [   152.883] (WW) NVIDIA(0): Unable to support custom viewPortOut 1024 x 576 +0 +96
    [   152.904] (WW) NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
    [   152.904] (WW) NVIDIA(0):     from CRT-0's EDID.
    [   152.904] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
    [   152.904] (II) UnloadModule: "nv"
    [   152.904] (II) Unloading nv
    [   152.904] (II) UnloadModule: "fbdev"
    [   152.904] (II) Unloading fbdev
    [   152.904] (II) UnloadSubModule: "fbdevhw"
    [   152.904] (II) Unloading fbdevhw
    [   152.904] (II) UnloadModule: "vesa"
    [   152.904] (II) Unloading vesa
    [   152.904] (--) Depth 24 pixmap format is 32 bpp
    [   152.914] (II) NVIDIA(0): Setting mode "CRT-0:nvidia-auto-select"
    [   153.024] (II) Loading extension NV-GLX
    [   153.072] (==) NVIDIA(0): Disabling shared memory pixmaps
    [   153.072] (==) NVIDIA(0): Backing store disabled
    [   153.072] (==) NVIDIA(0): Silken mouse enabled
    [   153.075] (==) NVIDIA(0): DPMS enabled
    [   153.075] (II) Loading extension NV-CONTROL
    [   153.076] (II) Loading extension XINERAMA
    [   153.076] (II) Loading sub module "dri2"
    [   153.076] (II) LoadModule: "dri2"
    [   153.076] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
    [   153.076] (II) Module dri2: vendor="X.Org Foundation"
    [   153.076]    compiled for 1.12.3, module version = 1.2.0
    [   153.076]    ABI class: X.Org Server Extension, version 6.0
    [   153.076] (II) NVIDIA(0): [DRI2] Setup complete
    [   153.076] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
    [   153.076] (--) RandR disabled
    
    [   153.077] (II) Initializing built-in extension RENDER
    [   153.077] (II) Initializing built-in extension RANDR
    [   153.077] (II) Initializing built-in extension COMPOSITE
    [   153.077] (II) Initializing built-in extension DAMAGE
    [   153.080] (II) Initializing extension GLX
    
    [   153.727] (II) Module evdev: vendor="X.Org Foundation"
    [   153.727]    compiled for 1.12.3, module version = 2.7.3
    [   153.727]    Module class: X.Org XInput Driver
    [   153.727]    ABI class: X.Org XInput driver, version 16.0
    
    
    
    
    [   207.230] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
    [   207.230] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    [   207.230] (**) NVIDIA(0):     device CRT-0 (Using EDID frequencies has been enabled on
    [   207.230] (**) NVIDIA(0):     all display devices.)
    [   340.157] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
    [   340.158] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    [   340.158] (**) NVIDIA(0):     device CRT-0 (Using EDID frequencies has been enabled on
    [   340.158] (**) NVIDIA(0):     all display devices.)
    
    
    I have highlighted possible areas of concern. One more thing:

    Code:
    kdesu kwrite /etc/X11/xorg.conf
    gives a BLANK file!

    It appears somehow /etc/X11/xorg.conf has been wiped out.

    I would appreciate your help to solve my problems.

  5. #5

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Quote Originally Posted by taytong888 View Post
    At this point, this log includes the following clues: "no screen section", "no layout section", "no monitor specified", and "the directory /usr/share/fonts/URW does not exist"
    those are simply informational messages that occur when there is no configuration file(s) being used (which would specify such items) and X resorts to using defaults for autoconfiguration.

    Perhaps an update yesterday somehow messed up the display. I don't remember if a kernel update was involved.
    you can see what you installed/uninstalled yesterday (and any other day for that matter) via: Yast > Software Mgmt > Extras > Show History

    How do I select relevant parts of Xorg.0.log, copy then upload the excerpt to SUSE Paste?
    Do not use excerpts, just upload the whole thing.

  6. #6

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Hello Tyler_K,

    Thanks for your reply. YAST >Software Management >Extras>Show History: No kernel has been updated recently. I do note that xorg-x11-server was updated to version 7.6_1.12.3 on July 5, but not sure if this has anything to do with my current problems.

    I did not see any upload button in susepaste so I had to copy and paste the whole thing from the terminal. I then had to truncate quite a bit in order to be able to post Xorg.0.log as you can see above.

  7. #7

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Hello again,

    I was just able to boot into openSUSE 12.2 normally and log in normally. My usual KDE desktop is back! Don't know what happened!

    However, I noticed the following:

    1. YAST > Software Management shows nvidia driver (Post # 3 above) IS installed.

    2. A check with /etc/X11/xorg.conf.d shows all 3 sub-directories /50-monitor.conf, /50-screen.conf and /50-device.conf were somehow reverted to default settings. For example:

    Code:
    /etc/X11/xorg.conf.d/50-device.conf
    
    #Section "Device"
    #Identifier "Default Device"
    #Driver "radeon"
    #EndSection
    I am wondering how come the on-motherboard radeon driver was used instead of nvidia, resulting in my usual KDE desktop. It appears the radeon-based graphics and videos are not as sharp and vivid as those based on nvidia. Any idea or suggestions to reconfigure these 3 sub-directories to use nvidia?

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,009
    Blog Entries
    1

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    I am wondering how come the on-motherboard radeon driver was used instead of nvidia, resulting in my usual KDE desktop. It appears the radeon-based graphics and videos are not as sharp and vivid as those based on nvidia. Any idea or suggestions to reconfigure these 3 sub-directories to use nvidia?
    You're mistaken. That's a config file with entries commented out (by the '#' character). It is included as part of the 'xorg-x11-driver-video' package.

  9. #9

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    Quote Originally Posted by taytong888 View Post
    I booted into runlevel 3 then
    Code:
    startx
    I was then able to access the normal and default log in screen.
    for openSUSE, startx (for security reasons) no longer works for normal users, so you must have done so via root. Don't do that -- that's a security risk in itself, as well as can lead to really messing up your system (in particular because of changes of file ownership to root, which causes havoc for the user account). Use "sudo systemctl start xdm" or "sudo /usr/sbin/init 5" instead.

    I did not see a link after pasting Xorg.0.log onto susepaste box so I will post it below:
    yes, appears we posted at the same time.

    I have highlighted possible areas of concern.
    See my comment above for explanation as to the reason for some of those highlights

    One more thing:

    Code:
    kdesu kwrite /etc/X11/xorg.conf
    gives a BLANK file!
    yes, see previous comment above; no xorg.conf file was being used

    It appears somehow /etc/X11/xorg.conf has been wiped out.
    did you ever have one? It is not necessary to use one any more (X will, as mentioned previously) autoconfigure itself ... but if you desire, you can still use an xorg.conf or applicable xorg.conf.d/ files

    Thanks for your reply. YAST >Software Management >Extras>Show History: No kernel has been updated recently. I do note that xorg-x11-server was updated to version 7.6_1.12.3 on July 5, but not sure if this has anything to do with my current problems.
    no

    Quote Originally Posted by taytong888 View Post
    I was just able to boot into openSUSE 12.2 normally and log in normally. My usual KDE desktop is back! Don't know what happened!
    Not sure. But, now that its working again, I wouldn't worry about it

    However, I noticed the following:

    1. YAST > Software Management shows nvidia driver (Post # 3 above) IS installed.
    yes, as can be seen in the rpm querry command output

    2. A check with /etc/X11/xorg.conf.d shows all 3 sub-directories
    clarification, those are files within the xorg.conf.d directory, as opposed to sub directories

    /50-monitor.conf, /50-screen.conf and /50-device.conf were somehow reverted to default settings. For example:
    Had you ever changed them yourself? Otherwise, they will be static and unchanged.

    [quote[#Driver "radeon"

    I am wondering how come the on-motherboard radeon driver was used instead of nvidia, resulting in my usual KDE desktop. It appears the radeon-based graphics and videos are not as sharp and vivid as those based on nvidia. Any idea or suggestions to reconfigure these 3 sub-directories to use nvidia?[/QUOTE]As

  10. #10

    Default Re: openSUSE12.2 64-bit KDE: Booted into desktop with wrong resolution!

    #Driver "radeon"

    I am wondering how come the on-motherboard radeon driver was used instead of nvidia, resulting in my usual KDE desktop. It appears the radeon-based graphics and videos are not as sharp and vivid as those based on nvidia. Any idea or suggestions to reconfigure these 3 sub-directories to use nvidia?
    As Deano mentioned, you are mistaken.
    • first, notice that the whole section is commented out via the "#" in front of each line ... meaning that you were never using the radeon
    • second, those comments are just an example and are there for everyone
    • third, these files won't change unless you change them
    • fourth, there is no percievable difference in image quality
    • fifth, you do not need to adjust any of them for use with the nvidia (see previous comment)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •