Results 1 to 4 of 4

Thread: Rewrite command not found

  1. #1

    Default Rewrite command not found

    I am trying to install mecab (MeCab: Yet Another Part-of-Speech and Morphological Analyzer)

    which requires mecab-ipadic. In the makefile I have following line

    matrix.bin char.bin sys.dic unk.dic:
    $(mecab_dict_index) -d . -o . -f EUC-JP -t euc-jp
    echo To enable dictionary, rewrite /usr/local/etc/mecabrc as \"dicrc = /usr/local/lib64/mecab/dic/ipadic\"

    After everything compiles fine I try to enable the dictionary but my OpenSuse 12.3 64 does not have a rewrite command

    Yast2 also did not find anything. Where can I find it ?

    Thanks . Db.

  2. #2

    Default AW: Rewrite command not found

    Quote Originally Posted by Darkblue2 View Post
    matrix.bin char.bin sys.dic unk.dic:
    $(mecab_dict_index) -d . -o . -f EUC-JP -t euc-jp
    echo To enable dictionary, rewrite /usr/local/etc/mecabrc as \"dicrc = /usr/local/lib64/mecab/dic/ipadic\"

    After everything compiles fine I try to enable the dictionary but my OpenSuse 12.3 64 does not have a rewrite command

    Yast2 also did not find anything. Where can I find it ?
    There is no rewrite command.

    I think that message means, you should edit the file "/usr/local/etc/mecabrc" with a text editor so that it contains "dicrc = /usr/local/lib64/mecab/dic/ipadic"...

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Rewrite command not found

    On 2013-07-13 17:26, Darkblue2 wrote:

    > matrix.bin char.bin sys.dic unk.dic:
    > $(mecab_dict_index) -d . -o . -f EUC-JP -t euc-jp
    > echo To enable dictionary, rewrite /usr/local/etc/mecabrc as \"dicrc =
    > /usr/local/lib64/mecab/dic/ipadic\"
    >
    > After everything compiles fine I try to enable the dictionary but my
    > OpenSuse 12.3 64 does not have a rewrite command


    It is not a command. It is human language instructions for you do the
    rewrite :-)


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4

    Default Re: Rewrite command not found

    Thank you both , I got it to work by putting the line into the relevant configuration file.

    Db

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •