Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: NNTP access problem: 119: Connection timed out...

  1. #1

    Default NNTP access problem: 119: Connection timed out...


    Hello. First let me say that I love the existence of the NNTP gateway to
    the forum. I used to prefer mailing lists over forums because I liked the
    clean text interface I get with alpine better than anything a web browser
    can give me. But nowadays, most of the time when there exist both a mailing list
    and a forum for anything technical, mailing lists tend to be just a little bit
    less friendly than the forum.

    Having an NNTP gateway to a user forum such as currently provided by
    nntp.opensuze.org, is the best of both worlds... When it works.

    I can't really say when it started, I had to reinstall my Sabayon
    installation due to a bad system upgrade. And another killed my Xubuntu,
    which I decided to replace with Mageia. Both of which took my attention
    away from other interests for a while. It's only been this week that I
    returned to the opensuze forum for the first time in months.

    Now I access nntp.opensuze.org directly from alpine. It used to work sweet.
    But now I'm finding that when I select nntp.opensuze.org from ALPINE 2.00's
    COLLECTION LIST screen, I'm seeing:

    Code:
    ----------------------
    [Fetching folder data]
    ----------------------

    On the status line for a lot longer than I should. That at least the first
    time I try, {And sometimes for the first two or three attempts} I get:

    Code:
    ----------------------
    [Connection failed to nntp.opensuse.org,119: Connection timed out]
    ----------------------

    At which point I use the keyboard command keys "<" $ ">" to back out to the
    COLLECTION LIST screen, and reopen the collection list. When I finally see
    my subscribed subforums {including this one} they open so fast that I don't
    even see the " [Fetching folder data] " message. Then if I'm quick about it
    I can read some messages. better results can be had by quickly saving all
    new messages to a local folder to read later. But either way when I back
    out to the list to select the next subforum, I'm usually having to reopen
    the collection list {see above} first...

    Then when it comes to posting a message to any of the subforums it didn't
    used to matter if the nntp.opensuze.org collection was open or not. As long
    as that was the currently selected news server in the .pinerc, any properly
    configured message containing {for example} these headers:

    Code:
    ----------------------
    Newsgroups: opensuse.org.feedback.forums.support-information
    From: JtWdyP <jtwdyp@no-mx.forums.opensuse.org>
    ----------------------

    would be posted even if the currently open folder was either a local one or
    an IMAP folder.

    But now, when I'm done composing, it behooves me to suspend it to the
    postponed folder, then reopen the nntp.opensuse.org Collection {see above}
    again. And as soon as I can see the list of my subscribed subforums, I need
    to quickly select to compose from postponed, select the message and use
    crtl+x to begin the "send message dialog"... I do have to be quick, If I
    delay, the posting will fail, and I'll need to postpone it again so that I
    can once again tell alpine to open the nntp collection again...

    I don't think the problem is alpine as it used to work properly. And still
    does when the nntp collection is set to gmane's nntp mailing list mirror.

    Also this occurs with nntp.opensuze.org now, regardless of which of my
    installed Linux, I'm running Or on which of two computers I'm running it
    on.

    Is this part of a known problem? Or a new symptom. And is anybody else
    having the same problem??

    --
    JtWdyP



  2. #2

    Default Re: NNTP access problem: 119: Connection timed out...

    I use NNTP as well across several domains and have never seen this (the
    openSUSE forums are among the most active in terms of message count).
    Since you have your game figured out (other thread) you obviously know
    your way around Linux a little... could you do some troubleshooting with
    us to identify the issue? A few questions to start:

    Wired or wireless connection? If wireless, can you try wired? FYI: My
    connection is wired; I have more issues when wireless at the other end of
    my place, but that's to be expected.

    Second, do you have IPv6 enabled on your machine? Have you tried
    disabling and rebooting, unless you really need it? nntp.opensuse.org
    does not have an AAAA (IPv6) DNS record from what I can tell, so if your
    system tries that first it may timeout before trying the A (IPv4) DNS
    record. Shouldn't work that way, but I don't use clients other than
    Thunderbird, or other Linux distributions, for NNTP.

    It sounds like this happens regularly. Can you catch it in a LAN trace?

    Code:
    ----------
    sudo /usr/sbin/tcpdump -n -s 0 -i any -w /tmp/nntp0.cap port 119
    ----------

    Let it run until you see the symptom and work past it. Hit ctrl+c to
    cancel the trace and then post the resulting file somewhere after compressing:

    Code:
    ----------
    bzip2 /tmp/nntp0.cap
    ----------

    If you cannot post it anywhere else, like a Dropbox share or something,
    let us know and we'll try something like ftp://ftp.novell.com/incoming and
    see if somehow we can grab the file from there (it's a place where files,
    once uploaded, can only be downloaded by Novell employees, so posting the
    name of the file here won't risk anybody getting it unless they're
    looking; Novell is affiliated with openSUSE, just so you know why their
    FTP site is mentioned).

    Otherwise there are always fun little network tests assuming you have
    'netcat' installed:

    Code:
    ----------
    while [ 1 ] ; do date; netcat -zv nntp.opensuse.org 119; sleep 5; done
    ----------

    Feel free to run that in a shell somewhere and see if you ever get any
    failures connecting. If not, maybe the timeout is because of the amount
    of data coming down from the NNTP server when you get new messages, but
    that seems pretty unlikely too since you should only be getting what's
    new, and that's not going to be measured in megabytes unless you're out
    for quite a while.

    Good luck.

  3. #3

    Default Re: NNTP access problem: 119: Connection timed out...


    It would appear that on Jul 13, ab did say:

    > I use NNTP as well across several domains and have never seen this (the
    > openSUSE forums are among the most active in terms of message count).
    > Since you have your game figured out (other thread) you obviously know
    > your way around Linux a little... could you do some troubleshooting with
    > us to identify the issue? A few questions to start:


    A little... maybe some, If I can figure out what you want...

    > Wired or wireless connection? If wireless, can you try wired? FYI: My
    > connection is wired; I have more issues when wireless at the other end of
    > my place, but that's to be expected.


    Both, My laptop is connected via wireless. But I have same problem with my
    desktop which is connected to the router via Ethernet cable...

    > Second, do you have IPv6 enabled on your machine? Have you tried
    > disabling and rebooting, unless you really need it? nntp.opensuse.org
    > does not have an AAAA (IPv6) DNS record from what I can tell, so if your
    > system tries that first it may timeout before trying the A (IPv4) DNS
    > record. Shouldn't work that way, but I don't use clients other than
    > Thunderbird, or other Linux distributions, for NNTP.


    I'm not sure... I've seen this happening with at least three of the Linux
    installed to my desktop system. But lets focus on the opensuze installation.
    I think opensuze may enable IPv6 by default. If you can tell me the cli
    command to disable it, I'll test that from the desktop. NOTE, I'm not using
    nether kde nor gnome, I prefer e17... So if possible make that cli something
    that works from a console (runlevel3 aka multi-user.target)...

    > It sounds like this happens regularly. Can you catch it in a LAN trace?
    >
    > Code:
    > ----------
    > sudo /usr/sbin/tcpdump -n -s 0 -i any -w /tmp/nntp0.cap port 119
    > ----------
    >
    > Let it run until you see the symptom and work past it. Hit ctrl+c to
    > cancel the trace and then post the resulting file somewhere after compressing:


    I'm guessing that I should run that from a different console or xterm than I'm
    going to run alpine in? Then when I get past the first 119 timeout well enough
    to open a forum message, I would switch back to the console or xterm where I
    ran the above command before I hit ctrl+c

    > Code:
    > ----------
    > bzip2 /tmp/nntp0.cap
    > ----------
    >
    > If you cannot post it anywhere else, like a Dropbox share or something,
    > let us know and we'll try something like ftp://ftp.novell.com/incoming and
    > see if somehow we can grab the file from there (it's a place where files,
    > once uploaded, can only be downloaded by Novell employees, so posting the
    > name of the file here won't risk anybody getting it unless they're
    > looking; Novell is affiliated with openSUSE, just so you know why their
    > FTP site is mentioned).


    Sounds like you think the data in the nntp0.cap file could be sensitive?

    So since my only option would be to upload it to my ISP provided web-space,
    which would mean that anybody who read the message with the link could access
    the file, perhaps I should hear more about this ftp://ftp.novell.com/incoming
    option...

    When I check it out with my favorite ftp client I can't navigate to any of the
    subdirectories, not even pub. nor can I view the readme...



    > Otherwise there are always fun little network tests assuming you have
    > 'netcat' installed:
    >
    > Code:
    > ----------
    > while [ 1 ] ; do date; netcat -zv nntp.opensuse.org 119; sleep 5; done
    > ----------
    >
    > Feel free to run that in a shell somewhere and see if you ever get any
    > failures connecting. If not, maybe the timeout is because of the amount
    > of data coming down from the NNTP server when you get new messages, but
    > that seems pretty unlikely too since you should only be getting what's
    > new, and that's not going to be measured in megabytes unless you're out
    > for quite a while.


    I assume netcat is in the repos...

    Should all of these tests wait till I've disabled IPv6???

    Be advised:
    It might take me a couple days to buy enough 'puter time from my lady.
    {She does get jealous of the time I spend on them...} And she's already heated
    with me for spending the time with that [other thread] amoebax thing...

    --
    JtWdyP


  4. #4

    Default Re: NNTP access problem: 119: Connection timed out...

    On 07/13/2013 03:39 AM, JtWdyP wrote:
    >> Second, do you have IPv6 enabled on your machine? Have you tried
    >> disabling and rebooting, unless you really need it? nntp.opensuse.org
    >> does not have an AAAA (IPv6) DNS record from what I can tell, so if your
    >> system tries that first it may timeout before trying the A (IPv4) DNS
    >> record. Shouldn't work that way, but I don't use clients other than
    >> Thunderbird, or other Linux distributions, for NNTP.

    >
    > I'm not sure... I've seen this happening with at least three of the Linux
    > installed to my desktop system. But lets focus on the opensuze installation.
    > I think opensuze may enable IPv6 by default. If you can tell me the cli
    > command to disable it, I'll test that from the desktop. NOTE, I'm not using
    > nether kde nor gnome, I prefer e17... So if possible make that cli something
    > that works from a console (runlevel3 aka multi-user.target)...


    Yes, all commands work from anywhere. To disable IPv6 run yast (from the
    command line or GUI) and go to Network Settings and modify your network
    card settings.

    Code:
    ----------
    sudo /sbin/yast lan
    ----------

    Under Global Options uncheck 'Enable IPv6' and then reboot after
    saving/exiting.

    >> It sounds like this happens regularly. Can you catch it in a LAN trace?
    >>
    >> Code:
    >> ----------
    >> sudo /usr/sbin/tcpdump -n -s 0 -i any -w /tmp/nntp0.cap port 119
    >> ----------
    >>
    >> Let it run until you see the symptom and work past it. Hit ctrl+c to
    >> cancel the trace and then post the resulting file somewhere after compressing:

    >
    > I'm guessing that I should run that from a different console or xterm than I'm
    > going to run alpine in? Then when I get past the first 119 timeout well enough
    > to open a forum message, I would switch back to the console or xterm where I
    > ran the above command before I hit ctrl+c


    If you can get the command there you could run this in a TTY (Ctrl+Alt+F2)
    so that it's always there and out of the way. Go back to your desktop
    (Ctrl+Alt+F7) and work until the issue happens, then finish duplicating
    and go back to the TTY and cancel the command. You could also do this
    from any xterm or equivalent.

    >> Code:
    >> ----------
    >> bzip2 /tmp/nntp0.cap
    >> ----------
    >>
    >> If you cannot post it anywhere else, like a Dropbox share or something,
    >> let us know and we'll try something like ftp://ftp.novell.com/incoming and
    >> see if somehow we can grab the file from there (it's a place where files,
    >> once uploaded, can only be downloaded by Novell employees, so posting the
    >> name of the file here won't risk anybody getting it unless they're
    >> looking; Novell is affiliated with openSUSE, just so you know why their
    >> FTP site is mentioned).

    >
    > Sounds like you think the data in the nntp0.cap file could be sensitive?


    The data should not be sensitive since the forums are public. Some people
    are paranoid about data they send out, so this option works. Basically
    point an FTP client of some sort to the server mentioned and upload the
    file, or use your own. Limited to port 119 nothing at all sensitive
    should show up. I'd be fine pulling from your server. Hopefully the
    problem isn't DNS or we won't catch it with that command, but you could
    try to get both:

    Code:
    ----------
    sudo /usr/sbin/tcpdump -n -s 0 -i any -w /tmp/nntp0.cap port 119 or port 53
    ----------

    > When I check it out with my favorite ftp client I can't navigate to any of the
    > subdirectories, not even pub. nor can I view the readme...
    >
    >


    "Helpful" FTP clients often fail on this site because of the restrictions
    imposed. If you use the command line it works just fine:

    Code:
    ----------
    ftp -a ftp.novell.com #-a automates an anonymous login
    binary
    cd incoming
    put /tmp/nntp0.cap.bz2
    bye
    ----------

    > I assume netcat is in the repos...


    Yes, indeed. It may be called netcat-openbsd or something, but you can
    find it with one of the following:

    Code:
    ----------
    zypper se netcat
    zypper se nc
    ----------

    > Should all of these tests wait till I've disabled IPv6???


    I would, since IPv6 is a suspect and not something you're likely
    needing/using.

    > Be advised:
    > It might take me a couple days to buy enough 'puter time from my lady.
    > {She does get jealous of the time I spend on them...} And she's already heated
    > with me for spending the time with that [other thread] amoebax thing...


    She's more important... take your time.

    Good luck.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NNTP access problem: 119: Connection timed out...

    On 2013-07-13 11:39, JtWdyP wrote:
    > I'm guessing that I should run that from a different console or xterm than I'm
    > going to run alpine in? Then when I get past the first 119 timeout well enough
    > to open a forum message, I would switch back to the console or xterm where I
    > ran the above command before I hit ctrl+c


    You are using alpine for nntp? wow. :-o

    I use alpine for email, but not for nntp because they do it wrong:
    alpine does not caches any message locallly, and does not keep record of
    what posts are already read and which not. I have not found a good
    enough text mode nntp client.

    It means that alpine is more sensitive than other clients to network
    problems.

    Anyway, I think you should try any other nntp client to find out if they
    exhibit the same problems or not.

    Alternatively, you could use leafnode, as a local nntp proxy server. I
    use it.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: NNTP access problem: 119: Connection timed out...

    On Fri, 12 Jul 2013 23:48:32 +0000, JtWdyP wrote:

    > nntp.opensuze.org


    Obviously, this isn't the address you're using - or is it?

    You might look at using tcptraceroute to see if there's something between
    you and the server dropping packets. Been working fine here for a very
    long time.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: NNTP access problem: 119: Connection timed out...

    Jim Henderson wrote:

    >> nntp.opensuze.org

    >


    Uh....?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NNTP access problem: 119: Connection timed out...

    On 2013-07-14 05:45, caf4926 wrote:
    > Jim Henderson wrote:
    >
    >>> nntp.opensuze.org

    >>

    >
    > Uh....?


    Look at the code section, the server name is correct there.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: NNTP access problem: 119: Connection timed out...


    It would appear that on Jul 13, ab did say:

    > Code:
    > ----------
    > sudo /sbin/yast lan
    > ----------
    >
    > Under Global Options uncheck 'Enable IPv6' and then reboot after
    > saving/exiting.


    Done...

    > >> It sounds like this happens regularly. Can you catch it in a LAN trace?


    BTW: Very regularly... Like every time lately.

    >
    > Code:
    > ----------
    > sudo /usr/sbin/tcpdump -n -s 0 -i any -w /tmp/nntp0.cap port 119 or port 53
    > ----------


    Done

    > "Helpful" FTP clients often fail on this site because of the restrictions
    > imposed. If you use the command line it works just fine:


    For chucks and giggles, since mc appears to be able to get to
    ftp.novell.com/incoming it's just that once there it can't get any ftp side
    ls data to update it's file list with etc.

    I tried using it's twin panel method of putting the file:
    jtwdyp-nntp0.cap.bz2
    But I had no feedback that it was successful so renamed the file:
    jtwdyp_nntp0.cap.bz2
    And did it this way:
    > Code:
    > ----------
    > ftp -a ftp.novell.com #-a automates an anonymous login
    > binary
    > cd incoming
    > put /tmp/nntp0.cap.bz2
    > bye
    > ----------


    Got errors when I tried to absolute pathname reference in the put line...
    So I repeated the ftp sequence from the directory containing the renamed
    file...

    150 Opening BINARY mode data connection for jtwdyp_nntp0.cap.bz2
    100% |******************************************************| 519 KB
    72.78 KB/s 00:00 ETA
    226 Transfer complete

    But I'd be curious to know if both the:
    jtwdyp_nntp0.cap.bz2
    And the:
    jtwdyp-nntp0.cap.bz2
    copies of the file got there...

    The problem is definately related to how alpine talks to nntp servers... as
    I can't get a single failed connection out of netcat...

    Any way to find out exactly where in the dialog alpine is screwing up so
    that I can try to talk to the people who currently work on it...

    Or, if it turns out that nntp.opensuse.org's server is being overly picky
    with what should be a legal communication dialog (according to the so called
    {RFCs???}) could the nntp server maybe get tweaked to make it tolerate alpine?

    --
    JtWdyP


  10. #10

    Default Re: NNTP access problem: 119: Connection timed out...


    It would appear that on Jul 13, Carlos E. R. did say:

    > You are using alpine for nntp? wow. :-o
    >
    > I use alpine for email, but not for nntp because they do it wrong:
    > alpine does not caches any message locallly, and does not keep record of
    > what posts are already read and which not. I have not found a good
    > enough text mode nntp client.


    You mean remember the difference between read messages and expunged ones the
    next time the nttp "folder" is opened right? Your right that alpine doesn't
    keep a database for that. The nntp servers certainly are not going to hold
    they kind of flag data for each and every user on the server.
    I "save" the "interesting" posts to a local folder where alpine does track
    that data because with local and/or imap folders such data is saved in the
    folder with the message.

    > It means that alpine is more sensitive than other clients to network
    > problems.


    That I've noticed. I suspect that the alpine team has always insisted on
    following the letter of what they call {is it "RFC"s?} rather than conforming
    to any defacto standards commonly in place with the servers it interacts with.
    Still, I agree they could/should have done a better job on the topic of silently
    reconnecting to a server, when something hiccups. That and when downloading
    a chunk of messages (say 100 for example) where the index data didn't have the
    right content length for a few of them, including zero length deleted articles,
    it would be nice if alpine would continue processing the rest of the
    messages...

    But that said, while Alpine has always been sensitive to time out on long
    periods of inactivity, (like while composing a reply) I never had trouble
    just opening nntp.opensuze.org with it before... Unless you count the short
    period when I didn't know I needed to stop using forums.opensuze.org...

    And Gmane's nntp mailing list gateway is STILL working as expected. Which
    for my purposes is good enough.

    > Anyway, I think you should try any other nntp client to find out if they
    > exhibit the same problems or not.


    I think that any client that does try to track the read state for messages kept ON
    an nntp would have to do so in a separate {local?} file or internal program data.
    Right? In which case I don't think it would be suitable for my needs where I
    sometimes find a reason ( in the middle of composing a message) to suddenly
    postpone/close any open edits/files and reboot into one of the other 4 Linux
    currently installed on my PC, and then reopen said files/compositions from there.
    When that happens I need the mail/news client on say opensuse to have the same
    message flags and/or expunged state, as I had on say Sabayon a couple minutes ago.

    I also don't want to deal with the {to me} horrid gui user interface I've found
    with any of the gui clients I've ever looked at.

    > Alternatively, you could use leafnode, as a local nntp proxy server. I
    > use it.


    Now THAT would be a possibility. However...

    I've never been interested in maintaining a true local news spool on my Linux. {If
    I went there for my desktop I'd have to do it for all 5 distros.} And
    somehow all 5 would have to share the same spool data. Perhaps in similar
    fashion to how alpine on all 5 distro share the same local mail folders via

    Code:
    -------------------
    ln - s ~/mail /path/to/personal/data/partition/maildir
    -------------------

    I also sync my assorted newsrc files {also on data partition} with simlinks...

    I did look at a wiki on leafnode, it implied that I'd need to bother with
    setting up a fully qualified domain name. Which I don't want, and otherwise
    it looked like too much work to get it all set up for what little use I'd
    get from it... 99% of the time my only use for nntp is gmane & opensuse.
    Alpine doesn't have any trouble with gmane. And I no how to make it
    connect to opensuse. It just takes more effort than it should.

    But thanks for the suggestions.

    --
    JtWdyP


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •