Results 1 to 3 of 3

Thread: OS 12.3 x86_64 with kblankscrn windows open on boot.

  1. #1
    Join Date
    Jun 2008

    Default OS 12.3 x86_64 with kblankscrn windows open on boot.


    I have the lattest updated version of OS 12.3 64bits and I am using default KDE and when I log in to my usuall session I get a huge amount of kblankscrn windows poping up all over the desktop.

    The strange thing is that the number of windows varies for each new boot.

    The windows are labelled kblankscrn <n> and are just plain black windows.

    and the process list show something like :

    6253 ?        S      0:00 kblankscrn.kss -session 1017f1b11721ae000137345294600000060460022_1373498660_280078
     6257 ?        S      0:00 kblankscrn.kss -session 1017f1b11721ae000137345805700000060460036_1373498660_280275
     6261 ?        S      0:00 kblankscrn.kss -session 1017f1b11721ae000137346069200000060460046_1373498660_280627
     6271 ?        S      0:00 kblankscrn.kss -session 1017f1b11721ae000137349354400000060460098_1373498660_281205
     6423 pts/3    S+     0:00 grep --color=auto kblank
    Seems like unfinished screensaver sessions from previous logins ?

    Anyone with the same problem ..


  2. #2
    Join Date
    Jun 2008
    Earth - Denmark

    Default Re: OS 12.3 x86_64 with kblankscrn windows open on boot.

    On 07/11/2013 10:46 AM, keyb user wrote:
    > Anyone with the same problem ..

    Google's answer to that questions is "yes", see

    where i didn't read more than just to see a KDE forum mentioning a
    bug has been filed, and a kbuntu forum with a "[SOLVED]" in the subject..

    NOTE: i have no idea if the solution(s) you read in other forums will
    'fit' your openSUSE or not, so do not take my post to mean i
    recommend you follow anyone's advice until you have done your due
    diligence--which includes reading my sig caveat.


  3. #3

    Default Re: OS 12.3 x86_64 with kblankscrn windows open on boot.

    This is a known bug in KDE since 4.10:

    The problem is that some screensavers don't quit correctly but keep running in the background. On next login all those processes get restarted by KDE's session management. Those are the windows you see.

    - Select a different screensaver (this only happens with some, "blank screen" is one of them)
    - disable KDE's session management in "Configure Desktop" (systemsettings)-> "Launch and Quit"->Session Management, set "On Login" to "Start with empty session" OR enter "kblankscrn.kss" in the text field below "Applications to be excluded from sessions:".
    Note that the latter only prevents those windows appearing on boot, you'll still have multiple kblankscrn.kss processes in memory after some time (a new one each time the screensaver kicks in).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts