Results 1 to 2 of 2

Thread: Google Chrome Stable: undefined symbol: _XGetRequest

  1. #1

    Default Google Chrome Stable: undefined symbol: _XGetRequest

    I am still using OpenSuSE v12.1 on an AMD64 Phenom II X3 computer. I had an older version of Google Chrome Stable installed and yesterday I decided to remove it. Then, manually installed the latest Google Chrome Stable version (rpm -ivh ~mazilo/Downloads/google-chrome-stable-28.0.1500.71-209842.x86_64.rpm --nodeps). Since then, Google Chrome no longer works (as I expected) and spits out an error message (/usr/bin/google-chrome: symbol lookup error: /usr/bin/google-chrome: undefined symbol: _XGetRequest) when I manually executed it as seen below.
    Code:
    [root@Mi:~/Downloads 93%] # rpm -ivh google-chrome-stable-28.0.1500.71-209842.x86_64.rpm --nodeps
    Preparing...                ########################################### [100%]
       1:google-chrome-stable   ########################################### [100%]
    redirecting to systemctl
    22.534u+4.312s=0:51.02e(52.6%) TDSavg=0k+0k+0k max=73572k 24+2166128io 0pf+0sw
    [mazilo@Mi:/tmp 155%] ~ google-chrome 
    /usr/bin/google-chrome: symbol lookup error: /usr/bin/google-chrome: undefined symbol: _XGetRequest
    [mazilo@Mi:/tmp 156%] ~
    The question I have is how do I revert to an older and/or working version of Google Chrome.

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Google Chrome Stable: undefined symbol: _XGetRequest

    Why did you install it with nodeps flag?
    Uninstall it and try installing it without nodeps flag. See the error messages on the dependency if any.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •