Results 1 to 2 of 2

Thread: [Solved] *ERROR* EDID checksum is invalid, remainder is N

Hybrid View

  1. #1

    Default [Solved] *ERROR* EDID checksum is invalid, remainder is N

    Just posting in case anyone else runs into this. After boot, your tty1 looks like this:

    Code:
    doing fast boot
    Creating device nodes with udev
    [    2.123456] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 43
    [    2.123456] Raw EDID:
    [    2.123456]  ∘00 ff ff ff ff ff ff 00 4c 5b ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    [    2.123456]  ∘ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
    
    Welcome to openSUSE 12.3 "Dartmouth" - Kernel 3.7.10-1.16-desktop (tty1).
    Firstly, note that EDID refers to "Extended display identification data" (see wikipedia). This is the information that the monitor sends to the PC about itself -- notably including a list of acceptable resolutions.

    The error message means: communication between monitor and PC is not working very well, and the EDID information package was not received properly. This will not stop you working; however, sometimes you may find that your computer falls back to a "safe" (and not very sexy) resolution like 800x600, or worse.

    The usual cause is: long, low-quality VGA cables used for high-resolution monitors. You may also be seeing some ghosting on your monitor (unsharp image, looks like it's been wiped out a little, usually to the right). Solution: use DVI or DisplayPort instead (or the royalty-paid alternative: HDMI). For the time being, consider switching to a lower resolution.

    The error does also happen with laptops, in which case you may want to get the PC <-> Monitor connection (internal to the laptop) looked at by an engineer.

    If you are happy with your monitor, and just want the error message to bugger off, try something like this in your /etc/X11/xorg.conf.d:

    Code:
    Option "IgnoreEDID" "1"
    Modes "1152X864" "1024X768" "800x600"
    (With thanks to John Peschken over at the Ubuntu forum.)

    The above may also help if X is falling back to "safe" resolutions.

    Good luck!

  2. #2

    Default Re: [Solved] *ERROR* EDID checksum is invalid, remainder is N

    I just want to add something:
    Sometimes it also helps to fix EDID errors if you just completely unplug your monitor (including the power plug).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •