Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: trying to install extcalc

  1. #11
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,787

    Default Re: trying to install extcalc

    Would help to see the origianl permissions. Should be owned by root with users allowed to execute.

  2. #12
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: trying to install extcalc

    On 07/09/2013 07:36 PM, gogalthorp wrote:
    > Would help to see the origianl permissions.


    i expect the one i posted (-rwxr-xr-x 1 root root) is exactly 100%
    original.

    --
    dd

  3. #13
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,462

    Default Re: trying to install extcalc

    That's what I have and it opens using KDE Plasma or from the console.

  4. #14
    George Olson NNTP User

    Default Re: trying to install extcalc

    On 07/10/2013 02:55 AM, dd wrote:
    > On 07/09/2013 07:36 PM, gogalthorp wrote:
    >> Would help to see the origianl permissions.

    >
    > i expect the one i posted (-rwxr-xr-x 1 root root) is exactly 100%
    > original.
    >

    Yes, that is what it was.

    I think I found the problem, though. The directory /opt/kde3/bin/ was
    not in my $PATH. So I added it to the $PATH, and change the permissions
    back to root:root on both extcalc and pgcalc, and they both run now, but
    only from the shell.

    This is how I added the directory to $PATH and then checked that it was
    on there:

    Code:
    george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
    george@tribaltrekker:~> echo $PATH
    /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/
    I wonder why the directory /opt/kde3/bin/ was never automatically added
    to my PATH variable? Could that be because of installing it by way of
    sudo instead of su - like you said?

    Also, how do I add a directory to $PATH for the KDE desktop environment?
    The programs will run out of the shell now, so it seems like I only
    added the /opt/kde3/bin/ directory to the $PATH that applies to the
    shell. (I am using bash for my shell)

    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it

  5. #15

    Default Re: trying to install extcalc

    On 2013-07-11, George Olson <golson765@no-mx.forums.novell.com> wrote:
    > I think I found the problem, though.


    Look George. We're not supreme beings (well maybe Andreas is). We're not clairvoyant nor we can't send imps or gremlins to
    to behold your computer screen to see what you mean when you say `program X can only be run as root'. There may be
    hackers among forum members (there's certainly the talent) who can sneak into your computer and fiddle about with your
    machine, but they wouldn't admit it here.

    So please output what you seen when you run:

    Code:
    sh-4.2$ extcalc
    or

    Code:
    sh-4.2$ pgcalc
    .... as a regular user, having installed either program the normal way (either through YaST or zypper in).




  6. #16
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: trying to install extcalc

    On 07/11/2013 08:44 AM, George Olson wrote:
    >
    Code:
    > george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
    > george@tribaltrekker:~> echo $PATH
    > /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/
    >
    >
    > I wonder why the directory/opt/kde3/bin/ was never automatically added
    > to my PATH variable? Could that be because of installing it by way of
    > sudo instead of su - like you said?


    i do not know...i looked at my path and see
    Code:
    /home/denverd/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin
    and then look and see that /usr/X11R6/bin and /usr/games are totally
    empty which i can't explain other than i must have, while trying to
    help someone here installed a game to try to help and afterwards
    uninstalled the game....maybe something similar caused /opt/kde3/bin
    to be created and put in the path..

    i believe that ideally a correctly created rpm would not only place
    the exec in the right place but also add that place to the path..

    but, if i look at your path (quoted above) i see "/home/george/bin"
    *three* times and i wonder why!! i wonder if you ran "sudo zypper
    extcalc" _while_ in /home/george/bin and zypp installed the
    executable in the right place but wrongly added your current location
    to the user path??

    strange.... i can't answer, but someone around here can!

    > Also, how do I add a directory to $PATH for the KDE desktop environment?
    > The programs will run out of the shell now, so it seems like I only
    > added the/opt/kde3/bin/ directory to the $PATH that applies to the
    > shell. (I am using bash for my shell)


    i do not understand that question. please try again. are you planning
    to change your shell from bash? to what? (and why? i mean of course
    you can change it to whatever you want, but moving from bash is gonna
    severely reduce the number of knowledgeable helpers...)

    --
    dd
    http://tinyurl.com/DD-Caveat


  7. #17
    George Olson NNTP User

    Default Re: trying to install extcalc

    On 07/11/2013 06:08 PM, dd wrote:

    >
    >> Also, how do I add a directory to $PATH for the KDE desktop environment?
    >> The programs will run out of the shell now, so it seems like I only
    >> added the/opt/kde3/bin/ directory to the $PATH that applies to the
    >> shell. (I am using bash for my shell)

    >
    > i do not understand that question. please try again. are you planning to
    > change your shell from bash? to what? (and why? i mean of course you can
    > change it to whatever you want, but moving from bash is gonna severely
    > reduce the number of knowledgeable helpers...)
    >


    Sorry, not clear on that one. What I mean by that is, is there a
    different PATH variable for the KDE desktop environment (kwin?) than
    there is for a bash shell? I saw an older post,

    http://forums.opensuse.org/english/g...tory-path.html


    that specified some terms called "csh" and "tcsh", as distinguished
    differently from ".bashrc". So I was wondering if perhaps when you are
    in a bash shell, the PATH that applies to the shell is actually not the
    same PATH that applies in the KDE desktop environment. If there is, I
    was wondering how you change that PATH, because changing it in bash
    didn't seem to do the job for being able to run the file by clicking on
    an icon. I can change the icon settings to look in the /opt/kde3/bin/
    directory, for the application, but was thinking that I shouldn't have
    to do that.

    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it

  8. #18
    George Olson NNTP User

    Default Re: trying to install extcalc

    On 07/11/2013 04:29 PM, flymail wrote:
    > On 2013-07-11, George Olson <golson765@no-mx.forums.novell.com> wrote:
    >> I think I found the problem, though.

    >
    > Look George. We're not supreme beings (well maybe Andreas is). We're not clairvoyant nor we can't send imps or gremlins to
    > to behold your computer screen to see what you mean when you say `program X can only be run as root'. There may be
    > hackers among forum members (there's certainly the talent) who can sneak into your computer and fiddle about with your
    > machine, but they wouldn't admit it here.
    >


    nice, lol

    > So please output what you seen when you run:
    >
    >
    Code:
    > sh-4.2$ extcalc
    >


    Code:
    george@tribaltrekker:~> extcalc
    If 'extcalc' is not a typo you can use command-not-found to lookup the
    package that contains it, like this:
    cnf extcalc

    >
    > or
    >
    >
    Code:
    > sh-4.2$ pgcalc
    >


    Code:
    george@tribaltrekker:~> pgcalc
    If 'pgcalc' is not a typo you can use command-not-found to lookup the
    package that contains it, like this:
    cnf pgcalc



    >
    > ... as a regular user, having installed either program the normal way (either through YaST or zypper in).
    >
    >
    >



    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it

  9. #19
    George Olson NNTP User

    Default Re: trying to install extcalc

    On 07/11/2013 06:08 PM, dd wrote:
    > On 07/11/2013 08:44 AM, George Olson wrote:


    > i do not understand that question. please try again. are you planning to
    > change your shell from bash? to what? (and why? i mean of course you can
    > change it to whatever you want, but moving from bash is gonna severely
    > reduce the number of knowledgeable helpers...)
    >


    Well, now I see that the issue must be something deeper. I had an
    interesting thing happen - I opened up a bash console, added
    /opt/kde3/bin/ to the path, and ran extcalc. It ran fine. I checked the
    PATH, and /opt/kde3/bin/ was in the PATH variable. Then I exited the
    shell, and reopened the shell, and extcalc would no longer run. I
    checked the PATH variable again, and /opt/kde3/bin/ was no longer in the
    path. It had only been added for that open session of the konsole, and
    then it went back to the way it was before once I closed the konsole.

    How do I add /opt/kde3/bin/ permanently to the PATH variable?

    Here is how I added it before. Note that I am not adding it as root, as
    it seems that root has its own PATH variable (correct me if I am wrong
    on that).

    Code:
    george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
    george@tribaltrekker:~> echo $PATH
    /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/
    Then I closed the konsole, opened it up again within 5 seconds after
    closing it, and checked path:

    Code:
    george@tribaltrekker:~> echo $PATH
    /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/
    See, it's not there!


    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it

  10. #20
    George Olson NNTP User

    Default Re: trying to install extcalc

    On 07/12/2013 11:44 AM, George Olson wrote:
    > On 07/11/2013 06:08 PM, dd wrote:
    >> On 07/11/2013 08:44 AM, George Olson wrote:

    >
    >> i do not understand that question. please try again. are you planning to
    >> change your shell from bash? to what? (and why? i mean of course you can
    >> change it to whatever you want, but moving from bash is gonna severely
    >> reduce the number of knowledgeable helpers...)
    >>

    >
    > Well, now I see that the issue must be something deeper. I had an
    > interesting thing happen - I opened up a bash console, added
    > /opt/kde3/bin/ to the path, and ran extcalc. It ran fine. I checked the
    > PATH, and /opt/kde3/bin/ was in the PATH variable. Then I exited the
    > shell, and reopened the shell, and extcalc would no longer run. I
    > checked the PATH variable again, and /opt/kde3/bin/ was no longer in the
    > path. It had only been added for that open session of the konsole, and
    > then it went back to the way it was before once I closed the konsole.
    >
    > How do I add /opt/kde3/bin/ permanently to the PATH variable?
    >
    > Here is how I added it before. Note that I am not adding it as root, as
    > it seems that root has its own PATH variable (correct me if I am wrong
    > on that).
    >
    >
    Code:
    > george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
    > george@tribaltrekker:~> echo $PATH
    > /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/
    >
    >
    > Then I closed the konsole, opened it up again within 5 seconds after
    > closing it, and checked path:
    >
    >
    Code:
    > george@tribaltrekker:~> echo $PATH
    > /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/
    >
    >
    > See, it's not there!
    >
    >


    Well, now it is there:

    Code:
    george@tribaltrekker:~> echo $PATH
    /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/home/george/bin/:/home/george/bin/
    All I did differently was reboot - I ran zypper ps and saw there were
    some things that needed to be reset, so I rebooted and then opened a
    konsole and checked PATH. Looks like it is in there now and this did the
    trick.

    Also, the file runs now from the icon without having to put the full
    path in the application line. So looks like the problem is solved.

    Thanks to everyone for your help!

    --
    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •