Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Very poor performance when zooming webpages

  1. #11

    Default Re: Very poor performance when zooming webpages

    Ok, it wants me to choose what to do with the dependency found (see picture)



    OpenSUSE Leap 42.2 x64 KDE

  2. #12
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Exclamation Re: Very poor performance when zooming webpages

    Quote Originally Posted by robertot5 View Post
    Ok, it wants me to choose what to do with the dependency found (see picture)



    Looks like you have tried to install all nVIDIA driver versions, but in fact you only need one version. What video card chip set are you using? I would find out the latest driver version my video chipset would take, and only have that installed. I use the open source driver and only have the following files for nvidia loaded (Searching for nvidia in YaST):

    Code:
    libdrm_nouveau2
    libdrm_nouveau2-32bit
    xf86-video-nv 
    xorg-x11-driver-video-nouveau

    Once you find out the supported version, either only use that, such as 319.17 or get rid of it all like I have or consider loading the driver the hard way, outside of YaST:

    Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

    But you do not load every file that has the word nVIDIA in it.

    Thank You,
    Last edited by jdmcdaniel3; 18-Jul-2013 at 18:07.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #13

    Default Re: Very poor performance when zooming webpages

    Quote Originally Posted by robertot5 View Post
    Ok, it wants me to choose what to do with the dependency found (see picture)
    Well, as I said: Remove all the packages with "nvidia" in the NAME.
    That doesn't include "xf86-video-nv", does it? So keep that.

    Remove those:
    - nvidia-computeG02
    - nvidia-computeG03
    - nvidia-gfxG02-kmp-default
    - nvidia-gfxG02-kmp-desktop
    - nvidia-gfxG03-kmp-default
    - nvidia-settings
    - x11-video-nvidiaG02
    - x11-video-nvidiaG03

    Then continue the way I wrote before.

    Regarding "nvidia-settings": this is a very old version (290.10) that doesn't even work anymore with the current driver.
    You don't need that anyway, since it is included in the driver package.

  4. #14

    Default Re: Very poor performance when zooming webpages

    Quote Originally Posted by wolfi323 View Post
    Well, as I said: Remove all the packages with "nvidia" in the NAME.
    That doesn't include "xf86-video-nv", does it? So keep that.

    Remove those:
    - nvidia-computeG02
    - nvidia-computeG03
    - nvidia-gfxG02-kmp-default
    - nvidia-gfxG02-kmp-desktop
    - nvidia-gfxG03-kmp-default
    - nvidia-settings
    - x11-video-nvidiaG02
    - x11-video-nvidiaG03

    Then continue the way I wrote before.

    Regarding "nvidia-settings": this is a very old version (290.10) that doesn't even work anymore with the current driver.
    You don't need that anyway, since it is included in the driver package.
    I've installed the driver as stated and everything seems fine now, though the isse with poor performance on webpages with high multimedia content remains, I'm still trying to track down what hardware component could cause that.
    OpenSUSE Leap 42.2 x64 KDE

  5. #15

    Default AW: Re: Very poor performance when zooming webpages

    Quote Originally Posted by robertot5 View Post
    I've installed the driver as stated and everything seems fine now, though the isse with poor performance on webpages with high multimedia content remains, I'm still trying to track down what hardware component could cause that.
    Better install "Mesa-demo-x" and check with "glxinfo | grep render" if the driver really is working.

    Also you could try to turn ON hardware acceleration again.
    Check if hw acceleration is turned ON for flash: Right-click on a flash video and choose settings.

    Also which desktop environment are you using?
    IF KDE, open "Configure Desktop"->"Desktop Effects"->"Advanced" and check that "Composite type" is set to "OpenGL" and "Qt graphics system" is set to "raster".

  6. #16

    Default Re: AW: Re: Very poor performance when zooming webpages

    Quote Originally Posted by wolfi323 View Post
    Better install "Mesa-demo-x" and check with "glxinfo | grep render" if the driver really is working.

    Also you could try to turn ON hardware acceleration again.
    Check if hw acceleration is turned ON for flash: Right-click on a flash video and choose settings.

    Also which desktop environment are you using?
    IF KDE, open "Configure Desktop"->"Desktop Effects"->"Advanced" and check that "Composite type" is set to "OpenGL" and "Qt graphics system" is set to "raster".
    This is the result of "glxinfo | grep render"

    Code:
    direct rendering: Yes
    OpenGL renderer string: GeForce 8600 GT/PCIe/SSE2
        GL_NV_blend_square, GL_NV_conditional_render, GL_NV_copy_depth_to_color, 
        GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info,
    I checked Desktop Effects ! Compositing type is indeed set to OpenGL. Instead, I do not find a Qt graphics system option. I have KDE on OpenSUSE 12.2 x64.

    If I check Flash settings on any videos I have the "Enable hardware acceleration" checked, even though I disabled it in Firefox settings. Enabling or disabling that option in Flash settings does not seem to make any difference. I will try and enable "Use hardware acceleration when available" option in Firefox and see if anything improoves.

    Thank you !
    OpenSUSE Leap 42.2 x64 KDE

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •