Results 1 to 10 of 10

Thread: kernel3.10 has a big problem

  1. #1

    Default kernel3.10 has a big problem

    the 3.10 kernel made my cpu runing on the fastest freq with turbo boot always on,when i downgrade it to 12.3‘s kernel 3.7 ,the problem solved

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,052
    Blog Entries
    3

    Default Re: kernel3.10 has a big problem

    Quote Originally Posted by zhanshime View Post
    the 3.10 kernel made my cpu runing on the fastest freq with turbo boot always on,when i downgrade it to 12.3‘s kernel 3.7 ,the problem solved
    Consider posting a bug report on this. I would start with the opensuse bugzilla, though they might tell you to post to the kernel bug reporting site. Bug reports are how we get feedback to the developers who can fix things.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: kernel3.10 has a big problem

    Quote Originally Posted by zhanshime View Post
    the 3.10 kernel made my cpu runing on the fastest freq with turbo boot always on,when i downgrade it to 12.3‘s kernel 3.7 ,the problem solved
    First off, no need to shout, we have no problem reading your message. I am using kernel 3.10 and the CPU speed governors are working just fine for me. I use my SAKC bash script to compile the kernel and I used the configuration editor to install all possible governors whcih are:

    Your 5 Options: CONSERVATIVE,ONDEMAND,USERSPACE,POWERSAVE,PERFORMANCE

    By default you may not get them all. Further, during the kernel configuration process, you can set the default kernel speed governor. I see nothing wrong with the kernel verion 3.10 as it relates to controlling CPU speed governors with an Intel CPU. Here are some references that might be helpful to you:

    openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

    C.F.U. - CPU Frequency Utilitiy - Version 1.10 - For use with the cpufrequtils package - Blogs - openSUSE Forums

    Linux Kernel 3.10 RCX has Been Released To Test - Post Your Comments Here!

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: kernel3.10 has a big problem

    i have already set the cpu run on the powersave mode but it doesn‘t work ,
    with 3.10 it has two options :POWERSAVE,PERFORMANCE,not work
    with 3.7 it has two options :ONDEMAND,PERFORMANCE,work
    http://sdrv.ms/14wiREP

    Quote Originally Posted by jdmcdaniel3 View Post
    First off, no need to shout, we have no problem reading your message. I am using kernel 3.10 and the CPU speed governors are working just fine for me. I use my SAKC bash script to compile the kernel and I used the configuration editor to install all possible governors whcih are:

    Your 5 Options: CONSERVATIVE,ONDEMAND,USERSPACE,POWERSAVE,PERFORMANCE

    By default you may not get them all. Further, during the kernel configuration process, you can set the default kernel speed governor. I see nothing wrong with the kernel verion 3.10 as it relates to controlling CPU speed governors with an Intel CPU. Here are some references that might be helpful to you:

    openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

    C.F.U. - CPU Frequency Utilitiy - Version 1.10 - For use with the cpufrequtils package - Blogs - openSUSE Forums

    Linux Kernel 3.10 RCX has Been Released To Test - Post Your Comments Here!

    Thank You,

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: kernel3.10 has a big problem

    Quote Originally Posted by zhanshime View Post
    i have already set the cpu run on the powersave mode but it doesn‘t work ,
    with 3.10 it has two options :POWERSAVE,PERFORMANCE,not work
    with 3.7 it has two options :ONDEMAND,PERFORMANCE,work

    http://sdrv.ms/14wiREP
    So it looks like you have kernel 3.1.0-rc4, but kernel 3.10 full is out now: linux-3.10.tar.xz

    You can use my SAKC bash script to install it: S.A.K.C. - SUSE Automated Kernel Compiler

    You must modify your kernel configuration to get all of the speed governors to work. It is hard for me to give you exact instructions as I don't have the steps down by memory. However, if you want to try SAKC, will stop using the font size of 4, the default should be just 2, I will do some screen captures just for you on how to make the CPU Speed Governor changes and post them here online.

    Thank You,

    I have made a blog comment with instructions on how to select your speed governors when you compile your own kernel: https://forums.opensuse.org/blogs/jd...40/#comment856
    Last edited by jdmcdaniel3; 05-Jul-2013 at 18:32.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: kernel3.10 has a big problem

    Quote Originally Posted by jdmcdaniel3 View Post
    I am using kernel 3.10 and the CPU speed governors are working just fine for me. I use my SAKC bash script to compile the kernel and I used the configuration editor to install all possible governors whcih are:

    Your 5 Options: CONSERVATIVE,ONDEMAND,USERSPACE,POWERSAVE,PERFORMANCE

    By default you may not get them all. Further, during the kernel configuration process, you can set the default kernel speed governor. I see nothing wrong with the kernel verion 3.10 as it relates to controlling CPU speed governors with an Intel CPU
    No, things have changed in some cases now James; see my post here.

  7. #7

    Default Re: kernel3.10 has a big problem

    I solved the problem according to Tyler_K's explain:
    • in 3.10, support for the P-state driver was extended to Ivy Bridge (what you have) processors ... maybe Haswell too? (I don't remember)
    • all the cpufreq scaling governors do not apply ... do NOT use them with the p-state driver, which (IIRC) is built into the kernel (i.e. static as opposed to a module)
    • to disable the pstate driver (if you really are having trouble with it), use the "intel_pstate=disable" boot option


    Quote Originally Posted by jdmcdaniel3 View Post
    So it looks like you have kernel 3.1.0-rc4, but kernel 3.10 full is out now: linux-3.10.tar.xz

    You can use my SAKC bash script to install it: S.A.K.C. - SUSE Automated Kernel Compiler

    You must modify your kernel configuration to get all of the speed governors to work. It is hard for me to give you exact instructions as I don't have the steps down by memory. However, if you want to try SAKC, will stop using the font size of 4, the default should be just 2, I will do some screen captures just for you on how to make the CPU Speed Governor changes and post them here online.

    Thank You,

    I have made a blog comment with instructions on how to select your speed governors when you compile your own kernel: https://forums.opensuse.org/blogs/jd...40/#comment856

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: kernel3.10 has a big problem

    And so you added in the kernel command: "intel_pstate=disable" and that solved your problem?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: kernel3.10 has a big problem

    Quote Originally Posted by Tyler_K View Post
    No, things have changed in some cases now James; see my post here.
    So I have an i7 4770K on my PC now and the only thing I see wrong is that the Governor Userspace does not seem to work, but the other four do change the CPU speed. As far as user control of CPU speed settings, what options does a user even get now with the new cpu's?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  10. #10

    Default Re: kernel3.10 has a big problem

    Hi James,
    Quote Originally Posted by jdmcdaniel3 View Post
    So I have an i7 4770K on my PC now and the only thing I see wrong is that the Governor Userspace does not seem to work, but the other four do change the CPU speed.
    While I'm entirely uncertain, I would guess then that the "maybe" in:
    Quote Originally Posted by Tyler_K
    in 3.10, support for the P-state driver was extended to ... maybe Haswell too? (I don't remember)
    is actually a case of "no, it wasn't" for Haswell ... so, if the later is the case, then the regular cpufreq governors would still apply to you (for now) until support for the latest processors get added to the p-state driver

    As far as user control of CPU speed settings, what options does a user even get now with the new cpu's?
    From the little that I've seen about it so far, I believe that you can still see freq. info through userspace tools (like cpupower etc), but you can no longer control the freq. settings, or that there is actually very little left for the user to control.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •