Results 1 to 5 of 5

Thread: GNOME, openSUSE 12.3, hibernate not working

  1. #1

    Default GNOME, openSUSE 12.3, hibernate not working

    Hi,

    I "zypper dupped" from openSUSE 12.1 to 12.3. The update basically worked, though there were several issues to get the system back to life afterwards (Xorg not running due to Nvidia vs nouveau driver issues, GNOME desktop immediately crashing on login, since the new GNOME didn't like something which the old GNOME version had stored in the ~/.gnome2 directory etc). But that's all resolved, the system is working now - except hibernation.


    • I have already installed "gnome-shell-extension-alternative-status-menu".
    • I also enabled the extension via https://extensions.gnome.org/local/ (would be cool if it had been enabled by default, when installed).


    The problem:
    • I'm seeing the "hibernate" option in the GNOME menu now, but when I select the option, the desktop is only locked - but then it doesn't hibernate at all. The system keeps running. I can unlock the screen again, retry etc - but it never hibernates.
    • Hibernation works perfectly when I enable it by command-line though: "pm-hibernate" works just fine. So it's not caused by a missing swap partition etc.


    Apparently there's something not working which connects the GNOME GUI option "hibernate" to the actual system call.

    In /var/log/messages I can see the following error messages whenever I trigger the GNOME "hibernate" option - so this could be related:

    dbus-daemon[722]: dbus[722]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=714 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.248" (uid=1000 pid=10701 comm="/usr/bin/gnome-session ")

    dbus[722]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=714 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.248" (uid=1000 pid=10701 comm="/usr/bin/gnome-session ")


    Any ideas on what to check welcome!


    Thanks!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: GNOME, openSUSE 12.3, hibernate not working

    Quote Originally Posted by thorstenbr View Post
    Hi,

    I "zypper dupped" from openSUSE 12.1 to 12.3. The update basically worked, though there were several issues to get the system back to life afterwards (Xorg not running due to Nvidia vs nouveau driver issues, GNOME desktop immediately crashing on login, since the new GNOME didn't like something which the old GNOME version had stored in the ~/.gnome2 directory etc). But that's all resolved, the system is working now - except hibernation.


    • I have already installed "gnome-shell-extension-alternative-status-menu".
    • I also enabled the extension via https://extensions.gnome.org/local/ (would be cool if it had been enabled by default, when installed).


    The problem:
    • I'm seeing the "hibernate" option in the GNOME menu now, but when I select the option, the desktop is only locked - but then it doesn't hibernate at all. The system keeps running. I can unlock the screen again, retry etc - but it never hibernates.
    • Hibernation works perfectly when I enable it by command-line though: "pm-hibernate" works just fine. So it's not caused by a missing swap partition etc.


    Apparently there's something not working which connects the GNOME GUI option "hibernate" to the actual system call.

    In /var/log/messages I can see the following error messages whenever I trigger the GNOME "hibernate" option - so this could be related:

    dbus-daemon[722]: dbus[722]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=714 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.248" (uid=1000 pid=10701 comm="/usr/bin/gnome-session ")

    dbus[722]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=714 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.248" (uid=1000 pid=10701 comm="/usr/bin/gnome-session ")


    Any ideas on what to check welcome!


    Thanks!
    Just something you could try. Create a text file called "Hibernate-To-Disk" that contains the text:

    Code:
    [Desktop Entry]
    Comment[en_US]=Hibernate to Disk
    Comment=Hibernate to Disk
    Exec=/bin/sh -c 'echo disk > /sys/power/state'
    GenericName[en_US]=Hibernate-To-Disk
    GenericName=Hibernate-To-Disk
    Icon=xfsm-hibernate
    MimeType=
    Name[en_US]=Hibernate to Disk
    Name=Hibernate to Disk
    Path=
    StartupNotify=false
    Terminal=false
    TerminalOptions=
    Type=Application
    X-DBUS-ServiceName=
    X-DBUS-StartupType=none
    X-KDE-SubstituteUID=true
    X-KDE-Username=
    Save the file in the folder /usr/share/applications as root. A file manager run as root would work. Not sure if you might need to log out and in or not. The icon I found might not be present and need to be changed, but this seems to work for me, found under applications in GNOME. I created it under KDE first where it also works. When you startup Grub, you can select any openSUSE kernel you want as your entire image gets loaded from disk. I keep all desktops loaded and so I often am not sure what part is working, but one issue might be needing to be root. You can add in sudo to the exe command (Exec=sudo /bin/sh -c 'echo disk > /sys/power/state') and set terminal to yes (Terminal=true) and see what that does if it does not work right off.

    Thank You,

    PS: Make sure to save your work first when playing with Hibernate.
    Last edited by jdmcdaniel3; 01-Jul-2013 at 18:20.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: GNOME, openSUSE 12.3, hibernate not working

    Code:
    gnome-shell-extension-alternative-status-menu
    is already in the main repos. On seeing this thread invoked hibernate and it works perfectly on openSUSE 12.3
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4
    Join Date
    Jan 2009
    Posts
    16

    Default Re: GNOME, openSUSE 12.3, hibernate not working

    Quote Originally Posted by thorstenbr View Post
    Hi,

    I "zypper dupped" from openSUSE 12.1 to 12.3. The update basically worked, though there were several issues to get the system back to life afterwards (Xorg not running due to Nvidia vs nouveau driver issues, GNOME desktop immediately crashing on login, since the new GNOME didn't like something which the old GNOME version had stored in the ~/.gnome2 directory etc). But that's all resolved, the system is working now - except hibernation.


    • I have already installed "gnome-shell-extension-alternative-status-menu".
    • I also enabled the extension via https://extensions.gnome.org/local/ (would be cool if it had been enabled by default, when installed).


    The problem:
    • I'm seeing the "hibernate" option in the GNOME menu now, but when I select the option, the desktop is only locked - but then it doesn't hibernate at all. The system keeps running. I can unlock the screen again, retry etc - but it never hibernates.
    • Hibernation works perfectly when I enable it by command-line though: "pm-hibernate" works just fine. So it's not caused by a missing swap partition etc.


    Apparently there's something not working which connects the GNOME GUI option "hibernate" to the actual system call.

    In /var/log/messages I can see the following error messages whenever I trigger the GNOME "hibernate" option - so this could be related:

    dbus-daemon[722]: dbus[722]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=714 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.248" (uid=1000 pid=10701 comm="/usr/bin/gnome-session ")

    dbus[722]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=714 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.248" (uid=1000 pid=10701 comm="/usr/bin/gnome-session ")


    Any ideas on what to check welcome!


    Thanks!
    Hi Thorsten,

    Same problem here after zypper dup from 12.2. In the messages log I found the same lines as you and also:

    2013-08-06T10:03:42.796366+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) closing serial port...
    2013-08-06T10:03:42.799190+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) serial port closed
    2013-08-06T10:03:42.799824+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) opening serial port...
    2013-08-06T10:03:42.802461+02:00 linux dbus-daemon[924]: modem-manager[946]: (ttyUSB0) failed to parse QCDM version info command result: -4
    2013-08-06T10:03:42.807492+02:00 linux dbus-daemon[924]: modem-manager[946]: (ttyUSB0) failed to parse QCDM version info command result: -4
    2013-08-06T10:03:42.810306+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) closing serial port...
    2013-08-06T10:03:42.810549+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) serial port closed
    2013-08-06T10:03:42.810835+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) opening serial port...
    2013-08-06T10:03:42.811069+02:00 linux dbus-daemon[924]: modem-manager[946]: <warn> (ttyUSB0): port attributes not fully set
    2013-08-06T10:03:54.796406+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) closing serial port...
    2013-08-06T10:03:54.798978+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) serial port closed
    2013-08-06T10:03:54.799598+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) opening serial port...
    2013-08-06T10:03:54.802360+02:00 linux dbus-daemon[924]: modem-manager[946]: (ttyUSB0) failed to parse QCDM version info command result: -4
    2013-08-06T10:03:54.807591+02:00 linux dbus-daemon[924]: modem-manager[946]: (ttyUSB0) failed to parse QCDM version info command result: -4
    2013-08-06T10:03:54.810620+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) closing serial port...
    2013-08-06T10:03:54.811127+02:00 linux dbus-daemon[924]: modem-manager[946]: <info> (ttyUSB0) serial port closed

    I uninstalled ModemManager and now hibernation works.

    I'll fix my modem later. Maybe after that I will need ModemManager again, but for now hibernation is fixed.

    --
    kind regards, wouter...

  5. #5
    Join Date
    Jan 2009
    Posts
    16

    Default Re: GNOME, openSUSE 12.3, hibernate not working

    I did some more testing, but results are not as reproducible as I thought. Most of the time hibernation fails. When I try "gdbus call --system --dest org.freedesktop.UPower --object-path /org/freedesktop/UPower --method org.freedesktop.UPower.Hibernate" in a console window or, as root, pm-hibernate, the system returns Resuming...

    The system does not hibernate. It is an HP laptop with an encrypted system volume group that has swap in it as a logical volume. On the odd occasion that hibernation works after a couple of retries the system resumes just fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •