Results 1 to 3 of 3

Thread: selinux setup error

  1. #1

    Question selinux setup error

    i tried to enable selinux on my OpenSUSE 12.3, i did everything like described in SDB:SELinux - openSUSE except that when i run the selinux-ready command i get the following error:
    check_filesystem: ERR. Filesystem 'selinuxfs' is missing. Please enable SELinux while compiling the kernel.

    in the guide the output is :check_filesystem: OK. Filesystem 'selinuxfs' exists.

    so i think everything is alright with the kernel (i'm using the default one shipped with suse), but i need to maybe mount the filesystem to /selinux or proc/filesystems ?
    any help appreciated

  2. #2
    Join Date
    May 2010
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ

    Default Re: selinux setup error

    AppArmor - Gentoo Wiki says that fstab entry might be required
    Also found this pdf explaining the setting up of SElinux
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

  3. #3

    Default Re: selinux setup error

    i tried the fstab entry and it won't help, because selinuxfs is an "unknown file system"
    has anyone tried booting with the selinux kernel parameters or changing CONFIG_SECURITY_SELINUX_BOOTPARAM_VALUE=0 to 1 ???
    that's the only solutions i can think after some reading.
    or maybe there is another way to enable a filesystem type? as /sys/fs/selinux directory is missing in 12.3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts