Results 1 to 5 of 5

Thread: Running application as super user

  1. #1
    Join Date
    Nov 2012
    Location
    india
    Posts
    6

    Default Running application as super user

    I have problem while execute qtwvdialer app from desktop it does not connect n/w, instead if i execute application from terminal with su command it works fine. so how do i execute the qtwvdialer with clicking desktop icon? what are the settings have to manage in icon properties, could anyone tell me...

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Running application as super user

    Quote Originally Posted by nccode View Post
    I have problem while execute qtwvdialer app from desktop it does not connect n/w, instead if i execute application from terminal with su command it works fine. so how do i execute the qtwvdialer with clicking desktop icon? what are the settings have to manage in icon properties, could anyone tell me...
    To run X-windows applications as root, use the graphical su commands, kdesu or gnomesu.

  3. #3
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Running application as super user

    Did you compile it with your normal user or root? You should probably compile it as your normal user and then see if you can double click on it to launch. Otherwise, you can create a desktop file for your program which can be double clicked and put in the KDE kickstart menu. There is a tutorial here.
    Also straight from the website for the application
    To run QtWvDialer as normal user you could chmod +s /usr/loca/bin/wvdial and chmod +xs /usr/sbin/pppd (Your path may differ. A which pppd and which wvdial as root should show you the path used on your system)
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Running application as super user

    On 06/28/2013 04:26 AM, nccode wrote:
    > if i execute application from terminal with su
    > command it works fine.


    try adding yourself to the dialout group: go YaST > Security and
    Users > User and Group Management > on the Users tab, single left
    click to highlight YOUR user name > click the "Edit" button lower
    left > go to "Details" tab > on the right side, in the long list,
    single left click the box next to "dialout" group > click "OK"
    button, lower right > click "OK" button on the "User and Group
    Administration" pane >

    then

    -open a new terminal, and WITHOUT becoming root, execute it as
    yourself and leave the terminal open

    -let it try to connect (if it does you are done, problem solved)

    -if it still won't connect, then once the application has
    finished/closed: copy/paste the terminal output back to this thread

    -using "code tags" as in the instructions here: http://goo.gl/i3wnr


    if the above does not work then try to use YaST > Security and Users
    > User and Group Management to temporarily add a new TestUser, then

    log out and log back in as the TestUser and try the application as
    that new test user: is the problem resolved?

    --
    dd
    http://tinyurl.com/DD-Caveat

  5. #5
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Running application as super user

    Quote Originally Posted by DenverD View Post
    On 06/28/2013 04:26 AM, nccode wrote:
    > if i execute application from terminal with su
    > command it works fine.


    try adding yourself to the dialout group: go YaST > Security and
    Users > User and Group Management > on the Users tab, single left
    click to highlight YOUR user name > click the "Edit" button lower
    left > go to "Details" tab > on the right side, in the long list,
    single left click the box next to "dialout" group > click "OK"
    button, lower right > click "OK" button on the "User and Group
    Administration" pane >

    then

    -open a new terminal, and WITHOUT becoming root, execute it as
    yourself and leave the terminal open

    -let it try to connect (if it does you are done, problem solved)

    -if it still won't connect, then once the application has
    finished/closed: copy/paste the terminal output back to this thread

    -using "code tags" as in the instructions here: Posting in Code Tags - A Guide


    if the above does not work then try to use YaST > Security and Users
    > User and Group Management to temporarily add a new TestUser, then

    log out and log back in as the TestUser and try the application as
    that new test user: is the problem resolved?

    --
    dd
    http://tinyurl.com/DD-Caveat

    It would seem like following the developers instructions for chmod is simpler, no? I mean its nice to have options so who knows..... I would go with the developer on this one first and then fall back on your suggestion.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •