Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KDE printer settings need root password to change paper size

  1. #1
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default KDE printer settings need root password to change paper size

    Is there any way to change paper sizes on my Oki c330dn without root password? Any help will be appreciated.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: KDE printer settings need root password to change paper size

    On 2013-06-26 12:56, anika200 wrote:
    >
    > Is there any way to change paper sizes on my Oki c330dn without root
    > password? Any help will be appreciated.


    Ok. First thing is to know who (what) presents that dialog. KDE? Gnome?
    LibreOffice?

    Alternatively, you can set the page size in the CUPS local web page.
    Point any browser to

    Code:
    http://localhost:631/printers/
    It will require your login/pass, and your user pass should suffice. If
    you click on a printer, you get two drop lists. One is "maintenance",
    and the other "administration". It is the second one that is more
    strict, but I can access "modify printer" as user. In "set default
    options for 'printer name'" I see a tab named "general" where I can set
    the default page size and tray.

    If you can't access any of this as user, the settings are done via
    "/etc/cups/cupsd.conf". There are a lot of settings there to configure
    who can access what.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: KDE printer settings need root password to change paper size

    Quote Originally Posted by robin_listas View Post
    On 2013-06-26 12:56, anika200 wrote:
    >
    > Is there any way to change paper sizes on my Oki c330dn without root
    > password? Any help will be appreciated.


    Ok. First thing is to know who (what) presents that dialog. KDE? Gnome?
    LibreOffice?


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    I am using KDE and searching with the kickstart menu for "printer" gets me to the "Printer - KDE Control Module". When selected the first thing it does is pop up a dialog to enter the root password (the username is already listed as root when the dialog opens). I then have to enter my root password again when I change the paper size and hit apply via the dialog in the screenshot.

    Maybe this behavior can be changed via /etc/cups/cupsd.conf? Maybe I can change some setting in policy kit or add myself to some printing group?


    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: KDE printer settings need root password to change paper size

    On 2013-06-26 14:46, anika200 wrote:
    >
    > robin_listas;2567430 Wrote:



    > I am using KDE and searching with the kickstart menu for "printer" gets
    > me to the "Printer - KDE Control Module". When selected the first thing
    > it does is pop up a dialog to enter the root password (the username is
    > already listed as root when the dialog opens). I then have to enter my
    > root password again when I change the paper size and hit apply via the
    > dialog in the screenshot.


    Mmm.

    Run this and post here inside code tags:

    Code:
    grep PERMISSION_SECURITY /etc/sysconfig/security
    You should have "easy local". If you have "secure", that's your problem.


    > Maybe this behavior can be changed via /etc/cups/cupsd.conf?


    If you use cups native tools, yes. With the kde printer module, I'm not
    sure. Are you sure it asks for root's password, not the user password?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #5

    Default Re: KDE printer settings need root password to change paper size

    My guess is if the op follow the first advice of carlos it will allow the user to modify the paper size.
    People who do not break things first will never learn to create anything

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: KDE printer settings need root password to change paper size

    On 2013-06-26 18:46, conram wrote:
    >
    > My guess is if the op follow the first advice of carlos it will allow
    > the user to modify the paper size.


    Another possibility is choosing paper size in the application that is
    going to print, like libreoffice.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: KDE printer settings need root password to change paper size

    Quote Originally Posted by robin_listas View Post
    On 2013-06-26 18:46, conram wrote:
    >
    > My guess is if the op follow the first advice of carlos it will allow
    > the user to modify the paper size.


    Another possibility is choosing paper size in the application that is
    going to print, like libreoffice.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    Yes, these things all work. Thanks for the help.
    Using CUPS web interface I do not seem to even need a password after I modify the last section of /etc/cupsd.conf by adding "Allow all", still testing this though and it probably would not survive an upgrade.

    As far as the security I have this
    Code:
    lee@linux-aa3c:~> grep PERMISSION_SECURITY /etc/sysconfig/securityPERMISSION_SECURITY="easy local"
    # PERMISSION_SECURITY. If PERMISSION_SECURITY contains 'secure' or
    lee@linux-aa3c:~>

    Still puzzles me why the KDE printer control module would need the root password twice. Yes it asks for root password not just the user, at least the word "root" is already filled into the username box when the dialog is opened.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KDE printer settings need root password to change paper size

    On 06/26/2013 08:16 PM, anika200 wrote:
    > Still puzzles me why the KDE printer control module would need the root
    > password twice. Yes it asks for root password not just the user, at
    > least the word "root" is already filled into the username box when the
    > dialog is opened.


    while apparently the easy way to do the job is NOT to get KDE
    involved, at all..

    but if one does use the KDE tool i guess it asks for the password
    since the config file is owned by root, and lives in a system folder
    which is owned by root, so KDE 'knows' that to make a change root
    _must_ be involved--that is what KDE tools typically do..

    but, why you got asked twice i have no idea....and, my guess is the
    asked twice part is worthy of a bugzilla..

    please file it and return to here with a URL so we can follow it....tia!

    --
    dd


  9. #9
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: KDE printer settings need root password to change paper size

    No one else ever indicated if they have the same results of twice for the password?
    Anyway, I filed a bug report here https://bugs.kde.org/show_bug.cgi?id=321650
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: KDE printer settings need root password to change paper size

    On 2013-06-26 21:46, anika200 wrote:
    >
    > No one else ever indicated if they have the same results of twice for
    > the password?
    > Anyway, I filed a bug report here
    > https://bugs.kde.org/show_bug.cgi?id=321650


    Don't, you have a misconfiguration.

    Please edit "/etc/sysconfig/security" and make sure you have a line
    containing:

    Code:
    PERMISSION_SECURITY="easy local"
    It is not clear from your CODE section if you have it or not.


    And anyway, bugs have to be reported against openSUSE first; only report
    upstream if you see the bug across distros or you use the latest version
    from upstream.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •