Results 1 to 4 of 4

Thread: Unable to Mount NTFS partition

  1. #1
    Join Date
    Jun 2013
    Location
    Mumbai, India
    Posts
    2

    Post Unable to Mount NTFS partition

    HI,
    I'm currently using SUSE SLES 11SP2 x86_64 Patch 2. I'm having issues in mounting my NTFS drives.I can't seem to mount my NTFS drives on my SUSE, I can see them under /windows/ directory listed as C D E F G.. & O respectively (so my assumptions are they are mounted) BUT when I explore those drives I can't view its contents.. it's appears completely blank,I tried searching the internet but didn't get any solution to this.. is it a SUSE sles 11 sp2 limitation or am I not doing it correctly?
    I don't know how to fix this so I can browse the files on my NTFS drives. here's what I have tried doing so far...

    1)
    I did edit the /etc/fstab file after I read some article over here: SDB:NTFS - openSUSE
    here's my fstab file

    Code:
                     
    
    1. /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part8 swap swap defaults 0 0 /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part2 / ext3 acl,user_xattr 1 1 /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part1 /windows/C ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part1 /windows/D ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part1 /windows/E ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part5 /windows/F ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part6 /windows/G ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-WDC_WD5000AAKX-75U6AA0_WD-WCC2ED719484-part7 /windows/H ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part5 /windows/I ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part6 /windows/J ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part7 /windows/K ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3VD9L-part8 /windows/L ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part5 /windows/M ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-ST3360320AS_6QF3XFER-part6 /windows/N ntfs-3g defaults,locale=en_US.UTF-8 0 0 /dev/disk/by-id/ata-HDS728080PLA380_PFDB32S6SSU5HN-part5 /windows/O ntfs-3g defaults,locale=en_US.UTF-8 0 0 proc /proc proc defaults 0 0 sysfs /sys sysfs noauto 0 0 debugfs /sys/kernel/debug debugfs noauto 0 0 usbfs /proc/bus/usb usbfs noauto 0 0 devpts /dev/pts devpts mode=0620,gid=5 0 0
    2)
    I tried sharing the drives in windows 8 via the disk properties tab settings
    3)
    I tried to mnt it via running the following cmds:

    Code:
    fdisk -l
    Gave output:

    Code:
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00039d5c
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1            2048   209717247   104857600    7  HPFS/NTFS/exFAT
    /dev/sda2   *   209717248   419432447   104857600   83  Linux
    /dev/sda3       419432448   976773119   278670336    5  Extended
    /dev/sda5       419434496   629149695   104857600    7  HPFS/NTFS/exFAT
    /dev/sda6       629151744   838866943   104857600    7  HPFS/NTFS/exFAT
    /dev/sda7       838868992   964698111    62914560    7  HPFS/NTFS/exFAT
    /dev/sda8       964700160   976773119     6036480   82  Linux swap / Solaris
    
    Disk /dev/sdd: 82.3 GB, 82348277760 bytes
    255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00006a32
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1   *        2048    62926604    31462278+   7  HPFS/NTFS/exFAT
    /dev/sdd2        62926785   160826714    48949965    f  W95 Ext'd (LBA)
    /dev/sdd5        62926848   160826714    48949933+   7  HPFS/NTFS/exFAT
    
    Disk /dev/sdb: 360.1 GB, 360080695296 bytes
    255 heads, 63 sectors/track, 43777 cylinders, total 703282608 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0000607f
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1           16065   703277504   351630720    f  W95 Ext'd (LBA)
    /dev/sdb5           16128   175831424    87907648+   7  HPFS/NTFS/exFAT
    /dev/sdb6       175831488   351646784    87907648+   7  HPFS/NTFS/exFAT
    /dev/sdb7       351646848   527462144    87907648+   7  HPFS/NTFS/exFAT
    /dev/sdb8       527462208   703277504    87907648+   7  HPFS/NTFS/exFAT
    
    Disk /dev/sdc: 360.1 GB, 360080695296 bytes
    255 heads, 63 sectors/track, 43777 cylinders, total 703282608 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x6ece6079
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1   *          63   175815359    87907648+   7  HPFS/NTFS/exFAT
    /dev/sdc2       175815360   703261439   263723040    f  W95 Ext'd (LBA)
    /dev/sdc5       175815423   351630719    87907648+   7  HPFS/NTFS/exFAT
    /dev/sdc6       351630783   527446079    87907648+   7  HPFS/NTFS/exFAT
    /dev/sdc7       527446143   703261439    87907648+   7  HPFS/NTFS/exFAT
    After getting the listed drives info I

    Code:
    mount -t ntfs-3g -o noatime /dev/sda8 /mnt/ntfs/
    got error as;

    Code:
    mount: unknown filesystem type 'ntfs-3g'
    then I did:

    Code:
    mount -t fuse -o noatime /dev/sdd5 /mnt/ntfs/
    Got error as:

    Code:
    /bin/sh: /dev/sdd5: Permission denied
    So I did CHOWN as

    Code:
    chown simon /windows
    but still I was not able to mount the NTFS drives.. or view its contents..


    additional info:
    I have installed SUSE on 2nd primary partition & is set to active, (1st primary partition is windows 8 enterprise)
    Ran cmds as SU

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to Mount NTFS partition

    On 2013-06-25 11:36, simbha wrote:
    >
    > HI,
    > I'm currently using SUSE SLES 11SP2 x86_64 Patch 2.


    But these are the openSUSE forums, not the SLES/SLED forums. Please post
    here instead: SLES/SLED forums
    (same login/pass).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    Join Date
    Jun 2013
    Location
    Mumbai, India
    Posts
    2

    Thumbs up Re: Unable to Mount NTFS partition

    Quote Originally Posted by robin_listas View Post
    On 2013-06-25 11:36, simbha wrote:
    >
    > HI,
    > I'm currently using SUSE SLES 11SP2 x86_64 Patch 2.


    But these are the openSUSE forums, not the SLES/SLED forums. Please post
    here instead: SLES/SLED forums
    (same login/pass).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    ooppps!!! I didn't notice it.. was so much into getting a solution for it but anyway thanks a lot.. I did post a thread on that forum.. hope to get a solution or else I might have to jump back to openSUSE 12.3 too..

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Unable to Mount NTFS partition

    Aaprt from the fact mentioned above that this is the openSUSE forums, fstab and mounting is pretty universal. In any case when I read:
    Code:
    /dev/sda8       964700160   976773119     6036480   82  Linux swap / Solaris
    and
    Code:
    mount -t ntfs-3g -o noatime /dev/sda8 /mnt/ntfs/
    I am a bit amazed that you try to mount a partition that is to be used for Swap as a partition that contains an NTFS file system.

    I did not read the rest of the post, but this drew my attention.
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •