Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

Hybrid View

  1. #1
    Join Date
    Jun 2013
    Location
    Athens - Greece
    Posts
    24

    Default Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Hello everybody.
    Recently I've installed 12.3 edition in my desktop. Newbie to openSUSE world.
    I've updated to gnome version 3.8 through an easy procedure via zypper. (add repo - refresh - dup) . From this time I cannot change the keyboard layout with any combination except the Super + Space. Any other combination (Alt+Shift , Alt+Ctrl ... etc) will fail.
    I've asked a friend who has Gnome 3.8 in Ubuntu (via PPA) just because I want to be sure this is not a Gnome's problem, and I was right. There, the keyboard layout switch works as it should.

    What I have tried so far listed below.

    1. Change keyboard layout through "Keyboard Shortcuts -> Typing"
    2. Change layout through "Gnome Tweak Tool -> Typing -> Modifiers only-input source switcher"
    3. Add 2 lines inside /etc/X11/xorg.conf.d/90-keytable.conf (XkbOptions and XkbLayout) to match my preferred layout switch.
    4. Add in /etc/xdg/autostart a new .desktop entry . (Exec=setxkbmap -option grp:alt_shift_toggle "us,gr")


    Any idea would be welcome

    Regards
    NikTh

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Have you tried with YaST
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3
    Join Date
    Jun 2013
    Location
    Athens - Greece
    Posts
    24

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Quote Originally Posted by vazhavandan View Post
    Have you tried with YaST
    Probably I'm missing something here, because I cannot see an option to set my keyboard keys combination to change the layout. (also expert settings have not this option)






  4. #4
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Quote Originally Posted by NikTh View Post
    Hello everybody.
    Recently I've installed 12.3 edition in my desktop. Newbie to openSUSE world.
    I've updated to gnome version 3.8 through an easy procedure via zypper. (add repo - refresh - dup) . From this time I cannot change the keyboard layout with any combination except the Super + Space. Any other combination (Alt+Shift , Alt+Ctrl ... etc) will fail.
    I've asked a friend who has Gnome 3.8 in Ubuntu (via PPA) just because I want to be sure this is not a Gnome's problem, and I was right. There, the keyboard layout switch works as it should.

    What I have tried so far listed below.

    1. Change keyboard layout through "Keyboard Shortcuts -> Typing"
    2. Change layout through "Gnome Tweak Tool -> Typing -> Modifiers only-input source switcher"
    3. Add 2 lines inside /etc/X11/xorg.conf.d/90-keytable.conf (XkbOptions and XkbLayout) to match my preferred layout switch.
    4. Add in /etc/xdg/autostart a new .desktop entry . (Exec=setxkbmap -option grp:alt_shift_toggle "us,gr")


    Any idea would be welcome

    Regards
    NikTh
    I am having the same issue here ... just upgraded from OS 12.2 > 12.3 and the system is uptodate with the repositories ... I am currently customizing settings. One setting that i rely on heavily is the 'Compose Key' shortcut that allows me to add foreign accents to letters.

    However ... the options is DISABLED in this version of OS [see screenshot] ... have tried to find the answer locally but am totally out of ideas! .. This post is the ONLY one that i can find on the net regarding this issue ...

    Has anybody got any ideas how i might ENABLE the Typing Shortcuts???


  5. #5
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    If somebody could confirm whether this is a distro wide issue with OS12.3-64 ... or is it just my installation.

    Thanks.

  6. #6
    Join Date
    Jun 2013
    Location
    Athens - Greece
    Posts
    24

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Quote Originally Posted by griadooss View Post
    If somebody could confirm whether this is a distro wide issue with OS12.3-64 ... or is it just my installation.

    Thanks.
    I think yes. I said that on my first post.

    Quote Originally Posted by NikTh View Post
    I've asked a friend who has Gnome 3.8 in Ubuntu (via PPA) just because I want to be sure this is not a Gnome's problem, and I was right. There, the keyboard layout switch works as it should.
    Quote Originally Posted by vazhavandan View Post
    Click on those "disabled" labels and it will allow you set key combinations
    Unfortunately this not apply in my installation. When I click "disabled" to set a custom combo it just ignores it.

  7. #7

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Quote Originally Posted by NikTh View Post
    Unfortunately this not apply in my installation. When I click "disabled" to set a custom combo it just ignores it.
    Have the same problem in 12.3 after update. It ignores any buttons i press. Maybe i could edit some config-file manually to teach Suse change layout?

  8. #8

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    My keyboard is supposed to be US. So I set on YaST "Portuguese (Brasil -- US accents)" and it works correctly on the test field and on yast. But any other location it will not work. So I think there is a conflict on my keyboard layout. Changing it under "system settings" -> "keyboard" -> "layout settings" does no effect. (And there are no "Portuguese (Brasil -- US accents)" option there). Any hints on where should I look next? /etc/sysconfig says:

    Code:
    ## Path:        Hardware/Keyboard
    ## Description: Keyboard settings
    ## Type:        string
    ## Default:     ""
    ## ServiceRestart: kbd
    #
    # Keyboard settings for the text console
    #
    # Keyboard mapping
    # (/usr/share/kbd/keymaps/)
    # e.g. KEYTABLE="de-latin1-nodeadkeys", "us" or empty for US settings
    #
    KEYTABLE="us-acentos.map.gz"
    
    ## Type:        integer
    ## Default:
    #
    # Keyboard delay time in ms (250, 500, 750, 1000)
    KBD_DELAY=""
    
    ## Type:    string(2.0,2.1,2.3,2.5,2.7,3.0,3.3,3.7,4.0,4.3,4.6,5.0,5.5,6.0,6.7,7.5,8.0,8.6,9.2,10.0,10.9,12.0,13.3,15.0,16.0,17.1,18.5,20.0,21.8,24.0,26.7,30.0)
    ## Default:
    #
    # Keyboard repeat rate (2.0 - 30.0)
    KBD_RATE=""
    
    ## Type:        list(bios,yes,no)
    ## Default:     bios
    #
    # NumLock on? ("yes" or "no" or empty or "bios" for BIOS setting)
    KBD_NUMLOCK="bios"
    
    ## Type:        yesno
    ## Default:     no
    #
    # ScrollLock on? ("yes" or "no")
    KBD_SCRLOCK="no"
    
    ## Type:        yesno
    ## Default:     no
    #
    # CapsLock on? ("yes" or "no")
    KBD_CAPSLOCK="no"
    
    ## Type:        yesno
    ## Default:     no
    #
    # Disable CAPS LOCK and make it a normal Shift key?
    # (Ctrl Caps Lock will still toggle Caps Lock functionality)
    # Note that you need to tweak the xkb maps or use xmodmap
    # if you want to do the same under X-Windows. In ~/.Xmodmap:
    # keycode 0x42 = Shift_L Shift_L
    #
    KBD_DISABLE_CAPS_LOCK="no"
    
    ## Type:        string
    ## Default:
    #
    # ttys for the above settings 
    # Example: "tty1 tty2"
    # "" for tty's 1-6
    #
    KBD_TTY=""
    
    # 
    # Compose tables to be loaded.
    # Compose tables are good for producing characters, which can not
    #  be directly input from your keyboard, such as characters with
    #  accents, currency signs, ...
    # Please read /usr/share/doc/packages/kbd/README.SuSE for an
    #  explanation.
    # You may leave this variable empty (default compose table from kernel 
    #  or KEYTABLE will be used then -- most keyboard maps don't have a
    #  compose table, though)
    # More than one compose table can be given. For a selection of possible
    #  tables see /usr/share/kbd/keymaps/include/compose.*
    # You can give more than one compose table, but only the last one will
    #  determine the compose combinations.
    #  The word "clear" has a special meaning:
    #  Your compose table will be cleared, before more compose symbols are
    #  added.
    # The files compose.winkeys and shiftctrl may be used to map the 
    #  <compose> key to the W*n menu key and Shift-Ctrl, respectively,
    #  on a PC keyboard.
    # A typical setting for Latin1 users (with a PC keyboard) may be
    #  COMPOSETABLE="clear winkeys shiftctrl latin1.add"
    # For latin2, this would be
    #  COMPOSETABLE="clear winkeys shiftctrl latin2"
    # A typical setting for sb. with a character set, where a matching 
    #  compose table is missing (but with a PC keyboard), would be
    #  COMPOSETABLE="winkeys shiftctrl"
    # 
    COMPOSETABLE="clear latin1.add"
    
    # The YaST-internal identifier of the attached keyboard.
    #
    YAST_KEYBOARD="portugese-br-usa,pc104"

  9. #9
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Quote Originally Posted by griadooss View Post
    I am having the same issue here ... just upgraded from OS 12.2 > 12.3 and the system is uptodate with the repositories ... I am currently customizing settings. One setting that i rely on heavily is the 'Compose Key' shortcut that allows me to add foreign accents to letters.

    However ... the options is DISABLED in this version of OS [see screenshot] ... have tried to find the answer locally but am totally out of ideas! .. This post is the ONLY one that i can find on the net regarding this issue ...

    Has anybody got any ideas how i might ENABLE the Typing Shortcuts???

    Click on those "disabled" labels and it will allow you set key combinations
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  10. #10
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Re: Cannot change keyboard layout - Gnome 3.8 - OpenSUSE 12.3

    Quote Originally Posted by vazhavandan View Post
    Click on those "disabled" labels and it will allow you set key combinations
    OMG!!! .... ... perhaps a more intuitive label might be [Not set] ... or [Select ...]', because the function is NOT disabled, is it!?!

    Thnx Vaz.......

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •