Results 1 to 4 of 4

Thread: NX strange side effect after latest 12.2 update.

  1. #1
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Default NX strange side effect after latest 12.2 update.

    After the latest 12.2 update and indeed on 12.3 . The nxserver runs fine, but when access a remote login using the nx client libre office and yast2 both display blank pages(white) but all of the controls and text areas are there only not visible. Using KDE as delivered, Everything worked on 12.2 up until the latest updates, always had a problem with 12.3.

    Does any body know what changes might cause this problem. Where should I look for clues to a solution?

    As this is how we all access our desktops, we are all pretty much shut down in the office.

    Thanks
    Brian

  2. #2
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Default Re: NX strange side effect after latest 12.2 update.

    Update, when I attached to the system with ssh -X user@mysystem

    and start yast2 I get same result white screen but all inputs are active, libreoffice is same all text is invisible unless highlighted then is is displayed, it appears to be an X issue, Does anyone know what might have changed? I have tried this on 3 separate 12.2 systems with the latest updates, and a 12.3 all are the same, yet locally or via LTSP everything works fine!

    Oh tried abiword, believe it or not, the screen was same all text not visible but in this case selecting did not make it visible.

  3. #3

    Default AW: Re: NX strange side effect after latest 12.2 update.

    Quote Originally Posted by ercoupeflyer View Post
    Update, when I attached to the system with ssh -X user@mysystem

    and start yast2 I get same result white screen but all inputs are active, libreoffice is same all text is invisible unless highlighted then is is displayed, it appears to be an X issue, Does anyone know what might have changed? I have tried this on 3 separate 12.2 systems with the latest updates, and a 12.3 all are the same, yet locally or via LTSP everything works fine!

    Oh tried abiword, believe it or not, the screen was same all text not visible but in this case selecting did not make it visible.
    Your problem with Qt applications could be this bug:
    https://bugzilla.novell.com/show_bug.cgi?id=807781

    A workaround would be to set the environment variable "QT_X11_NO_MITSHM" to 1 (maybe in your ~/.profile).

    No idea about abiword though (this is a GTK application).

  4. #4
    Join Date
    Jul 2008
    Location
    California
    Posts
    123

    Default Re: NX strange side effect after latest 12.2 update.

    OK.

    More updates, after updating the 12.2 client I was testing from with the latest updates today, also doing this for all servers as well, 12.2. and 12.3, there seemed to be a lot of X11 based updates. The NXclient for opensuse seemed to work fine. The problem is now isolated to windows nx clients accessing the opensuse servers.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •