Results 1 to 4 of 4

Thread: Trying to install Kibana, ruby gems install error

  1. #1
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Trying to install Kibana, ruby gems install error

    Hoping someone can offer a suggestion,
    Although the application (a Ruby Gems app) is being installed from source, the error references development/libary packages (I think I have required installed) and the Dev package version doesn't match the installed files (but maybe someone can definitively say this is normal).

    Installing a Logstash/Elastisearch/Kibana solution,
    Using logstash as installed from some private obs repos(PerryWerneck repo) (which installed without error. Have yet to test functionality though).
    Have installed elasticsearch using the rpm from the elasticsearch.org website.

    Am now attempting to install Kibana following the instructions from this page
    Kibana. Make sense of a mountain of logs.
    1. downloaded my copy of the github repo
    2. Verified KibanaConfig.rb is already set correctly to point to localhost
    3. Installed the ruby gem "bundler"
    4. Ran "bundle install"
    Results in the following output
    Code:
    Fetching gem metadata from http://rubygems.org/.........
    Fetching gem metadata from http://rubygems.org/..
    Resolving dependencies...
    Using rake (10.0.3) 
    Using daemons (1.1.9) 
    Using diff-lcs (1.1.3) 
    Installing eventmachine (1.0.3) 
    Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
    
            /usr/bin/ruby1.9 extconf.rb 
    checking for main() in -lssl... *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers.  Check the mkmf.log file for more
    details.  You may need configuration options.
    
    Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/bin/ruby1.9
        --with-openssl-config
        --without-openssl-config
        --with-pkg-config
        --without-pkg-config
        --with-ssl-dir
        --without-ssl-dir
        --with-ssl-include
        --without-ssl-include=${ssl-dir}/include
        --with-ssl-lib
        --without-ssl-lib=${ssl-dir}/
        --with-ssllib
        --without-ssllib
    /usr/lib64/ruby/1.9.1/mkmf.rb:381:in `try_do': The compiler failed to generate an executable file. (RuntimeError)
    You have to install development tools first.
        from /usr/lib64/ruby/1.9.1/mkmf.rb:461:in `try_link0'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:476:in `try_link'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:619:in `try_func'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:845:in `block in have_library'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:790:in `block in checking_for'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:284:in `block (2 levels) in postpone'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:254:in `open'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:284:in `block in postpone'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:254:in `open'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:280:in `postpone'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:789:in `checking_for'
        from /usr/lib64/ruby/1.9.1/mkmf.rb:840:in `have_library'
        from extconf.rb:5:in `block in check_libs'
        from extconf.rb:5:in `each'
        from extconf.rb:5:in `all?'
        from extconf.rb:5:in `check_libs'
        from extconf.rb:39:in `manual_ssl_config'
        from extconf.rb:61:in `<main>'
    
    
    Gem files will remain installed in /usr/lib64/ruby/gems/1.9.1/gems/eventmachine-1.0.3 for inspection.
    Results logged to /usr/lib64/ruby/gems/1.9.1/gems/eventmachine-1.0.3/ext/gem_make.out
    An error occurred while installing eventmachine (1.0.3), and Bundler cannot
    continue.
    Make sure that `gem install eventmachine -v '1.0.3'` succeeds before bundling.
    As you can see, there is some kind of "ruby libraries and headers"
    Verified all ruby-dev is installed, these are the ruby and ruby versions installed (removed some unnecessary stuff)

    Code:
    Loading repository data...
    Reading installed packages...
    
    
    Information for package ruby:
    
    Repository: openSUSE-12.3-Update
    Name: ruby
    Version: 1.9.3-15.2.1
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 1.9 KiB
    
    Information for package ruby-devel:
    
    Repository: openSUSE-12.3-Update
    Name: ruby-devel
    Version: 1.9.3-15.2.1
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 0 B
    Note that although my ruby and ruby-devel packages are version 1.9.3.15.2.1,
    The libraries are in a tree marked /usr/lib64/ruby/1.9.1
    Don't know if that's normal and expected or a problem.

    In any case, I don't know what other sources of ruby libraries I should be checking if the versioning isn't really an issue.

    TIA,
    TSU

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,133

    Default Re: Trying to install Kibana, ruby gems install error

    After using the search function of my browser, I found out that this is most probably about openSUSE 12.3 But it would be more helpful when you tell that first and formemost when starting a thread
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Trying to install Kibana, ruby gems install error

    Quote Originally Posted by hcvv View Post
    After using the search function of my browser, I found out that this is most probably about openSUSE 12.3 But it would be more helpful when you tell that first and formemost when starting a thread
    Yeah, sorry.
    Gotta remember about describing the standard details.

    And, yes...
    Creatively you can search my post and find that I'm referencing 12.3 repos.

    TSU

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Trying to install Kibana, ruby gems install error

    Have resolved.

    I'll be writing up a specific Guide for installing this important solution (Logstash, Elasticsearch and Kibana) on openSUSE separately, but the more general Ruby issues I raised have been answered...

    - All Ruby version 1.9.1 and later(current stable is 1.9.3) now install into /usr/lib64/ruby/1.9.1 due to some kind of version "compatibility" so won't likely change unless some kind of major change happens

    - Since building Ruby Gems apps don't fail with any detailed error, resolving may require research for the specific error, but in general make sure the standard dev tools are installed in addition to the Ruby packages. The following zypper command likely installs ruby, ruby gems and basic required libraries to build ruby apps
    Code:
    zypper in ruby patterns-openSUSE-devel_ruby devel_ruby ruby-gem-bundler gcc gcc-++ make
    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •