Results 1 to 8 of 8

Thread: trouble with /dev/nvidiactl permission

  1. #1

    Default trouble with /dev/nvidiactl permission

    hello

    from some CAD and FEA sofwares i get the following msg


    NVIDIA: could not open the device file /dev/nvidiactl (Permission denied)


    and the software as a strange behavior after that, many crashes!
    if i do that all works ok


    # chmod 666 /dev/nvidia* &
    this puts the permissions to
    nvidia* root.video crw-rw-rw-


    however on reboot the permissions are revetred to
    nvidia* root.video crw-rw----


    how to make this change permanent


    thanks


    i do know if this best posted in Forum: Applications


    jean pierre aubry

  2. #2

    Default Re: trouble with /dev/nvidiactl permission

    Quote Originally Posted by dedalus2 View Post
    hello

    from some CAD and FEA sofwares i get the following msg


    NVIDIA: could not open the device file /dev/nvidiactl (Permission denied)


    and the software as a strange behavior after that, many crashes!
    if i do that all works ok


    # chmod 666 /dev/nvidia* &
    this puts the permissions to
    nvidia* root.video crw-rw-rw-


    however on reboot the permissions are revetred to
    nvidia* root.video crw-rw----


    how to make this change permanent


    thanks


    i do know if this best posted in Forum: Applications


    jean pierre aubry
    Simply add your user to the "video" group.
    See: https://www.suse.com/releasenotes/i3...#idm1265054156

    But that should already be fixed with the latest systemd update.
    What version of systemd do you have installed?
    Code:
    rpm -qi systemd

  3. #3

    Default Re: trouble with /dev/nvidiactl permission

    hello wolfi323

    thanks for this flash ansver

    here is my version

    Code:
     dedalus@dedalus:~> rpm -qi systemdName        : systemd
    Version     : 195
    Release     : 13.11.1
    Architecture: x86_64
    Install Date: mer. 06 mars 2013 12:27:07 CET
    Group       : System/Base
    Size        : 4689689
    License     : LGPL-2.1+
    Signature   : RSA/SHA256, ven. 22 févr. 2013 18:37:00 CET, Key ID b88b2fd43dbdc284
    Source RPM  : systemd-195-13.11.1.src.rpm
    Build Date  : ven. 22 févr. 2013 18:34:40 CET
    Build Host  : build13
    Relocations : (not relocatable)
    Packager    : http://bugs.opensuse.org
    Vendor      : openSUSE
    URL         : http://www.freedesktop.org/wiki/Software/systemd
    Summary     : A System and Session Manager
    one of the application, Gmsh, seems to work
    another one, Salome, keeps crashing, maybe for another reason!

  4. #4

    Default Re: trouble with /dev/nvidiactl permission

    Quote Originally Posted by dedalus2 View Post
    hello wolfi323

    thanks for this flash ansver

    here is my version

    Code:
     dedalus@dedalus:~> rpm -qi systemdName        : systemd
    Version     : 195
    Release     : 13.11.1
    Architecture: x86_64
    Install Date: mer. 06 mars 2013 12:27:07 CET
    Group       : System/Base
    Size        : 4689689
    License     : LGPL-2.1+
    Signature   : RSA/SHA256, ven. 22 févr. 2013 18:37:00 CET, Key ID b88b2fd43dbdc284
    Source RPM  : systemd-195-13.11.1.src.rpm
    Build Date  : ven. 22 févr. 2013 18:34:40 CET
    Build Host  : build13
    Relocations : (not relocatable)
    Packager    : http://bugs.opensuse.org
    Vendor      : openSUSE
    URL         : http://www.freedesktop.org/wiki/Software/systemd
    Summary     : A System and Session Manager
    That's the older version.
    Please bring your system up to date by running YaST->Online Update, Apper or "sudo zypper up".

  5. #5

    Default Re: trouble with /dev/nvidiactl permission

    i have done and it seems to work ok

    i am very reluctant to let the update be done automatically
    sometimes libraries get replaced by newer ones and my technical software do not work anymore
    and these software are big ones, the largest is 5.5 Gb on disk


    and some have very strange requirement, a CAD program requires "libaudio2"??


    in a recent past many updates would kill "kfind" for some unknown reasons

  6. #6

    Default Re: trouble with /dev/nvidiactl permission

    Quote Originally Posted by dedalus2 View Post
    i am very reluctant to let the update be done automatically
    sometimes libraries get replaced by newer ones and my technical software do not work anymore
    and these software are big ones, the largest is 5.5 Gb on disk
    That would indicate problems with your repo setup. Libraries don't get upgraded in the standard repos including the update repo (only security/bug fixes are applied). That should only happen if you install them manually from a different repo since libzypp also doesn't change the vendor by default.

    So check your repo list and remove unwanted/unneeded repos.
    And if you run YaST->Online Update or "zypper patch" ONLY updates from the standard update repo are considered, which should be safe in any case.
    You can configure the update applet to do this as well, just add the following line to /etc/PackageKit/ZYpp.conf:
    Code:
    HidePackages=true
    and some have very strange requirement, a CAD program requires "libaudio2"??
    On my system only gstreamer-0_10 (gstreamer-0_10-plugins-bad-orig-addon to be precise) needs libaudio2.
    So this could be an indirect dependency. What output do you get when you run:
    Code:
    rpm -e --test libaudio2
    If you find the dependency strange, than you should consider reporting a bug to the provider of the package, it might be a packaging error.

    in a recent past many updates would kill "kfind" for some unknown reasons
    Never had problems with that. And I install many more updates than just the standard ones.

  7. #7

    Default Re: trouble with /dev/nvidiactl permission

    thanks for you very clear explanation about the way updates are done, i will take that into account!

    maybe i had some troubles when trying to compile one appli from source and the required libraries


    regarding libaudio2 it is mandatory for "dassault-systemes-draftsight" i suppose to be able to play some audio animated tutos
    if so i wonder why it is mandatory?


    i cannot find out why i had kfind deleted at several instances, but this not important


    the more i go the more i try to use software as close as possible to pure X dependancies,
    "worker" for example as a file manager pleases me very much

  8. #8

    Default Re: trouble with /dev/nvidiactl permission

    Quote Originally Posted by dedalus2 View Post
    regarding libaudio2 it is mandatory for "dassault-systemes-draftsight" i suppose to be able to play some audio animated tutos
    if so i wonder why it is mandatory?
    Well, you would have to ask them.
    Maybe it's built in a way that it won't run without libaudio2 installed...

    Btw. libaudio2 is a client library for NAS, the Network Audio System.
    I doubt that you use that anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •