Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Suddenly I can't run anything

  1. #1

    Default Suddenly I can't run anything

    Hello,
    I'm starting to experience a very weird issue, it happened twice now !
    For some reason, all of a sudden absolutely nothing can be launched in KDE, either by mouse click or keyboard. I click on icons and nothing happens, no jumping icon as it loads, no hdd led activity, no nothing. I also cannot open the terminatl from kick menu, in fact I can't launch anything from the kick menu. The only way to retrieve functionality is to log out and then back in or a restart. I did not noticed a particular reason or scenario when this happens, it is just random and.
    Oh, and the thing that work by clicking on it is the Log Out\Restart buttons from kick menu.

    Anyone has any ideea what causes this and how can I track it down ?
    OpenSUSE Leap 42.2 x64 KDE

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,054

    Default Re: Suddenly I can't run anything

    On Tue, 18 Jun 2013 22:56:02 +0000, robertot5 wrote:

    > I did not noticed a particular reason or scenario when this happens, it
    > is just random and.


    I would be inclined to launch a terminal when you can and wait for it to
    happen, then start checking logs and try launching stuff from the
    terminal to see what error messages come up.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,054

    Default Re: Suddenly I can't run anything

    On Wed, 19 Jun 2013 00:26:31 +0000, Jim Henderson wrote:

    > On Tue, 18 Jun 2013 22:56:02 +0000, robertot5 wrote:
    >
    >> I did not noticed a particular reason or scenario when this happens, it
    >> is just random and.

    >
    > I would be inclined to launch a terminal when you can and wait for it to
    > happen, then start checking logs and try launching stuff from the
    > terminal to see what error messages come up.


    You also might let us know what version of openSUSE you're suing, what
    desktop enviornment (sounds like you're using KDE, but confirmation would
    be good, along with the version), and what additional software, if any,
    you've installed.

    It sounds something like a resource issue.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Suddenly I can't run anything

    Quote Originally Posted by robertot5 View Post
    Hello,
    I'm starting to experience a very weird issue, it happened twice now !
    For some reason, all of a sudden absolutely nothing can be launched in KDE, either by mouse click or keyboard. I click on icons and nothing happens, no jumping icon as it loads, no hdd led activity, no nothing. I also cannot open the terminatl from kick menu, in fact I can't launch anything from the kick menu. The only way to retrieve functionality is to log out and then back in or a restart. I did not noticed a particular reason or scenario when this happens, it is just random and.
    Oh, and the thing that work by clicking on it is the Log Out\Restart buttons from kick menu.

    Anyone has any ideea what causes this and how can I track it down ?
    So if this was me, I would reboot, then open up terminal and run zypper for a full upgrade of all packages. Open up terminal and do this:

    Code:
    sudo zypper refresh
    sudo zypper up
    Reboot your PC AND, if this does not help, show us your repos:

    Code:
    zypper repos
    I have a nice bash script for working with zypper you can find here:

    Zypper Command - Zypper Package Management Menu System

    I have seen such as issue with KDE after doing an update for KDE and not yet doing a reboot after the update, but you do want to be fully updated.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: Suddenly I can't run anything

    Hi,
    I have OpenSUSE 12.2, KDE, x64 as shown in my signature.

    I will do the update and upgrade right away and try keeping a terminal window opened at all times so when this happens again, if it happens, to see if I can run anything from terminal.

    P.S:
    These are my repos
    Code:
    #  | Alias                     | Name                               | Enabled | Refresh
    ---+---------------------------+------------------------------------+---------+--------
     1 | KDE:Extra                 | KDE:Extra                          | Yes     | Yes    
     2 | PK_TMP_DIR                | PK_TMP_DIR                         | Yes     | Yes    
     3 | VirtualBox_Oracle         | VirtualBox Oracle                  | Yes     | Yes    
     4 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes     | Yes    
     5 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | Yes     | No     
     6 | packman.inode.at-suse     | Packman Repository                 | Yes     | Yes    
     7 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes    
     8 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes    
     9 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes    
    10 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes    
    11 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes    
    12 | repo-source               | openSUSE-12.2-Source               | No      | Yes    
    13 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes    
    14 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes
    OpenSUSE Leap 42.2 x64 KDE

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Suddenly I can't run anything

    Quote Originally Posted by robertot5 View Post
    Hi,
    I have OpenSUSE 12.2, KDE, x64 as shown in my signature.

    I will do the update and upgrade right away and try keeping a terminal window opened at all times so when this happens again, if it happens, to see if I can run anything from terminal.

    P.S:
    These are my repos
    Code:
    #  | Alias                     | Name                               | Enabled | Refresh
    ---+---------------------------+------------------------------------+---------+--------
     1 | KDE:Extra                 | KDE:Extra                          | Yes     | Yes    
     2 | PK_TMP_DIR                | PK_TMP_DIR                         | Yes     | Yes    
     3 | VirtualBox_Oracle         | VirtualBox Oracle                  | Yes     | Yes    
     4 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes     | Yes    
     5 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | Yes     | No     
     6 | packman.inode.at-suse     | Packman Repository                 | Yes     | Yes    
     7 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes    
     8 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes    
     9 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes    
    10 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes    
    11 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes    
    12 | repo-source               | openSUSE-12.2-Source               | No      | Yes    
    13 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes    
    14 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes
    So this entry, most likely is your CD/DVD drive can be removed:

    Code:
    5 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | Yes     | No
    I was unable to determine what this one is for:

    Code:
    2 | PK_TMP_DIR                | PK_TMP_DIR                         | Yes     | Yes
    I should have asked for this, which would told us more:

    Code:
    zypper repos -u
    The option -u would provide the URL for each repo name. Do that update as suggest and let us know if it helped. I can say that off and on, I did have the same problem with KDE in openSUSE 12.2 and I even tried an update of KDE to the latest release, not supplied with 12.2, and it never worked properly again. I actually reloaded 12.2 and did a full upgrade as I suggested here but that was a while ago now, and the details are more clouded, but I do feel it is a KDE specific problem you are seeing in openSUSE 12.2. I can report this has not been a problem for me in openSUSE 12.3 so far. I have stuck with the distro KDE version, loading updates only for that version. I see that you have the KDE Extra repo added, though I don't know of an issue with that.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: Suddenly I can't run anything

    Code:
    #  | Alias                     | Name                               | Enabled | Refresh | URI                                                                
    ---+---------------------------+------------------------------------+---------+---------+--------------------------------------------------------------------
     1 | KDE:Extra                 | KDE:Extra                          | Yes     | Yes     | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.2/
     2 | PK_TMP_DIR                | PK_TMP_DIR                         | Yes     | Yes     | dir:///var/tmp/TmpDir.Hf9Avx                                       
     3 | VirtualBox_Oracle         | VirtualBox Oracle                  | Yes     | Yes     | http://download.virtualbox.org/virtualbox/rpm/opensuse/11.4/       
     4 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes     | Yes     | ftp://download.nvidia.com/opensuse/12.2/                           
     5 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | Yes     | No      | cd:///?devices=/dev/disk/by-id/ata-ASUS_DRW-1608P2S,/dev/sr0       
     6 | packman.inode.at-suse     | Packman Repository                 | Yes     | Yes     | http://packman.inode.at/suse/12.2/                                 
     7 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes     | http://download.opensuse.org/debug/distribution/12.2/repo/oss/     
     8 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes     | http://download.opensuse.org/debug/update/12.2/                    
     9 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes     | http://download.opensuse.org/debug/update/12.2-non-oss/            
    10 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes     | http://download.opensuse.org/distribution/12.2/repo/non-oss/       
    11 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes     | http://download.opensuse.org/distribution/12.2/repo/oss/           
    12 | repo-source               | openSUSE-12.2-Source               | No      | Yes     | http://download.opensuse.org/source/distribution/12.2/repo/oss/    
    13 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes     | http://download.opensuse.org/update/12.2/                          
    14 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes     | http://download.opensuse.org/update/12.2-non-oss/
    I disabled the CD repo and the PK_TMP_DIR wich was something from UnetBootin.
    OpenSUSE Leap 42.2 x64 KDE

  8. #8

    Default Re: Suddenly I can't run anything

    It is happening again, right now I am able to post this because Firefox was open but I just click anything else and nothing happens, I have to do a reboot.
    Is there a keyboard shortcut for opening a terminal ?
    CTRL+ESC does not work either.
    OpenSUSE Leap 42.2 x64 KDE

  9. #9

    Default Re: Suddenly I can't run anything

    On 2013-07-10, robertot5 <robertot5@no-mx.forums.opensuse.org> wrote:
    >
    > It is happening again, right now I am able to post this because Firefox
    > was open but I just click anything else and nothing happens, I have to
    > do a reboot.
    > Is there a keyboard shortcut for opening a terminal ?
    > CTRL+ESC does not work either.


    If you want terminal just to reboot use a virtual console (CTRL-ALT-F1_to_F6).

    Log in as root (and yes you can do this into a virtual console only to reboot!) and then:

    Code:
    sh-4.2$ shutdown -r now
    Good luck!


  10. #10

    Default Re: Suddenly I can't run anything

    Quote Originally Posted by robertot5 View Post
    It is happening again, right now I am able to post this because Firefox was open but I just click anything else and nothing happens, I have to do a reboot.
    Is there a keyboard shortcut for opening a terminal ?
    CTRL+ESC does not work either.
    Kind of. You could press Ctrl+Alt+F1 to get to a text console. Login there with your normal username/password.
    If you prepend "DISPLAY=:0" to an command it will try to open its window on your running Xserver.
    F.e.:
    Code:
    DISPLAY=:0 kwrite
    will start kwrite in the running KDE session.

    Just keep a konsole open all the time in case it happens again.
    Or use yakuake, this hides itself until you press the shortcut key...

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •