Results 1 to 10 of 10

Thread: System Services changes do not take

  1. #1
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default System Services changes do not take

    I have been having a puzzling thing happen to me. I can go to Yast > System Services and make changes to the services that I want to start at startup. Turning on, or off, services returns 0 (which means there was no error, at least I think it does). I leave System Services the usual way with no error. Yet, when I re-open System Services, whether I have rebooted or not, the services that had been changed, reverts back to their original settings. Does anyone have any idea(s) concerning this?
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: System Services changes do not take

    It could be that the move from sysvinit to systemd did not settle down into everything. Thus it maybe that YaST is not working properly with systemd in this aspect.

    Maybe it is better to try to find out how sysemd utilities can help you here.
    Henk van Velden

  3. #3

    Default Re: System Services changes do not take

    On 06/16/2013 04:36 PM, hcvv pecked at the keyboard and wrote:
    > It could be that the move from sysvinit to systemd did not settle down
    > into everything. Thus it maybe that YaST is not working properly with
    > systemd in this aspect.
    >
    >

    Welcome to the world of systemd where not much is yet user friendly. You
    will need to set services to start manually using the command systemctl.
    I don't use it myself because it is not yet user friendly enough for me.

  4. #4

    Default Re: System Services changes do not take

    Quote Originally Posted by kerijan2003 View Post
    I have been having a puzzling thing happen to me. I can go to Yast > System Services and make changes to the services that I want to start at startup. Turning on, or off, services returns 0 (which means there was no error, at least I think it does). I leave System Services the usual way with no error. Yet, when I re-open System Services, whether I have rebooted or not, the services that had been changed, reverts back to their original settings. Does anyone have any idea(s) concerning this?
    You are exiting the dialog with OK, right?
    Well, I can't remember how it was on 12.2, but here on 12.3 a service I disable is shown as enabled again when I re-enter System Services. But the service is actually disabled (I checked with "systemctl status apache2.service" f.e.). And enabling them doesn't work it seems.
    That only applies to services which have a systemd .service file, old sysvinit init scripts show their state correctly and can be disabled/enabled.

    You can disable/enable systemd services with "sudo systemctl enable xxx.service" or "sudo systemctl disable xxx.service".

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: System Services changes do not take

    On 2013-06-16 23:34, Ken Schneider wrote:
    > On 06/16/2013 04:36 PM, hcvv pecked at the keyboard and wrote:
    >> It could be that the move from sysvinit to systemd did not settle down
    >> into everything. Thus it maybe that YaST is not working properly with
    >> systemd in this aspect.
    >>
    >>

    > Welcome to the world of systemd where not much is yet user friendly. You
    > will need to set services to start manually using the command systemctl.
    > I don't use it myself because it is not yet user friendly enough for me.


    Absolutely, YaST is broken. Known thing.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6

    Default Re: System Services changes do not take

    Quote Originally Posted by wolfi323 View Post
    Well, I can't remember how it was on 12.2, but here on 12.3 a service I disable is shown as enabled again when I re-enter System Services. But the service is actually disabled (I checked with "systemctl status apache2.service" f.e.). And enabling them doesn't work it seems.
    That only applies to services which have a systemd .service file, old sysvinit init scripts show their state correctly and can be disabled/enabled.
    The behaviour I described seems to be this bug: https://bugzilla.novell.com/show_bug.cgi?id=808317, which should have been fixed since end of March but apparently isn't.

    But that's on 12.3. And the OP is using 12.2 according to his signature. I really can't remember if it ever worked there...

    Anyway, as I already mentioned:
    Run "sudo systemctl enable xxx.service" to enable a service.
    Run "sudo systemctl disable xxx.service" to disable a service.
    (I don't really find that "not user friendly", although it's no GUI of course... )

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: System Services changes do not take

    On 2013-06-17 11:06, wolfi323 wrote:

    > Anyway, as I already mentioned:
    > Run "sudo systemctl enable xxx.service" to enable a service.
    > Run "sudo systemctl disable xxx.service" to disable a service.
    > (I don't really find that "not user friendly", although it's no GUI of
    > course... )


    There is "systemadm", package "systemd-ui".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,484
    Blog Entries
    2

    Default Re: System Services changes do not take

    If I were to guess, you didn't set the services to start correctly.

    You cannot set system services to bootup automatically using the System Init Services Runlevels "Simple" view.
    You must click the radio button that changes to "Expert" View.
    Then,
    The button bottom left will simply start/stop/restart/refresh, but if you click <only> that button the effect will only be the current session.
    You <also> need to click the button bottom right to enable/disable the service on bootup.

    Yeah, it's a weird setup which has existed since forever and it's easy to overlook all the necessary steps to enable services to start on bootup. If I were designing, I would have grouped the buttons closer together and maybe even in a different way(eg using radio buttons instead) so that required steps might not be overlooked.

    If you know the specific systemd service, then you can also enable from command line
    Code:
    systemctl enable foobar.service
    HTH,
    TSU

  9. #9
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default Re: System Services changes do not take

    Thanks for the responses. Some of the responses assume that I may not have done something right, which isn't the case. I did what I have been doing since I've been using openSuSE (if I remember correctly, since version 11.1). Yast has never given me this problem before. Now that I am reminded of the alternative way of setting up system services, I'll be using that. I thank each and everyone who responded. It's all good stuff.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: System Services changes do not take

    On 2013-06-17 20:36, kerijan2003 wrote:
    >
    > Thanks for the responses. Some of the responses assume that I may not
    > have done something right, which isn't the case. I did what I have been
    > doing since I've been using openSuSE (if I remember correctly, since
    > version 11.1). Yast has never given me this problem before. Now that I
    > am reminded of the alternative way of setting up system services, I'll
    > be using that. I thank each and everyone who responded. It's all good
    > stuff.


    You are not doing anything wrong, it is simply known that YaST is broken
    in respect to systemd. It has not been maintained properly as fast as
    systemd has taken in, that's all.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •