Results 1 to 2 of 2

Thread: Installing different JRE and JDK's

  1. #1
    Join Date
    Jun 2013
    Location
    Philippines
    Posts
    9

    Unhappy Installing different JRE and JDK's

    Ok, as I have a project(a grails project) that really depends on the different versions of JAVA which are JAVA 6 and 7, I really need now to install them both in my linux box. So what I did earlier is to install JAVA 6(with JDK after) first, then I followed it with JAVA 7, but my problem is I can only see that Java 7 was left installed and Java 6 was overwritten. How can I install both Java 6 and Java 7 with there respective JDK's without the Java 7 overwrites the version 6?

    my OS is OpenSUSE 12.3 and I am trying to install Java 1.6 update 45(with JDK) and Java 1.7(with JDK) update 21.

    I am trying this one How To: Installing Oracle’s Java JDK 6/7 in Linux Fedora Core 17 | Manuel Jordan's Blog but I really feel that I will break my system if I follow the blog article because the Java version that the blog writer was trying to install is really old and he runs FEDORA and not OpenSuse

    this is the log shown when I am trying to install again JRE 6

    ./jre-6u45-linux-i586-rpm.bin
    Unpacking...
    Checksumming...
    Extracting...
    UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs@lists.wku.edu).
    inflating: jre-6u45-linux-i586.rpm
    Preparing... ################################# [100%]
    package jre-1.7.0_21-fcs.i586 (which is newer than jre-1.6.0_45-fcs.i586) is already installed
    file /etc/init.d/jexec from install of jre-1.6.0_45-fcs.i586 conflicts with file from package jre-1.7.0_21-fcs.i586
    file /etc/init.d/jexec from install of jre-1.6.0_45-fcs.i586 conflicts with file from package jdk-2000:1.7.0_21-fcs.i586

    Done.

  2. #2
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Installing different JRE and JDK's

    The official documentation from (what used to be Sun) Oracle says to uninstall any previous version of Java before installing the current one. To understand this, you have to understand how things work. In Windows one can install more than one version of things because of the DLLs. Basically, Windows can have many concurrent versions of the same libraries. In Linux, most programs will use existing libraries on the system. This is also why Linux users can run into dependancy hell (I have also had this happen in Windows where it depended on some other stuff to be installed so I could install program A). Now the plugin for JRE is the same file name regardless of version, so even if you did install multiple versions (which can be done), having the browser recognize the differences is beyond me. I'm sure it could be done, but I have never attempted it, and have no inclination to attempt it as it defies Sun's, now Oracles documentation. It would require some hacking. If you want, it is possible to install multiple versions at the same time, into different directories. Just don't do it with rpm. Rpm has its spec file which tells it where to install things and how.
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •