All,

- OpenSuSE 12.1 (i586)
- KDE 4.7.2


We recently just got a ZOTAC PC (comes with no OS installed) and installed OpenSuSE 12.1 on it. This PC will eventually after I'm done configuring it, be
used connected to a TV as a kiosk like device...

The PC came with a MCE Remote Control with a USB Receiver device as well. If I simply plug in the USB receiver I can instantly use some things on it
like the arrows work for Firefox, and within the terminal the arrows will scroll through the command history. As well as a few other buttons like the power
button will put the PC to sleep, and the back arrow will act as the back arrow in Firefox, etc...

So I used the irrecord command (*from the KRemoteControl package) to give every button on the remote a name/namespace and next to each button's
"name" the irrecord command writes the "code" that each button emits when pressed. I'll insert that "ircd.conf" File below...

Now, what I was trying to do was set up some custom stuff of LIRC using the KRemoteControl program which has the krcdnotifieritem. In that program's GUI
you can setup Modes for remotes and actions along with them. But after configuring the remote's "/ etc / lirc / lircd.conf" file and adding a few custom actions
for it within the krcdnotifieritemGUI, I run the following command:
Code:
lircd --device=/dev/input/ir   --driver=devinput  /etc/lirc/lircd.conf
I can then see lircd running with the ps command. But when I press the button I configured in the GUI it will still do what that button had originally done before configuring
anything...

I also tried adding the following to "my" home dir as well as root's home dir (I wasn't sure who's dir it would look in?). The following was added to a file called
".lircrc" which is where you can setup custom actions for specific buttons inside certain apps.
Code:
# I think this one "should" start Firefox..?
begin
    prog =        irexec
    remote =     ZOTAC_IR_Remote
    button =    KEY_CLEAR
    config =    firefox
end

# And I think when Firefox is running and I click the Record button it should execute the F11 key to switch to fullscreen..?
begin
        prog =     firefox
        remote =   ZOTAC_IR_Remote
        button =   KEY_RECORD
        config =   F11
end
And here is my "lircd.conf" file:
*Located at "/etc / lirc / lircd.conf"...
Code:
# Please make this file available to others
# by sending it to <lirc@bartelmus.de>
#
# this config file was automatically generated
# using lirc-0.8.7(devinput) on Tue Jun 11 15:52:01 2013
#
# Contributed By:                Me
#
# Brand:                                                             PHILIPS
# Model No. of remote control:                        RC2604323/01G
# Devices being controlled by this remote:    /dev/input/ir
#

begin remote

  name             ZOTAC_IR_Remote
  bits           56
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  pre_data_bits   8
  pre_data       0x0
  gap          32965
  toggle_bit_mask 0x0

      begin codes
          KEY_POWER                0x04000400010082 0x00000000000001
          KEY_POWER2               0x04000400010083 0x00000000000001
          KEY_DOWN                 0x04000400070051 0x00000000000001
          KEY_UP                   0x04000400070052 0x00000000000001
          KEY_LEFT                 0x04000400070050 0x00000000000001
          KEY_RIGHT                0x0400040007004F 0x00000000000001
          KEY_PAUSE                0x040004000C00B1 0x00000000000001
          KEY_PLAY                 0x040004000C00B0 0x00000000000001
          KEY_STOP                 0x040004000C00B7 0x00000000000001
          KEY_RECORD               0x040004000C00B2 0x00000000000001
          KEY_FASTFORWARD          0x040004000C00B3 0x00000000000001
          KEY_REWIND               0x040004000C00B4 0x00000000000001
          KEY_NEXT                 0x040004000C00B5 0x00000000000001
          KEY_PREVIOUS             0x040004000C00B4 0x00000000000001
          KEY_PREVIOUS             0x040004000C00B6 0x00000000000001
          KEY_BACK                 0x040004000C0224 0x00000000000001
          KEY_INFO                 0x040004000C0209 0x00000000000001
          KEY_OK                   0x04000400070028 0x00000000000001
          KEY_MUTE                 0x040004000C00E2 0x00000000000001
          KEY_VOLUMEDOWN           0x040004000C00EA 0x00000000000001
          KEY_VOLUMEUP             0x040004000C00E9 0x00000000000001
          KEY_BRIGHTNESSDOWN       0x040004000C009D 0x00000000000001
          KEY_BRIGHTNESSUP         0x040004000C009C 0x00000000000001
          KEY_1                    0x0400040007001E 0x00000000000001
          KEY_2                    0x0400040007001F 0x00000000000001
          KEY_3                    0x04000400070020 0x00000000000001
          KEY_4                    0x04000400070021 0x00000000000001
          KEY_5                    0x04000400070022 0x00000000000001
          KEY_6                    0x04000400070023 0x00000000000001
          KEY_7                    0x04000400070024 0x00000000000001
          KEY_8                    0x04000400070025 0x00000000000001
          KEY_9                    0x04000400070026 0x00000000000001
          KEY_NUMERIC_STAR         0x040004000700E1 0x00000000000001
          KEY_NUMERIC_POUND        0x040004000700E1 0x00000000000001
          KEY_CLEAR                0x04000400070029 0x00000000000001
          KEY_MENU                 0x040004000C008D 0x00000000000001
          KEY_ENTER                0x04000400070028 0x00000000000001
      end codes

end remote
**So the file above was generated by running the "irrecord" command and going through each button one at a time.

So I'm trying to figure out since nothing that I configured seems to be working at all, I'm thinking whatever it is that is controlling the remote control by default may be
getting in the way?? By "default" I mean after I installed OpenSuSE on the PC and booted up for the first time after the installation and I plugged in the IR USB Receiver
the remote was able to do some stuff.

These are the Sites I used while trying to configure the following components:
Code:
 LIRC Config:
              http://www.g-loaded.eu/2006/01/10/how-to-configure-and-use-lirc/
              http://www.lirc.org/html/configure.html
".lircrc" File:
             http://www.lirc.org/html/configure.html#lircrc_format
             http://www.mythtv.org/wiki/PVR-350_Remote_Quick_Guide#Which_lircrc
Sample Cfgs ("lircd.conf"):
             http://lirc.sourceforge.net/remotes/
If anyone has any ideas/suggestions it would be greatly appreciated..!
Also, if you need me to supply any other information just let me know. I was going to include all the hardware device infor for the USB Receiver but
I didn't want to clutter up the post more then it already is...

Thanks in Advance,
Matt