Results 1 to 4 of 4

Thread: DontZap DontVTSwitch

  1. #1

    Default DontZap DontVTSwitch

    It has been a little while since I had to try and customize anything with openSUSE. I was going though some old docs I had with 11.4 and with 12.3 it appears a lot has changed. I am trying to disable the ctrl-alt-backspace logout "feature" and also the ability to switch to a different virtual, alt + Fx.

    This is what I had before in /etc/X11/xorg.conf but it doesn't appear to work these days. Also the /etc/inittab file just has my boot runlevel value.

    Section "ServerFlags"
    Options "DontVTSwitch" "true"
    Options "DontZap" "true"
    EndSection

    I am running openSUSE 12.3 with XFCE and wondering where I can disable these at now?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: DontZap DontVTSwitch

    On 06/12/2013 05:26 PM, D8TA wrote:
    > 12.3 it appears a lot has changed.


    yep, from 11.4 to 12.3 is a LOT of substantial changes...


    > I am trying to disable the ctrl-alt-backspace logout "feature"


    open YaST [note these instructions may not be exact for your
    version--i don't have a 12.3 here to look at], go Security & Users
    (on left) > Security Center and Hardening (on right) > in the
    resultant new window pane, click to highlight "Boot Settings" (on
    left) and on the right spin the dial to set "Interpretation of Ctrl +
    Alt + Del" to be what you want.. (mine is set to "Ignore" as the
    Divinity intended)


    > and also the ability to switch to a different virtual, alt + Fx.


    that is a systemd thing, someone else will have to help you with that..

    --
    dd
    http://tinyurl.com/DD-Caveat

  3. #3

    Default Re: DontZap DontVTSwitch

    Quote Originally Posted by D8TA View Post
    It has been a little while since I had to try and customize anything with openSUSE. I was going though some old docs I had with 11.4 and with 12.3 it appears a lot has changed. I am trying to disable the ctrl-alt-backspace logout "feature" and also the ability to switch to a different virtual, alt + Fx.

    This is what I had before in /etc/X11/xorg.conf but it doesn't appear to work these days. Also the /etc/inittab file just has my boot runlevel value.

    Section "ServerFlags"
    Options "DontVTSwitch" "true"
    Options "DontZap" "true"
    EndSection

    I am running openSUSE 12.3 with XFCE and wondering where I can disable these at now?

    Thanks.
    Those options do still work. But it's spelt "Option" not "Options".

    But the preferred way nowadays is to remove /etc/X11/xorg.conf (although it is still used if available), and create a file /etc/X11/xorg.conf.d/01-serverflags.conf (the exact name doesn't really matter) with the following content:
    Code:
    Section "ServerFlags"
     Option "DontVTSwitch" "true"
     Option "DontZap" "true"
    EndSection
    /etc/inittab isn't used anymore. You can just remove it. (But it is needed for YaST->System->Runlevel Editor to work)
    The default "runlevel" (systemd calls them targets) is now set via the symlink /etc/systemd/system/default.target.
    See also: FrequentlyAskedQuestions

  4. #4

    Default Re: DontZap DontVTSwitch

    Thanks DenverD & wolfi323 working like advertised now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •