Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Kwin Crashes

  1. #1

    Default Kwin Crashes

    Today, after simply restarting my computer Kwin now crashes upon trying to re adjust my dual screen set up. When logging back into KDE my panels where black, instead of being transparent. Here's the error kwin gives me: Executable: kwin PID: 2472 Signal: Segmentation fault (11)

  2. #2

    Default Re: Kwin Crashes

    Upon further looking i found that the composting defaults to Xrender when i had it on OpenGL. Every time i close the desktop effects windows it goes back to Xrender. I i have strange suspicion that this has something to do with Compiz.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,401

    Default Re: Kwin Crashes

    Do you mind giving the primary information: which version of openSUSE?
    Henk van Velden

  4. #4

    Default Re: Kwin Crashes

    Quote Originally Posted by hcvv View Post
    Do you mind giving the primary information: which version of openSUSE?
    openSUSE 12.3 with tumbleweed repos.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwin Crashes

    On 06/07/2013 09:46 PM, bulletfreak wrote:
    > I i have strange suspicion that this has
    > something to do with Compiz.


    i don't remember, but didn't someone already tell you to forget
    compiz...it is SO old technology....afair everything that compiz
    could ever do (in the old days) KDE can do it all, and more....and,
    compiz just gets in the way.


    --
    dd

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwin Crashes

    On 06/07/2013 09:26 PM, bulletfreak wrote:
    > after simply restarting my computer


    was an update done before the reboot? (not _just_ before but anytime
    before? like, maybe you did power off reboot two weeks ago and have
    been doing a hibernate since?)

    if so there could easily have been something (the kernel maybe)
    running out of memory and then changed out with the first reboot
    after install....and, BANG if you are using a nVidia driver, or any
    other critical proprietary driver you are dead in the water until you
    .. . .

    --
    dd
    http://tinyurl.com/DD-Caveat

  7. #7

    Default Re: Kwin Crashes

    To the op, You didn't mentioned what's the kind of setup you did on your dual screen.
    If you are trying to enable xinerama it's not gonna work. If you are using twin view and
    separate X screen, kwin should work.
    People who do not break things first will never learn to create anything

  8. #8

    Default Re: Kwin Crashes

    Quote Originally Posted by DenverD View Post
    On 06/07/2013 09:46 PM, bulletfreak wrote:
    > I i have strange suspicion that this has
    > something to do with Compiz.


    i don't remember, but didn't someone already tell you to forget
    compiz...it is SO old technology....afair everything that compiz
    could ever do (in the old days) KDE can do it all, and more....and,
    compiz just gets in the way.


    --
    dd
    removed compiz. Still have the same problem.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwin Crashes

    On 06/07/2013 10:06 PM, bulletfreak wrote:
    > tumbleweed repos.


    you are in the wrong forum....post only to tumbleweed forum..

    --
    dd


  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,897
    Blog Entries
    3

    Default Re: Kwin Crashes

    Quote Originally Posted by bulletfreak View Post
    Today, after simply restarting my computer Kwin now crashes upon trying to re adjust my dual screen set up.
    I sometimes see this.

    I have seen it most often on an older computer using the radeon graphic driver. I have seen it less often with an nvidia graphics card and the nvidia driver. It has never happened on my system that uses Intel graphics.

    It mostly happens when I first login after setting up a new user, or first login after deleting "$HOME/.kde4". Once I turn off desktop effects, that usually stops it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •