Results 1 to 6 of 6

Thread: Wrong window manager on remote X !!

  1. #1

    Default Wrong window manager on remote X !!

    I have two machines running 12.3 64-bit.

    I usually interact with both of them through remote X using Xming on my Windows workstation.

    When logged into the machines locally, both show a normal Gnome 3 desktop.

    But when I remote X, one machine shows me the usual Gnome 3 looking GUI elements, whereas the other one is something more like twm or fallback, I'm not sure which. Why the hell is it doing that? And how do I fix it? It's driving me nuts!

    See screenshot for comparison:


  2. #2

    Default Re: Wrong window manager on remote X !!

    Quote Originally Posted by Prune View Post
    I have two machines running 12.3 64-bit.

    I usually interact with both of them through remote X using Xming on my Windows workstation.

    When logged into the machines locally, both show a normal Gnome 3 desktop.

    But when I remote X, one machine shows me the usual Gnome 3 looking GUI elements, whereas the other one is something more like twm or fallback, I'm not sure which. Why the hell is it doing that? And how do I fix it? It's driving me nuts!
    Since YaST runs as root, it also uses the settings for the user "root", not the ones for the normal user.
    Maybe root's theme setting is different?

    Run gnome-control-center or gnome-tweak-tool as root and try to change the theme setting.
    Code:
    gnomesu gnome-control-center
    or
    Code:
    gnomesu gnome-tweak-tool

  3. #3

    Default Re: Wrong window manager on remote X !!

    And if GNOME is running only in fallback mode, it's this bug I think:
    https://bugzilla.novell.com/show_bug.cgi?id=823625

  4. #4

    Default Re: Wrong window manager on remote X !!

    Uh, the theme selection is disabled...

    Can I just delete the whole root folder and try again? What else can I do?


  5. #5

    Default Re: Wrong window manager on remote X !!

    Quote Originally Posted by Prune View Post
    Uh, the theme selection is disabled...
    I think that's quite normal. I have that too if I start gnome-tweak-tool under KDE, but all the GUI elements appear as expected.
    The appearance of the GUI elements should be influenced by the "Gtk+ Theme" (or maybe the "Current Theme"?).
    You could try to change this and see if it makes a difference.

    Can I just delete the whole root folder and try again? What else can I do?
    If you mean /root : Yes, you can try that (as long as you don't have important files in there, of course ). Or maybe it would be better to just move all the stuff in there into another folder so it isn't found (you can move needed stuff back afterwards then). And don't forget that most of the files/folders that could cause this are hidden (they start with a '.').

    At least that would be a quick test to see if it is settings related.

    Also you could try to reinstall the packages "metatheme-adwaita-common" and "gtk3-metatheme-adwaita" (since you have "Adwaita" selected as theme). Maybe some file got broken?

  6. #6

    Default Re: Wrong window manager on remote X !!

    I reinstalled those two themes and deleted /root. Didn't fix the issue. In fact, running programs as regular user has the same problem.
    The theme works just fine when logged in locally on the machine, so it seems this is something related to remoting. What can I try next?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •